Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 354557 - x11-libs/gdk-pixbuf-2.22.*: fix libpng deprecations to be ready for libpng1.5
Summary: x11-libs/gdk-pixbuf-2.22.*: fix libpng deprecations to be ready for libpng1.5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 355871 (view as bug list)
Depends on:
Blocks: libpng-1.5 354985
  Show dependency tree
 
Reported: 2011-02-12 01:33 UTC by Rafał Mużyło
Modified: 2011-04-04 17:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Mużyło 2011-02-12 01:33:09 UTC
Patch is trivial - present in the upstream bug.
For the moment, configure.ac will need adding libpng15 in the obvious place.

Quite fortunately, once released, gtk-pixbuf 2.24.0 will move libpng to Requires.private, so the headache will be even smaller.
Comment 1 Samuli Suominen gentoo-dev 2011-02-21 17:53:25 UTC
*** Bug 355871 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2011-02-21 17:54:00 UTC
vapier's build.log with libpng 1.5.x is here:
https://bugs.gentoo.org/show_bug.cgi?id=355871
Comment 3 SpanKY gentoo-dev 2011-02-21 18:14:31 UTC
ugh, typo in summary makes it hard for searches to hit
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-04-04 17:47:51 UTC
Fixed in the tree, thanks for reporting.