Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 353906 - [ebuild request] dev-util/bustle
Summary: [ebuild request] dev-util/bustle
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo's Haskell Language team
URL: http://willthompson.co.uk/bustle/
Whiteboard:
Keywords:
Depends on: 353913
Blocks: 353155
  Show dependency tree
 
Reported: 2011-02-06 21:43 UTC by Dennis Schridde
Modified: 2011-05-09 21:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Sketchup of an ebuild (bustle-0.2.3.ebuild,484 bytes, text/plain)
2011-02-06 21:44 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2011-02-06 21:43:36 UTC
I'd like to have an ebuild for Bustle, since it is required as a dependency for dev-util/dbus-test-runner[test] (bug #353155).

I already constructed the generic parts of an ebuild, but since I have no idea about Haskell and its build process, I think I better leave that to more experienced people.

Reproducible: Always
Comment 1 Dennis Schridde 2011-02-06 21:44:23 UTC
Created attachment 261684 [details]
Sketchup of an ebuild
Comment 2 Lennart Kolmodin (RETIRED) gentoo-dev 2011-02-07 00:03:43 UTC
Wow, looks like a really cool project.

In order to add bustle to the portage tree we must first update the gtk2hs project. As of today we still only provide 0.9.12.1 which unfortunately is outdated.

The new gtk2hs project was split up into several smaller packages. We've got them in the overlay, but it has not yet been copied into the portage tree.

I corrected the provided ebuild a bit, it's available through the haskell overlay.
https://github.com/gentoo-haskell/gentoo-haskell/tree/master/dev-util/bustle
Comment 3 Dennis Schridde 2011-02-07 08:21:32 UTC
(In reply to comment #2)
> In order to add bustle to the portage tree we must first update the gtk2hs
> project. As of today we still only provide 0.9.12.1 which unfortunately is
> outdated.
Correct me if I am wrong, but 0.10.1 is in Gentoo: http://packages.gentoo.org/package/dev-haskell/gtk2hs

Or is that also not matching the requirements of bustle?
Comment 4 Dennis Schridde 2011-02-07 08:30:27 UTC
I think you got the LICENSE= wrong. The only file that is GPL-2 is the C file, all others I found are LGPL-2.1. Or is the policy to use the most restrictive of licenses?

As for gtk2hs: The cabal file allows installation for 0.10, too. But I assume the package will not compile when using that?
Comment 5 Sergei Trofimovich gentoo-dev 2011-05-09 21:20:38 UTC
Lennart fixed license to 'LICENSE="LGPL-2 GPL-2"'.
Pushed to the tree as:

> *bustle-0.2.3 (09 May 2011)
> 
>   09 May 2011; Sergei Trofimovich <slyfox@gentoo.org>
>   +files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch,
>   +bustle-0.2.3.ebuild, +metadata.xml:
>   Initial version. Draw pretty sequence diagrams of D-Bus traffic. Ebuild
>   provided by Dennis Schridde bug #353906.

Dennis, thanks for the ebuild and a link to the great software!