Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 353440 - Stabilize =net-misc/connman-0.75
Summary: Stabilize =net-misc/connman-0.75
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Robert Piasek (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 384733 386121 386139 387065
Blocks:
  Show dependency tree
 
Reported: 2011-02-01 19:58 UTC by Pacho Ramos
Modified: 2012-01-06 20:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2011-02-01 19:58:27 UTC
Would be interesting to get a version stabilized as it will be needed for getting evolution-2.32 stabilized

Reproducible: Always
Comment 1 Robert Piasek (RETIRED) gentoo-dev 2011-02-06 23:54:44 UTC
Hi,

To be honest connman development is moving so fast and every new version brings new features. That's why I remove old version as quick as new ones appear.

If you want to stabilise it, the best candidate would be 67-r1.
Comment 2 Pacho Ramos gentoo-dev 2011-02-07 08:54:17 UTC
Other option could be to use.mask connman evolution USE flag for not needing to stabilize it just now, do you think would it be a better option?
Comment 3 Robert Piasek (RETIRED) gentoo-dev 2011-02-08 13:20:27 UTC
Personally I believe connman and ofono should stay away from stable for now. If you want to stabilise something which depends on it, I would suggest using use.mask.

Comment 4 Pacho Ramos gentoo-dev 2011-02-08 17:12:57 UTC
OK, we will then stabilize an evolution version not requiring this
Comment 5 David J Cozatt 2011-04-05 20:22:13 UTC
AFAICT ;-)

connman up to version 0.68 retains some compatibility with 'wireless-tools' ie iwconfig

after which you need the newer wireless 'iw crda wireless-regdb' which is what I have though
unsuccessful with both ath9k_ht and p54pci connecting with connman to version 0.72 

and the correct kernel version of course. As for eth0 or bridging and connman haven't bothered to try yet since I don't need something like this for eth0 support ;-)

Looks like 0.72 and 0.68 should be stable targets

----snip--------------------
Message: 4
Date: Tue, 5 Apr 2011 16:33:07 +0200
From: Samuel Ortiz <deleted>
To: connman dev list <deleted>
Subject: ANNOUNCE: ConnMan 0.72
Message-ID: <deleted>
Content-Type: text/plain; charset=us-ascii

Hi All,

ConnMan 0.72 was released on March 30th, 2011.

We decided to cut this one since we were about to introduce the initial
session API implementation. As a consequence, this was a fairly quiet one.

The main 0.72 feature is our 6to4 experimental support, which tries to open a
6to4 tunnel whenever our IPv6 settings are set to auto while not getting any
RAs. Thanks to Jukka Rissanen for that.

We also got several memory leak fixes from Daniel Wagner, an oFono plugin fix
from Mohamed Abbas, a DHCP one from Lucas De Marchi (ProFUSION). We also made
our core DHCP code a bit smarter by comparing old and new IP settings when
getting a DHCP renewal.

You can fetch signed tarballs for ConnMan 0.72 [1] [2], but you can also get
the latest code from our git tree [3].

Cheers,
Samuel.

-------------/snip-----------
Comment 6 Pacho Ramos gentoo-dev 2011-06-12 12:11:53 UTC
Is any connman version ready to be stabilized?
Comment 7 Pacho Ramos gentoo-dev 2011-06-25 15:33:31 UTC
(In reply to comment #6)
> Is any connman version ready to be stabilized?

ping
Comment 8 Pacho Ramos gentoo-dev 2011-06-26 16:32:40 UTC
As talked with Nirbheek, we will skip this for now again, but this will probably hit us again in the future ;)
Comment 9 Pacho Ramos gentoo-dev 2011-10-05 08:50:20 UTC
Well, you know, the same as always ;)
Comment 10 Samuli Suominen gentoo-dev 2011-10-07 15:58:45 UTC
No previous stable, no risk of introducing an regression -> CC amd64 x86
Comment 11 Agostino Sarubbo gentoo-dev 2011-10-07 18:12:58 UTC
(In reply to comment #10)
> No previous stable, no risk of introducing an regression -> CC amd64 x86

It requires net-misc/ofono, same maintainer, please choise the version and edit the summary.
Comment 12 Ian Delaney (RETIRED) gentoo-dev 2011-10-07 19:32:17 UTC
amd64:

and more; needs more dep packages including header files.

one found is =net-wireless/wimax-tools-1.4.5 ~amd64
Comment 13 Agostino Sarubbo gentoo-dev 2011-10-07 20:00:28 UTC
(In reply to comment #12)
> amd64:
> 
> and more; needs more dep packages including header files.
> 
> one found is =net-wireless/wimax-tools-1.4.5 ~amd64

Looks other bugs on depends on.
Comment 14 Samuli Suominen gentoo-dev 2011-10-08 14:19:06 UTC
With bug 386139 it became clear we can't stabilize 0.75 yet because it needs linux-headers from bug 384733.
Comment 15 Samuli Suominen gentoo-dev 2011-10-08 14:20:50 UTC
Let's try 0.73 instead? And if that is a no-go, then this will have to wait again.
Comment 16 Samuli Suominen gentoo-dev 2011-10-08 14:24:01 UTC
And 0.73 is useless with our current stable iptables. Removing amd64/x86 from CC. Can't stabilize connman.
Comment 17 Samuli Suominen gentoo-dev 2011-10-13 18:22:17 UTC
amd64/x86:  Please test & stabilize this package after bug 384733 where you are in CC list now too.
Comment 18 Ian Delaney (RETIRED) gentoo-dev 2011-10-13 20:30:44 UTC
amd64

see bug #387065
Comment 19 Agostino Sarubbo gentoo-dev 2011-12-15 19:53:02 UTC
CC back amd64 when the bugs on "Depends On" are fixed.
Comment 20 Tony Vroon gentoo-dev 2011-12-25 12:44:05 UTC
I will ask for fast-track of 0.78 instead. Thank you.