Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 35279 - PythonMagick-0.5.ebuild (New Package)
Summary: PythonMagick-0.5.ebuild (New Package)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Gentoo Graphics Project
: 87552 (view as bug list)
Depends on: 35718
  Show dependency tree
Reported: 2003-12-07 12:15 UTC by Chris Mayo
Modified: 2005-04-05 10:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

PythonMagick-0.5.ebuild (New Package) ebuild (pythonmagick-0.5.ebuild,1.37 KB, text/plain)
2003-12-07 12:17 UTC, Chris Mayo
pythonmagick-0.5 ebuild - second attempt (pythonmagick-0.5.ebuild,1.07 KB, text/plain)
2003-12-13 04:29 UTC, Chris Mayo
Modified Jamfile from distribution to build outside boost tree (Jamfile,5.65 KB, text/plain)
2003-12-13 04:30 UTC, Chris Mayo
boost-build.jam to allow build outside boost tree (boost-build.jam,121 bytes, text/plain)
2003-12-13 04:33 UTC, Chris Mayo
pythonmagick-0.5-r1.ebuild (pythonmagick-0.5-r1.ebuild,1.00 KB, text/plain)
2004-03-13 13:14 UTC, Chris Mayo
Modified Jamfile (Jamfile,5.58 KB, text/plain)
2004-03-13 13:15 UTC, Chris Mayo
Jamrules (Jamrules,61 bytes, text/plain)
2004-03-13 13:16 UTC, Chris Mayo
boost-build.jam (boost-build.jam,76 bytes, text/plain)
2004-03-13 13:16 UTC, Chris Mayo
boost-jam-3.1.9.ebuild (boost-jam-3.1.9.ebuild,590 bytes, text/plain)
2004-03-13 13:18 UTC, Chris Mayo
pythonmagick development ebuild (pythonmagick-0.6_alpha.ebuild,987 bytes, text/plain)
2005-04-04 12:26 UTC, Chris Mayo

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Mayo 2003-12-07 12:15:50 UTC
As mentioned in bug 35278, attached is an ebuild for PythonMagick the Python module for GraphicsMagick (

At the moment this ebuild is hardcoded against GraphicsMagick-1.0.4 and Boost-1.30.2 because of the requirements for unpacking files in the correct location and making/installing. Some suggestions on making this more dynamic would be great!

Although it is possible to just 'emerge pythonmagick' I have then had problems if the perl module is compiled with USE='perl' emerge graphicsmagick. Running emerge graphicsmagick again cures this.

Comment 1 Chris Mayo 2003-12-07 12:17:26 UTC
Created attachment 21828 [details]
PythonMagick-0.5.ebuild (New Package) ebuild

I suggest dev-python for this ebuild.
Comment 2 Chris Mayo 2003-12-13 04:29:03 UTC
Created attachment 22132 [details]
pythonmagick-0.5 ebuild - second attempt

This version builds outside of the boost tree (i.e. doesn't unpack the boost
source just to compile this one). Also means it doesn't reinstall

Problems with emerge pythonmagick without graphicsmagick being installed now
seem to be solved.

Does need the additional files Jamfile and boost-build.jam (see subsequent
Comment 3 Chris Mayo 2003-12-13 04:30:34 UTC
Created attachment 22133 [details]
Modified Jamfile from distribution to build outside boost tree
Comment 4 Chris Mayo 2003-12-13 04:33:01 UTC
Created attachment 22134 [details]
boost-build.jam to allow build outside boost tree

Building outside the tree depends on boost-1.30.2-r1.ebuild submitted as bug
Comment 5 Chris Mayo 2004-03-13 13:14:28 UTC
Created attachment 27305 [details]

To build with Boost-1.31 need boost-jam-3.1.9, also attached.
Comment 6 Chris Mayo 2004-03-13 13:15:13 UTC
Created attachment 27306 [details]
Modified Jamfile
Comment 7 Chris Mayo 2004-03-13 13:16:20 UTC
Created attachment 27307 [details]
Comment 8 Chris Mayo 2004-03-13 13:16:39 UTC
Created attachment 27308 [details]
Comment 9 Chris Mayo 2004-03-13 13:18:17 UTC
Created attachment 27310 [details]

Just a renamed boost-jam-3.1.4.ebuild
Comment 10 Chris Mayo 2004-03-13 13:19:00 UTC
Comment on attachment 27305 [details]

Update for GraphicsMagick-1.05 and Boost-1.31 (Python 2.3)
Comment 11 Bryan Østergaard (RETIRED) gentoo-dev 2004-06-05 15:45:15 UTC
Added to portage, thanks for the ebuild.
Comment 12 Shane Hathaway 2004-09-10 10:34:44 UTC
Please reopen this bug.  Chris Mayo supplied three files that need to be in dev-python/pythonmagick/files for this ebuild to work.  Please include Jamfile, Jamrules, and boost-build.jam in the portage tree.  (Note that in the future, Gentoo probably ought to maintain a patch to Jamfile rather than replace it wholesale, however.)
Comment 13 Clemens Fruhwirth 2005-03-09 02:33:21 UTC
I second the last posters comment. This bug is NOT resolved. The files attached to this bug are missing from the files directory.
Comment 14 Fernando Serboncini (RETIRED) gentoo-dev 2005-04-02 09:18:18 UTC
I've added the missing files to the ebuild. 
Can you guys check that this ebuild is correctly working? 
Btw, the new pythonmagic 0.7 source code isn't available anymore from upstream page.
Comment 15 Fernando Serboncini (RETIRED) gentoo-dev 2005-04-02 09:24:49 UTC
*** Bug 87552 has been marked as a duplicate of this bug. ***
Comment 16 Chris Mayo 2005-04-04 12:26:43 UTC
Created attachment 55296 [details]
pythonmagick development ebuild

The files are fine - pythonmagick compiles and installs. But I now get errors

File "/usr/lib/python2.3/site-packages/PythonMagick/", line 1, in ?
    import _PythonMagick
ImportError: cannot open shared object file: No such
file or directory

Whenever I run a program using it. I think it's something to do with upgrading
from GraphicsMagick 1.0 to 1.1. Even if you downgrade GraphicsMagick and
recompile PythonMagick it is then looking for the other version of the file,

0.7 doesn't really exist they are just Windows binaries of the latest
development. Attached is a rough ebuild that grabs the latest source from the
subversion repository - I don't think there have been updates for a while. But
I get the same problem as above when I try and run programs using it.
Comment 17 Chris Mayo 2005-04-05 10:45:10 UTC
Some more emerging and the missing library problems have gone away.

(I am using graphicsmagick-1.0.6 (PythonMagick was developed against 1.0, not sure what the effect of using 1.1 is) and:

N.B. now that I can get it to run again I found a new bug that stops text annotation from working #88058.