Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 352335 - Stabilize sys-kernel/linux-headers-2.6.36.1
Summary: Stabilize sys-kernel/linux-headers-2.6.36.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 353448
Blocks: CVE-2011-0495 CVE-2010-3389
  Show dependency tree
 
Reported: 2011-01-21 12:50 UTC by Dane Smith (RETIRED)
Modified: 2011-07-20 06:22 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dane Smith (RETIRED) gentoo-dev 2011-01-21 12:50:41 UTC
Just getting the bug report open. Not sure which version to go with. Ssuominen, you mentioned issues with >=2.6.36? What were they?

Please note this is blocking security bug 352059.
Comment 1 Samuli Suominen gentoo-dev 2011-01-21 13:37:06 UTC
2.6.36 compability is fixed in tree for =sys-power/upower-0.9.7 and =sys-fs/udisks-1.0.2. current stables are broken.
note that these need glib-2.26, for which we don't even have stablereq bug yet, so I haven't opened one for udisks and upower either. you'll need to talk to gnome@ herd to get glib stablereq bug...
Comment 2 Christian Faulhammer (RETIRED) gentoo-dev 2011-01-26 09:41:47 UTC
(In reply to comment #1)
> 2.6.36 compability is fixed in tree for =sys-power/upower-0.9.7 and
> =sys-fs/udisks-1.0.2. current stables are broken.
> note that these need glib-2.26, for which we don't even have stablereq bug yet,
> so I haven't opened one for udisks and upower either. you'll need to talk to
> gnome@ herd to get glib stablereq bug...

 Samuli, will you coordinate those efforts as you seem to be into this matter?
Comment 3 Christian Faulhammer (RETIRED) gentoo-dev 2011-01-29 16:22:14 UTC
(In reply to comment #1)
> 2.6.36 compability is fixed in tree for =sys-power/upower-0.9.7 and
> =sys-fs/udisks-1.0.2. current stables are broken.
> note that these need glib-2.26, for which we don't even have stablereq bug yet,
> so I haven't opened one for udisks and upower either. you'll need to talk to
> gnome@ herd to get glib stablereq bug...

 Gnome, please advise, this is rather urgent as we have a security bug being blocked by this one.
Comment 4 Pacho Ramos gentoo-dev 2011-01-29 16:57:09 UTC
Cannot the fix be backported to upower-0.9.5?
Comment 5 Samuli Suominen gentoo-dev 2011-01-29 17:13:05 UTC
(In reply to comment #4)
> Cannot the fix be backported to upower-0.9.5?
> 

Caving in.  Backported the compile fixes to both udisks and upower.  Unfortunately udisks-1.0.1 will still likely segfault (you'll see it in dmesg in certain situations) and I'm not sure exactly what commit in upstream fixed that.

So if you're fine with that... I suggest to at least test udisks from nautilus/thunar/pcmanfm before stabilizing.
Comment 6 Pacho Ramos gentoo-dev 2011-01-29 17:17:01 UTC
Well, Gnome 2.32 shouldn't take too much time (I am using it since started to land tree and works fine), but still need to wait for upgrade guide (bug #352218) and would be better to know a bit more about bug #348253
Comment 7 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-02-03 17:31:00 UTC
We should stabilize a more recent sys-libs/libcap-ng too.
Comment 8 Christian Faulhammer (RETIRED) gentoo-dev 2011-02-06 10:17:02 UTC
Can we push about this issue please?  Unfortunately I cannot help on the Gnome side.
Comment 9 Pacho Ramos gentoo-dev 2011-02-06 11:12:19 UTC
(In reply to comment #8)
> Can we push about this issue please?  Unfortunately I cannot help on the Gnome
> side.
> 

As people suffering that gnome-panel crash issue are a bit quiet, you could know refer to bug 353436 to see Gnome 2.32 stabilization progress, that is currently waiting for its depending bugs that are other stabilization requests
Comment 10 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-02-08 09:25:20 UTC
(In reply to comment #1)
> 2.6.36 compability is fixed in tree for =sys-power/upower-0.9.7 and
> =sys-fs/udisks-1.0.2. current stables are broken.

Okay, so should we file stablereq bugs for them? If not, what's the right course of action? I'm fine with being blocked on known issues, but waiting for an unspecified event to happen is even worse.

> note that these need glib-2.26, for which we don't even have stablereq bug yet,
> so I haven't opened one for udisks and upower either. you'll need to talk to
> gnome@ herd to get glib stablereq bug...

There is bug #339223 to track that. Could you suggest what should we do with that?
Comment 11 Pacho Ramos gentoo-dev 2011-02-08 09:42:52 UTC
If the fixes cannot be backported to older upower versions (comment #5) this depends on bug 353436
Comment 12 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-02-08 14:59:35 UTC
(In reply to comment #11)
> If the fixes cannot be backported to older upower versions (comment #5) this
> depends on bug 353436

Freedesktop herd maintainers, could you advise on the above? This is blocking a security bug.
Comment 13 Samuli Suominen gentoo-dev 2011-02-08 15:31:01 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > If the fixes cannot be backported to older upower versions (comment #5) this
> > depends on bug 353436
> 
> Freedesktop herd maintainers, could you advise on the above? This is blocking a
> security bug.
> 

I already told in Comment #5 the fixes are already backported... 9 days ago...

Comment 14 Pacho Ramos gentoo-dev 2011-02-08 17:30:21 UTC
Sorry, I misunderstood your comment
Comment 15 Jeremy Murphy 2011-02-12 04:07:40 UTC
Tested on x86: dependants build and run fine, looks OK.
Comment 16 Myckel Habets 2011-02-13 15:23:32 UTC
(In reply to comment #15)
> Tested on x86: dependants build and run fine, looks OK.
> 

+1
Comment 17 blain 'Doc' Anderson 2011-02-14 17:10:06 UTC
amd64 compiled fine

emerge --info
Portage 2.1.9.25 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-AMD_Phenom-tm-_9650_Quad-Core_Processor-with-gentoo-1.12.14
Timestamp of tree: Sat, 12 Feb 2011 16:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles fixpackages multilib-strict news parallel-fetch protect-owned sandbox sfperms split-log strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.lagis.at/ ftp://ftp.ing.umu.se/linux/gentoo/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl amd64 apache2 berkdb bzip2 cairo cli cracklib crypt cups cxx dbus device-mapper dri extras ffmpeg fortran gdbm gdu gpm gt3support gtk iconv ipv6 kde melt mmx mng modules mudflap multilib mysql ncurses nls nptl nptlonly opengl openmp pam pcre perl png policykit pppd python qt3support qt4 readline sdl session sql sqlite sse sse2 ssl svg sysfs tcpd threads unicode vorbis webkit xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 18 Thomas Kahle (RETIRED) gentoo-dev 2011-02-15 16:54:39 UTC
x86 stable. Thanks Jeremy and Myckel.
Comment 19 Agostino Sarubbo gentoo-dev 2011-02-16 10:51:03 UTC
works on amd64
Comment 20 Markos Chandras (RETIRED) gentoo-dev 2011-02-16 22:23:13 UTC
amd64 done. Thank you guys
Comment 21 Alex Buell 2011-02-18 12:03:20 UTC
Tested OK on SPARC, glibc rebuild afterwards was OK. 
Comment 22 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2011-02-19 10:03:45 UTC
ppc/ppc64 stable
Comment 23 Markus Meier gentoo-dev 2011-03-13 20:35:39 UTC
arm stable
Comment 24 Raúl Porcel (RETIRED) gentoo-dev 2011-04-02 11:23:24 UTC
alpha/ia64/m68k/s390/sh/sparc stable
Comment 25 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-04 22:46:01 UTC
Stable for HPPA.