Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 352234 - [gnome-overlay] gnome-base/nautilus-2.91.7 failed on compile
Summary: [gnome-overlay] gnome-base/nautilus-2.91.7 failed on compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3
  Show dependency tree
 
Reported: 2011-01-20 13:44 UTC by tman
Modified: 2012-02-12 14:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/gnome-base/nautilus-2.91.7/temp/automake.out (automake.out,1.46 KB, text/plain)
2011-01-21 14:19 UTC, tman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2011-01-20 13:44:27 UTC
* Package:    gnome-base/nautilus-2.91.7
 * Repository: gnome
 * USE:        amd64 elibc_glibc exif gnome kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
 * Fixing OMF Makefiles ...
 [ ok ]
 * Running elibtoolize in: nautilus-2.91.7/
 *   Applying portage-1.2.0.patch ...
 *   Applying sed-1.5.6.patch ...
 *   Applying as-needed-2.2.6.patch ...
 * Applying nautilus-2.91.7-missing-conditional.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/gnome-base/nautilus-2.91.7/work/nautilus-2.91.7' ...
 * Running aclocal -I m4 ...
 [ ok ]
 * Running libtoolize --copy --force --install --automake ...
 [ ok ]
 * Running aclocal -I m4 ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy ...
 [ !! ]

 * Failed Running automake !
 *  
 * Include in your bugreport the contents of:
 *  
 *   /var/tmp/portage/gnome-base/nautilus-2.91.7/temp/automake.out

 * ERROR: gnome-base/nautilus-2.91.7 failed:
 *   Failed Running automake !
 *  
 * Call stack:
 *     ebuild.sh, line   56:  Called src_prepare
 *   environment, line 3311:  Called eautoreconf
 *   environment, line 1035:  Called eautomake
 *   environment, line 1004:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 *   environment, line  502:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  
 * If you need support, post the output of 'emerge --info =gnome-base/nautilus-2.91.7',
 * the complete build log and the output of 'emerge -pqv =gnome-base/nautilus-2.91.7'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/portage/local/layman/gnome/eclass/gnome2.eclass
 *   /usr/portage/local/layman/gnome/eclass/gnome2-utils.eclass
 * This ebuild is from a repository named 'gnome'
 * The complete build log is located at '/var/log/portage/gnome-base:nautilus-2.91.7:20110120-133746.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/nautilus-2.91.7/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/nautilus-2.91.7/work/nautilus-2.91.7'


Reproducible: Always

Steps to Reproduce:
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-01-21 12:58:53 UTC
 * Include in your bugreport the contents of:
 *  
 *   /var/tmp/portage/gnome-base/nautilus-2.91.7/temp/automake.out


please do so.
Comment 2 tman 2011-01-21 14:19:03 UTC
Created attachment 260435 [details]
/var/tmp/portage/gnome-base/nautilus-2.91.7/temp/automake.out
Comment 3 tman 2011-01-21 14:20:41 UTC
info in attachement
Comment 4 Gilles Dartiguelongue gentoo-dev 2011-01-21 14:48:15 UTC
looks like this package is not shipping introspection.m4...
Comment 5 Gunnar Steiniger 2011-02-03 18:40:56 UTC
same problem with version 2.91.8 from the overlay
Comment 6 Nicolas 2011-04-09 01:30:36 UTC
Same problem too with 3.0.8 from gnome overlay. It's a new install, with other pc it work fine :/. It's happend with others like the new gnome-terminal, always the same thing.
Comment 7 Nicolas 2011-04-09 01:35:23 UTC
(In reply to comment #6)
> Same problem too with 3.0.8 from gnome overlay. It's a new install, with other
> pc it work fine :/. It's happend with others like the new gnome-terminal,
> always the same thing.

3.0.0 sorry xD
Comment 8 Nicolas 2011-04-09 01:57:24 UTC
Emerge nautilus with the flag introspection solve the problem here.
Comment 9 Gilles Dartiguelongue gentoo-dev 2011-04-14 12:15:54 UTC
Current nautilus-3 ebuild does not run eautoreconf. Closing.