Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 352221 - [gnome-overlay] Document how to set the default session to gnome-fallback
Summary: [gnome-overlay] Document how to set the default session to gnome-fallback
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal with 2 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3 gnome3-upgrade-guide
  Show dependency tree
 
Reported: 2011-01-20 10:55 UTC by Priit Laes (IRC: plaes)
Modified: 2012-02-12 14:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2011-01-20 10:55:11 UTC
Currently users using gdm do not have option to choose classic Gnome session from the list of sessions (since 2.91, default gnome-session launches gnome-shell+mutter).
Comment 1 Priit Laes (IRC: plaes) 2011-02-02 14:44:22 UTC
Session name is called gnome-fallback now.
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-02-20 19:54:42 UTC
Upstream doesn't want this, since it's a fallback session and is automatically run if gnome-shell cannot be run. I'm not sure if we want to include this.
Comment 3 Pacho Ramos gentoo-dev 2011-02-21 08:54:33 UTC
I really want it :-P

(I am a bit tired of some upstream guys wanting to "force" people to use what they want...)
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-02-26 03:16:14 UTC
(In reply to comment #3)
> I really want it :-P
> 
> (I am a bit tired of some upstream guys wanting to "force" people to use what
> they want...)
> 

There's currently a setting to always run the fallback session:

Control Center > System Info > Graphics > Forced Fallback Mode

Also, don't expect fallback mode to be GNOME 2; it really isn't. It's literally a fallback from GNOME Shell. This is also why we'll be keeping GNOME 2 around for at least a year.
Comment 5 Pacho Ramos gentoo-dev 2011-02-26 11:21:03 UTC
Well, I expect it to be a way of running Gnome3 without 3D acceleration (or a really poor and unstable one, that is the case) ;-)

For that I would prefer to be able to choose it before login in anyway 
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-02-27 05:16:05 UTC
(In reply to comment #5)
> Well, I expect it to be a way of running Gnome3 without 3D acceleration (or a
> really poor and unstable one, that is the case) ;-)
> 
> For that I would prefer to be able to choose it before login in anyway 
> 

It seems I forgot to mention that there is a helper utility to check if 3D acceleration is present and usable. What you want should already work automatically.
Comment 7 Pacho Ramos gentoo-dev 2011-02-27 09:40:53 UTC
The problem is that 3D support in ATI 9200 looks to work (I mean, glxgears "runs" even slow, some basic games like etracer works but it tends to make X crash, specially at logout, also make sometimes to get consoles lost...). 

Maybe other option would be to document in out Gnome 3 upgrade guide about how to set "Forced Fallback Mode" for all users from command line with the gconftool-2 replacement (if possible). 
Comment 8 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-03-14 19:52:43 UTC
Changing summary to reflect the current status:

* We won't be providing a separate session called gnome-fallback
* gnome-session automatically detects if your drivers/hardware is sufficient to run gnome-shell and falls back to gnome-fallback if required
* Users can force the fallback session to always be used by either:

System Settings > System Info > Graphics > Forced Fallback Mode

or

gsettings set org.gnome.desktop.session session-name gnome-fallback

We need to document this so that people can change to fallback mode from the console in corner cases of broken drivers, etc.
Comment 9 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-24 22:06:27 UTC
Documented in http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-3.2-upgrade.xml