Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 351644 - sys-fs/udisks-glue should install service script and config
Summary: sys-fs/udisks-glue should install service script and config
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Samuli Suominen
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-14 12:21 UTC by Lucian Muresan
Modified: 2011-01-18 18:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config file (udisks-glue.conf,1.14 KB, text/plain)
2011-01-14 12:23 UTC, Lucian Muresan
Details
gentoo script (udisks-glue,814 bytes, text/plain)
2011-01-14 12:25 UTC, Lucian Muresan
Details
updated ebuild (udisks-glue-1.2.0.ebuild,1.32 KB, text/plain)
2011-01-14 12:26 UTC, Lucian Muresan
Details
config file (udisks-glue.conf,1.52 KB, text/plain)
2011-01-15 02:03 UTC, Lucian Muresan
Details
uodated ebuild with pmount USE & dependency (udisks-glue-1.2.0.ebuild,1.38 KB, text/plain)
2011-01-15 02:05 UTC, Lucian Muresan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lucian Muresan 2011-01-14 12:21:45 UTC
sys-fs/udisks-glue may be a nice automounter for users who already removed hal / halevt from their systems and are using either just console, or window managers without automount capabilities / utilities (such as for a HTPC with stripped down X-bloat for example, with fluxbox at most). But well, the current ebuild of udisks-glue comes without a gentoo service script and also without a sample configuration file (which should actually provided by upstream).

I created such a config file based on the example from the man page, and also a gentoo script and corresponding modified ebuild, others may find this useful, too.

Reproducible: Always
Comment 1 Lucian Muresan 2011-01-14 12:23:32 UTC
Created attachment 259798 [details]
config file

just a quick shot from the man page
Comment 2 Lucian Muresan 2011-01-14 12:25:14 UTC
Created attachment 259800 [details]
gentoo script

tried to write it with start-stop-daemon calls, but did not manage to get it running because of misbehavior of udisks-glue's pidfile option
Comment 3 Lucian Muresan 2011-01-14 12:26:44 UTC
Created attachment 259802 [details]
updated ebuild

also displays some info after installation, to inform the user about the service script which can be added to the default runlevel
Comment 4 Lucian Muresan 2011-01-15 02:03:40 UTC
Created attachment 259901 [details]
config file

mounting with the pmount utility instead of udisks seems to work better
Comment 5 Lucian Muresan 2011-01-15 02:05:02 UTC
Created attachment 259903 [details]
uodated ebuild with pmount USE & dependency

mounting with the pmount seems to work better, therefore optional pmount runtime dependency
Comment 6 Samuli Suominen gentoo-dev 2011-01-18 18:39:44 UTC
I don't use udisks-glue in this way and have no plans in maintaining this in Portage, sorry.  Thanks for the time to put these here though.
All you need is "man udisks-glue" to make your own configuration choices (as you apparently did :-). I'm not looking to make udisks-glue out-of-box experience, for that we have apps like sys-fs/udiskie.