Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 350397 - gnome-base/gnome-panel-2.32.1: compile failure: ImportError import libxml2 ImportError: No module named libxml2
Summary: gnome-base/gnome-panel-2.32.1: compile failure: ImportError import libxml2...
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-02 18:59 UTC by Luca Passaretta
Modified: 2011-01-03 22:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Passaretta 2011-01-02 18:59:20 UTC
gnome-base/gnome-panel-2.32.1: compile failure: ImportError    import libxml2 ImportError: No module named libxml2 : No module named libxml2


Reproducible: Always

Steps to Reproduce:
1. revdep-rebuild
2. emerge gnome-panel

Actual Results:  
gnome-panel-2.32.1 do not compile

Expected Results:  
revdep rebuild is stopped by gnome-panel

emerge --info
Portage 2.1.9.25 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.5, glibc-2.12.1-r3, 2.6.35-zen2-lafamiglia x86_64)
=================================================================
System uname: Linux-2.6.35-zen2-lafamiglia-x86_64-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 19 Dec 2010 14:00:21 +0000
ccache version 3.1.3 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/ccache:     3.1.3
dev-util/cmake:      2.8.3
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages metadata-transfer news nodoc noinfo parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,-z,now"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X a52 aac accessibility acpi alsa amd64 applet archive autoreplace bash-completion berkdb bluetooth branding bzip2 cairo ccache cdda cddax cddb cdio cdr cdrom cdsound cleartype cli cmake consolekit cpudetection cracklib crypt css cups cxx dbus device-mapper dhcpcd disk-partition dri dts dv dvb dvd dvdr eds emerald encode eselect evo exif extras fat ffmpeg firefox flac ftp fuse gd gdbm gdm gdu gecko gif git glib glibc-omitfp glitz glut gmail gmp gnome gnome-keyring gnutls google-gadgets gpm graphite gs gstreamer gtk gzip hal iconv inotify ipc java java6 javascript jpeg jpeg2k lame lcdfilter lcms ldap libedit libnotify lm_sensors lzma lzo mad mikmod mime mmx mng modules mp3 mp4 mpeg msn mudflap multilib musicbrainz mysql mysqli nautilus ncurses networkmanager nls nowlistening nptl nptlonly ntfs ogg opengl openmp optimization pam pango pcre pdf perl pidgin plasma player png policykit ppds python python3 rar readline ruby sdl session smp spell sql sqlite sqlite3 sse sse2 ssl startup-notification strong-optimization subversion svg sysfs tcpd threads threadsafe thumbnail tiff truetype twitter udev unicode urandom usb vcd vcdinfo vcdx video vorbis vpx wav wavpack webkit x264 xcb xfs xml xmlrpc xorg xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

__________________________________________________
COMPILE FAILURE:  
GEN    org.gnome.panel.NotificationAreaApplet.panel-applet
Found cached translation database
Merging translations into org.gnome.panel.NotificationAreaApplet.panel-applet.
  CCLD   libnotification-area-applet.la
  CCLD   testtray
make[4]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets/notification_area'
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets/notification_area'
Making all in wncklet
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets/wncklet'
  CC     libwnck_applet_la-window-menu.lo
  CC     libwnck_applet_la-wncklet.lo
  CC     libwnck_applet_la-window-list.lo
  CC     libwnck_applet_la-workspace-switcher.lo
  CC     libwnck_applet_la-showdesktop.lo
  GEN    org.gnome.panel.Wncklet.panel-applet.in
LC_ALL=C /usr/bin/intltool-merge -s -u -c ../../po/.intltool-merge-cache ../../po workspace-switcher.schemas.in workspace-switcher.schemas
Found cached translation database
Merging translations into workspace-switcher.schemas.
LC_ALL=C /usr/bin/intltool-merge -s -u -c ../../po/.intltool-merge-cache ../../po window-list.schemas.in window-list.schemas
Found cached translation database
Merging translations into window-list.schemas.
  GEN    org.gnome.panel.Wncklet.panel-applet
Found cached translation database
Merging translations into org.gnome.panel.Wncklet.panel-applet.
  CCLD   libwnck-applet.la
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets/wncklet'
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets'
make[3]: Nessuna operazione da eseguire per «all-am».
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets'
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/applets'
Making all in doc
make[2]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc'
Making all in reference
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc/reference'
Making all in panel-applet
make[4]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc/reference/panel-applet'
make[4]: Nessuna operazione da eseguire per «all».
make[4]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc/reference/panel-applet'
make[4]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc/reference'
make[4]: Nessuna operazione da eseguire per «all-am».
make[4]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc/reference'
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc/reference'
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc'
make[3]: Nessuna operazione da eseguire per «all-am».
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc'
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/doc'
Making all in help
make[2]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help'
Making all in clock
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock'
msgfmt -o it/it.mo it/it.po
xsltproc -o clock-C.omf --stringparam db2omf.basename clock --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock/clock.omf.in"  `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/clock.xml || { rm -f "clock-C.omf"; exit 1; }
if ! test -d it/; then mkdir it/; fi
if [ -f "C/clock.xml" ]; then d="../"; else d="/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock/"; fi; \
mo="it/it.mo"; \
if [ -f "${mo}" ]; then mo="../${mo}"; else mo="/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock/${mo}"; fi; \
(cd it/ && \
  `which xml2po` -m docbook -e -t "${mo}" \
    "${d}C/clock.xml" > clock.xml.tmp && \
    cp clock.xml.tmp clock.xml && rm -f clock.xml.tmp)
if ! test -d it/; then mkdir it/; fi
if [ -f "C/legal.xml" ]; then d="../"; else d="/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock/"; fi; \
mo="it/it.mo"; \
if [ -f "${mo}" ]; then mo="../${mo}"; else mo="/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock/${mo}"; fi; \
(cd it/ && \
  `which xml2po` -m docbook -e -t "${mo}" \
    "${d}C/legal.xml" > legal.xml.tmp && \
    cp legal.xml.tmp legal.xml && rm -f legal.xml.tmp)
Traceback (most recent call last):
  File "/usr/bin/xml2po-2.6", line 191, in <module>
Traceback (most recent call last):
  File "/usr/bin/xml2po-2.6", line 191, in <module>
    main(sys.argv[1:])
  File "/usr/bin/xml2po-2.6", line 88, in main
    from xml2po import Main
  File "/usr/lib64/python2.6/site-packages/xml2po/__init__.py", line 27, in <module>
    main(sys.argv[1:])
  File "/usr/bin/xml2po-2.6", line 88, in main
    from xml2po import Main
  File "/usr/lib64/python2.6/site-packages/xml2po/__init__.py", line 27, in <module>
    import libxml2
ImportError    import libxml2
ImportError: No module named libxml2
: No module named libxml2
make[3]: *** [it/clock.xml] Errore 1
make[3]: *** Attesa dei processi non terminati....
make[3]: *** [it/legal.xml] Errore 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help/clock'
make[2]: *** [all-recursive] Errore 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1/help'
make[1]: *** [all-recursive] Errore 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1'
make: *** [all] Errore 2
emake failed
 * ERROR: gnome-base/gnome-panel-2.32.1 failed:
 *   compile failure
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3694:  Called gnome2_src_compile
 *   environment, line 1854:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 * 
 * If you need support, post the output of 'emerge --info =gnome-base/gnome-panel-2.32.1',
 * the complete build log and the output of 'emerge -pqv =gnome-base/gnome-panel-2.32.1'.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1'

>>> Failed to emerge gnome-base/gnome-panel-2.32.1, Log file:

>>>  '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/temp/build.log'

 * Messages for package gnome-base/gnome-panel-2.32.1:

 * ERROR: gnome-base/gnome-panel-2.32.1 failed:
 *   compile failure
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3694:  Called gnome2_src_compile
 *   environment, line 1854:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 * 
 * If you need support, post the output of 'emerge --info =gnome-base/gnome-panel-2.32.1',
 * the complete build log and the output of 'emerge -pqv =gnome-base/gnome-panel-2.32.1'.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/gnome-panel-2.32.1/work/gnome-panel-2.32.1'
 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries
Comment 1 Rafał Mużyło 2011-01-02 22:50:56 UTC
So, you don't have libxml2 installed for python2.6.
Unless USE_PYTHON has both python2 versions, reinstalled packages
are installed only for the latest.
You probably didn't complete python-updater run and some packages are installed for one version,
while the rest for the other.
Comment 2 Gilles Dartiguelongue gentoo-dev 2011-01-03 09:28:42 UTC
select the python interpreter you had active before the last python updates (most likely 2.6, run python-updater, then you can consider switching.
Comment 3 Luca Passaretta 2011-01-03 22:24:00 UTC
(In reply to comment #1)
> So, you don't have libxml2 installed for python2.6.
> Unless USE_PYTHON has both python2 versions, reinstalled packages
> are installed only for the latest.
> You probably didn't complete python-updater run and some packages are installed
> for one version,
> while the rest for the other.
> 

Thank you very much! The problem is solved.