Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 35035 - emerge --update --pretend rsync -> error
Summary: emerge --update --pretend rsync -> error
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-04 01:54 UTC by nachtklavier
Modified: 2011-10-30 22:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nachtklavier 2003-12-04 01:54:43 UTC
# emerge --update --pretend rsync
emerge: the "sync" action does not support "--pretend."

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Radek Podgorny 2003-12-04 02:14:32 UTC
The whole "rsync" to "sync" mapping should be IMHO dropped...

Radek
Comment 2 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2003-12-04 04:27:19 UTC
I think the command should be changed to something like portage-update , so the emerge command shouldn't be used for that.
Comment 3 nachtklavier 2003-12-04 04:32:24 UTC
mmh, reading the second comment, i'm not sure if i understand it correctly. i just want to see what happens when i'm updating the package "rsync"... so i think emerge gets confused by whatever and thinks i want to sync something.
Comment 4 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2003-12-04 04:51:38 UTC
yep, that is also what i mean.
But then what if there is added a package called sync, then that one wouldn't work any longer.
That is why I surgest that the emerge command should not be used for updating the portage tree.
Comment 5 Marius Mauch (RETIRED) gentoo-dev 2003-12-04 05:35:21 UTC

*** This bug has been marked as a duplicate of 2365 ***