Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 350265 - Automatically rebuild all installed X11 drivers when X11 itself is upgraded
Summary: Automatically rebuild all installed X11 drivers when X11 itself is upgraded
Status: RESOLVED DUPLICATE of bug 192319
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-01 03:22 UTC by Timothy Miller
Modified: 2011-01-01 05:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Miller 2011-01-01 03:22:41 UTC
Every time X11 is upgraded, drivers break.  Often, the graphics card driver will still work, but my keyboard and mouse (evdev) always stop working, and it takes some head-scratching for me to remember what to do.  The solution is to re-emerge the drivers.

But this is too fragile and should be unnecessary.  

Either the drivers should be automatically re-emerged just to be safe, or version checks need to be made by portage to determine when driver binaries are out of date relative to X11 and need to be recompiled.

Fixing this would eliminate the flood of crying for help on IRC every time this happens, which is a LOT.


Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2011-01-01 05:56:51 UTC

*** This bug has been marked as a duplicate of bug 192319 ***