Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 350196 - net-wireless/broadcom-sta- fails to compile with Linux 2.6.37-rc8
Summary: net-wireless/broadcom-sta- fails to compile with Linux 2.6.37-rc8
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: MATSUU Takuto (RETIRED)
Depends on:
Reported: 2010-12-30 22:57 UTC by Jure Repinc
Modified: 2011-01-01 15:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2010-12-30 22:57:11 UTC
I just tried to emerge the new broadcom driver and it fails to compile
>> Emerging (1 of 5) net-wireless/broadcom-sta-
 * hybrid-portsrc_x86_64-v5_100_82_38.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                             [ ok ]
 * Package:    net-wireless/broadcom-sta-
 * Repository: gentoo
 * Maintainer:
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   preserve-libs sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.37-rc8/build
 * Found sources for kernel version:
 *     2.6.37-rc8
 * Checking for suitable kernel configuration options...                                                                                                                                 [ ok ]
>>> Unpacking source...
>>> Unpacking hybrid-portsrc_x86_64-v5_100_82_38.tar.gz to /var/tmp/portage/net-wireless/broadcom-sta-
>>> Source unpacked in /var/tmp/portage/net-wireless/broadcom-sta-
>>> Preparing source in /var/tmp/portage/net-wireless/broadcom-sta- ...
 * Applying broadcom-sta- ...                                                                                                                                     [ ok ]
 * Applying broadcom-sta- ...                                                                                                                                       [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-wireless/broadcom-sta- ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-wireless/broadcom-sta- ...
ln: failed to create symbolic link »Module.symvers«: File exists
 * Preparing wl module
make -j4 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= -C /usr/src/linux M=/var/tmp/portage/net-wireless/broadcom-sta- wl.ko 
make: Entering directory `/usr/src/linux-git'
  CC [M]  /var/tmp/portage/net-wireless/broadcom-sta-
  CC [M]  /var/tmp/portage/net-wireless/broadcom-sta-
  CC [M]  /var/tmp/portage/net-wireless/broadcom-sta-
/var/tmp/portage/net-wireless/broadcom-sta- In function ‘wl_attach’:
/var/tmp/portage/net-wireless/broadcom-sta- error: implicit declaration of function ‘init_MUTEX’
make[1]: *** [/var/tmp/portage/net-wireless/broadcom-sta-] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [wl.ko] Error 2
make: Leaving directory `/usr/src/linux-git'
emake failed
 * ERROR: net-wireless/broadcom-sta- failed:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=  -C /usr/src/linux M=/var/tmp/portage/net-wireless/broadcom-sta- wl.ko
 * Call stack:
 *, line   56:  Called src_compile
 *   environment, line 3577:  Called linux-mod_src_compile
 *   environment, line 2738:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                                               CROSS_COMPILE=${CHOST}-                                                 LDFLAGS=\"$(get_abi_LDFLAGS)\"                                          ${BUILD_FIXES}                                          ${BUILD_PARAMS}                                                 ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 * If you need support, post the output of 'emerge --info =net-wireless/broadcom-sta-',
 * the complete build log and the output of 'emerge -pqv =net-wireless/broadcom-sta-'.
 * The complete build log is located at '/var/tmp/portage/net-wireless/broadcom-sta-'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/broadcom-sta-'.
 * S: '/var/tmp/portage/net-wireless/broadcom-sta-'

Reproducible: Always

Steps to Reproduce:
1. Compile and use Linux 2.6.37-r8
2. Try to emerge broadcom-sta-

Actual Results:  
Emerge fails

Expected Results:  
Emerge should not fail

I solved the problem by changing line 487 from
sema_init(&wl->sem, 1);
Comment 1 MATSUU Takuto (RETIRED) gentoo-dev 2011-01-01 15:45:13 UTC
fixed in cvs. thanks.