Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 348930 - x11-base/xorg-server-1.9.x / net-irc/konversation-1.2.3: [Radeon:Classic] Graphical corruption/bleeding.
Summary: x11-base/xorg-server-1.9.x / net-irc/konversation-1.2.3: [Radeon:Classic] Gra...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 09:35 UTC by Jeremy Murphy
Modified: 2011-07-16 11:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Screenshot of graphical corruption. (graphics corruption in xorg-server-1.9.png,286.83 KB, image/png)
2010-12-17 09:36 UTC, Jeremy Murphy
Details
X log (Xorg.0.log,35.97 KB, text/plain)
2010-12-17 09:39 UTC, Jeremy Murphy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Murphy 2010-12-17 09:35:12 UTC
After random click or scroll event, a patch of the window corrupts.  It looks like the server connection window bleeding through.

This only started happening after I upgraded from xorg-server-1.7.7-r1 to xorg-server-1.9.2.

Reproducible: Sometimes

Steps to Reproduce:
1. Use the mouse, clicking and scrolling.

Actual Results:  
Graphical corruption, see screenshot.


Portage 2.1.9.24 (default/linux/x86/10.0/desktop/kde, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-i686-Intel-R-_Pentium-R-_M_processor_1.86GHz-with-gentoo-1.12.14
Timestamp of tree: Thu, 16 Dec 2010 23:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA skype-eula AdobeFlash-10.1 dlj-1.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distcc distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://ftp.iinet.net.au/pub/Gentoo "
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="en_AU en_AU.UTF-8 en_GB en_GB.UTF-8"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa apache2 avahi bash-completion berkdb blas bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups curl cxx dbus djvu dri dts dv dvb dvd dvdr emboss encode exif expat fam ffmpeg fftw firefox flac fontconfig fortran gd gdbm geoip gif gmp gnutls gphoto2 gpm graphviz gsl gtk hal iconv icu ieee1394 imagemagick imlib ipod ipv6 java java6 javascript jpeg kde kqemu lame lapack latex lcms ldap libsamplerate lirc lzo mad matroska mikmod mmap mmx mng modules mp3 mp4 mpeg mtp mudflap musepack mysql mysqli ncurses nls nptl nptlonly nsplugin odbc offensive ogg openal opengl pam pango pch pcre pdf perl php png ppds pppd python qt3support qt4 readline recode samba sdl session sharedmem sndfile sockets spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs syslog sysvipc taglib tcpd theora threads tiff timidity truetype unicode usb vorbis wavpack wifi wmf x264 x86 xcb xcomposite xml xorg xpm xscreensaver xulrunner xv xvid zeroconf zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_AU en_AU.UTF-8 en_GB en_GB.UTF-8" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeremy Murphy 2010-12-17 09:36:33 UTC
Created attachment 257403 [details]
Screenshot of graphical corruption.
Comment 2 Jeremy Murphy 2010-12-17 09:39:37 UTC
Created attachment 257404 [details]
X log
Comment 3 Jeremy Murphy 2010-12-17 09:42:22 UTC
I will also mention that this was using the classic Mesa driver.
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-17 18:04:29 UTC
Tried 1.9.2.902 yet?
Comment 5 Jeremy Murphy 2010-12-25 09:48:26 UTC
I just observed it on amd64 too, so yeah, I'll try 1.9.2.902 now.
Comment 6 Jeremy Murphy 2010-12-27 01:54:07 UTC
Alas, still happening in 1.9.2.902.
Comment 7 Jeremy Murphy 2010-12-30 08:38:49 UTC
I assume this graphical glitch is caused by whatever is causing the glitches reported in #349514 rather than being a bug in Konversation, so should I make this bug depend on it?  Or even close this bug and hijack it?  :)
Comment 8 Jeremy Murphy 2011-06-08 02:28:00 UTC
Haven't seen this on my laptop with an i945 graphics chip.
Comment 9 Jeremy Murphy 2011-07-16 11:26:59 UTC
I haven't seen this happen for quite a while so I'm going to presume it was an ephemeral bug.