Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 348582 - x11-drivers/nvidia-drivers-260.19.21 QA Notice: Found an absolute symlink in a library directory
Summary: x11-drivers/nvidia-drivers-260.19.21 QA Notice: Found an absolute symlink in ...
Status: RESOLVED DUPLICATE of bug 345375
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 03:44 UTC by David J Cozatt
Modified: 2010-12-13 23:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nvidia requested (nvidia-bug-report.log.gz,37.57 KB, text/gzip)
2010-12-13 03:47 UTC, David J Cozatt
Details
build log (x11-drivers:nvidia-drivers-260.19.21:20101213-014801.log,20.07 KB, text/plain)
2010-12-13 03:48 UTC, David J Cozatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David J Cozatt 2010-12-13 03:44:19 UTC
QA: other                                                                     │
│QA Notice: Found an absolute symlink in a library directory:                  │
│           usr/lib64/libnvcuvid.so -> /usr/lib64/libnvcuvid.so.260.19.21      │
│           It should be a relative symlink if in the same directory           │
│           or a linker script if it crosses the /usr boundary. 
 |  QA Notice: Found an absolute symlink in a library directory:    
              usr/lib64/libnvidia-cfg.so -> /usr/lib64/libnvidia-cfg.so.260.19.21│
│           It should be a relative symlink if in the same directory           │
│           or a linker script if it crosses the /usr boundary.          



Reproducible: Always




david@random ~ $ emerge --info nvidia-drivers
Portage 2.1.9.25 (default/linux/amd64/10.0, gcc-4.5.1, glibc-2.12.1-r3, 2.6.36-gentoo-r5 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-AMD_Athlon-tm-_64_Processor_3200+-with-gentoo-2.0.1
Timestamp of tree: Mon, 13 Dec 2010 01:15:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.6.6-r1, 2.7.1, 3.1.3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -ggdb -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -ggdb -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages multilib-strict news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.gtlib.gatech.edu/pub/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://mirrors.163.com/gentoo/ ftp://mirror.bih.net.ba/gentoo/"
LDFLAGS="-Wl,--hash-style=gnu,-O1 -Wl,--as-needed"
LINGUAS="en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/david/projects/work"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="acl alsa amd64 berkdb bzip2 cdr cli cracklib crypt cups cxx dri en fortran gdbm gpm gtk iconv midi mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pic pppd python readline session sse sse2 ssl sysfs tcpd threads unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18 ree18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

x11-drivers/nvidia-drivers-260.19.21 was built with the following:
USE="gtk (multilib) -acpi -custom-cflags"
Comment 1 David J Cozatt 2010-12-13 03:47:08 UTC
Created attachment 257000 [details]
nvidia requested
Comment 2 David J Cozatt 2010-12-13 03:48:50 UTC
Created attachment 257004 [details]
build log
Comment 3 Ben Kohler gentoo-dev 2010-12-13 22:51:00 UTC
bug 345375
Comment 4 Jeroen Roovers gentoo-dev 2010-12-13 23:43:21 UTC

*** This bug has been marked as a duplicate of bug 345375 ***