Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 347861 - app-admin/python-updater always rebuilds binary packages containing binaries statically linked against Python library
Summary: app-admin/python-updater always rebuilds binary packages containing binaries ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal with 1 vote (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-05 23:55 UTC by Benjamin Lee
Modified: 2018-02-14 15:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Lee 2010-12-05 23:55:49 UTC
Due to its statically linked Python installer, app-emulation/vmware-workstation is always rebuilt by python-updater.

The relevant output from 'python-updater -p -v -v -v':

 * Checking app-emulation/vmware-workstation-6.5.4.246459:0
 *   Adding to list: app-emulation/vmware-workstation:0
 *     check: static_linking [ Binaries linked against Python static libraries f
ound:
 *       /opt/vmware/workstation/lib/vmware/installer/python/python
 *     ]

Since this is a binary distribution that cannot be recompiled against the system's Python version, it should be ignored by python-updater.

Reproducible: Always

Steps to Reproduce:
1. Install app-emulation/vmware-workstation.
2. Install app-admin/python-updater-0.8.
3. Run python-updater.
Comment 1 Pacho Ramos gentoo-dev 2018-02-14 15:58:52 UTC
removed from the tree