Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34782 - Emerge rsync timesout and does not download list of files
Summary: Emerge rsync timesout and does not download list of files
Alias: None
Product: Mirrors
Classification: Unclassified
Component: Server Problem (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
Depends on:
Reported: 2003-11-30 15:38 UTC by Virginia K. Wills
Modified: 2009-01-23 19:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Virginia K. Wills 2003-11-30 15:38:28 UTC
When I try to run emerge rsync it goes through the retries and timesout each
time. If I do a rescue portage to version 2.0.47-r10, I can then do a sync, but
have to use a sandbox option to upgrade portage. When portage is upgraded it
doesn't matter if it is r15 or r18 the problem then reoccurs. See below:

emerge sync
>>> starting rsync with rsync://
This is, located in Florida, USA.

receiving file list ...
io timeout after 180 seconds - exiting
rsync error: timeout in data send/receive (code 30) at io.c(103)

>>> Starting retry 1 of 3
This is, located in Florida, USA.

receiving file list ...
io timeout after 180 seconds - exiting
rsync error: timeout in data send/receive (code 30) at io.c(103)

>> Starting retry 2 of 3

receiving file list ...
io timeout after 180 seconds - exiting
rsync error: timeout in data send/receive (code 30) at io.c(103)

>>> Starting retry 3 of 3
CEDE Gentoo Mirror

receiving file list ...
io timeout after 180 seconds - exiting
rsync error: timeout in data send/receive (code 30) at io.c(103)

!!! Rsync has not successfully finished. It is recommended that you keep
!!! trying or that you use the 'emerge-webrsync' option if you are unable
!!! to use rsync due to firewall or other restrictions. This should be a
!!! temporary problem unless complications exist with your network
!!! (and possibly your system's filesystem) configuration.

Reproducible: Always
Steps to Reproduce:
1.rescue to portage-2.0.47-r10 repair replaced files can emerge sync
2.upgrade to portage-2.0.47-r15 or portage-2.0.47-r18 cannot emerge sync timesout

Expected Results:  
Would like to be able to rsync without having to rescue portage and repair the
files this replaces.
Comment 1 Kurt Lieber (RETIRED) gentoo-dev 2003-11-30 15:58:25 UTC
Sounds like a portage bug rather than a mirror bug.  Re-assigning to the portage team.
Comment 2 Masatomo Nakano (RETIRED) gentoo-dev 2003-11-30 16:48:57 UTC
Hello Virginia,

Do you use proxy or something?
And can you show us 'emerge info' and `grep SYNC /etc/make.conf`
Comment 3 Virginia K. Wills 2003-11-30 17:15:18 UTC
Here is the information you requested:

No I do not use a proxy. I'm using Shorewall as a firewall. It causes no problems until portage is upgraded as I mentioned in the bug report.

Here is my 'emerge info'

Portage 2.0.49-r18 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.22)
System uname: 2.4.22 i686 Pentium III (Coppermine)
Gentoo Base System version
CFLAGS="-O2 -march=pentium3 -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -funroll-loops -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X alsa apm arts avi berkdb cdr crypt cups directfb encode esd foomaticdb gdbm gif gpm gtk gtk2 imlib java jpeg kde libg++ libwww mad mikmod motif mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png ppds python qt quicktime readline sdl slang spell ssl svga tcltk tcpd truetype usb x86 xml2 xmms xv zlib"

Here is the `grep SYNC /etc/make.conf`:

grep SYNC /etc/make.conf
# RSYNC_RETRIES sets the number of times portage will attempt to retrieve
Comment 4 Masatomo Nakano (RETIRED) gentoo-dev 2003-11-30 17:31:50 UTC
Thanks you for the infomation.
But I don't understand. hmm.

I just compared 2.0.49-r15 with 2.0.47-r10 about "emerge sync".
They are same about "emerge sync". (but thare are a little different in -18).

It might be just timeout.
Can you set "RSYNC_TIMEOUT=500" in /etc/rsync.conf and retry it?
Comment 5 Virginia K. Wills 2003-11-30 17:41:38 UTC
That may be where the problem is. I no longer have an /etc/rsync.conf file. I don't have a clue as to what is supposed to be in this file. I'm fairly new to Gentoo. I tried creating this file but it only contains the RSYNC_TIMEOUT=500 and I still have the problem.
Comment 6 Masatomo Nakano (RETIRED) gentoo-dev 2003-11-30 17:46:30 UTC
Sorry, "/etc/rsync.conf" is my typo.
"/etc/make.conf" is correct.
Comment 7 Virginia K. Wills 2003-11-30 18:10:00 UTC
OK, I put the RSYNC_TIMEOUT=500 in /etc/make.conf. When running 'emerge sync' it is still just sitting there at the point where it says receiving files. It is doing nothing.
Comment 8 SpanKY gentoo-dev 2003-11-30 19:55:23 UTC
if you disable the firewall and attempt to rsync does it work fine ?
Comment 9 Virginia K. Wills 2003-12-01 01:09:21 UTC
No it still does the same thing.
Comment 10 Nicholas Jones (RETIRED) gentoo-dev 2003-12-10 06:31:28 UTC
You are certain that you have the firewall disabled?
If setting the timeout to 500 doesn't fix it, I don't
quite see what the issue is. You can set it higher and
try again.

Are you on a modem? What kind of connection?

Comment 11 Virginia K. Wills 2003-12-10 07:16:38 UTC
Yes, I am certain the firewall was disabled. I issued the command "/etc/init.d/shorewall stop" Then I tried the command "emerge sync" It still times out same as with shorewall running. This morning I even tried opening port 873 with shorewall which is the rsync port. I still get the timeouts when using "emerge sync" I am using a modem. Everything worked just fine with "emerge sync" up until just before I filed this bug report. I have tried the use flag of -ipv6 and everything else that I have been able to find on the portage forum. I have re-emerged portage, rsync, and wget several times both with ipv6 and without ipv6. Nothing I've tried has solved the problem. I even tried re-emerging my system files. That didn't work either. I'm beginning to wonder if I may be missing something in the rsyncd.conf file.
Comment 12 Virginia K. Wills 2003-12-10 09:00:51 UTC
I will tell you again, increasing the timeout time does not do any good. During the time it says it is receiving the file list, absolutely nothing is happening. Before this problem started occuring, it was actually receiving the file list. It showed the number of files it had received and the modem indicator showed it was doing something. Now none of this is occuring. It is just sitting there, timesout and then moves on to try another mirror where the same thing happens all over again. 
Comment 13 Derek Dolney 2003-12-18 09:51:35 UTC
Are you using pam-0.77 ? I had a similar problem and it went away after downgrading to pam-0.75.

Strange thing is, I upgraded back to pam-0.77 and it works. It looks like the pam-0.77 ebuild has changed since I originally emerged it, but nothing that looks relevant to me.
Comment 14 Nicholas Jones (RETIRED) gentoo-dev 2003-12-22 22:05:13 UTC
Portage does nothing special with rsync other than settings the timeout
to 180 seconds by default. If this is still an issue, try setting the
timeout to something around 2400 seconds. The file list is over 1.5M and
at 5 minute megs, you're looking at 7-8 minutes... PLUS the delay for
IO on either side.

As far as portage is concerned, nothing can be done.
Comment 15 Sagadon 2009-01-23 19:50:39 UTC
Note: Try 'emerge-webrsync' as an alternative to 'emerge --sync'. The port may be blocked somewhere between you and the servers.