Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 347215 - app-cdr/cdemud-1.3.0 shouldn't depend on sysfsutils
Summary: app-cdr/cdemud-1.3.0 shouldn't depend on sysfsutils
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High minor (vote)
Assignee: Marcelo Goes (RETIRED)
URL:
Whiteboard:
Keywords:
: 377677 (view as bug list)
Depends on:
Blocks: 377673
  Show dependency tree
 
Reported: 2010-11-29 21:08 UTC by Rafał Mużyło
Modified: 2011-08-04 16:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Mużyło 2010-11-29 21:08:51 UTC
That dep was already removed upstream, only docs were not updated.
Comment 1 Rafał Mużyło 2011-08-04 10:00:32 UTC
*** Bug 377677 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2011-08-04 15:34:46 UTC
Looks like the source tree has some outdated file, like what is that sysfs_LIBS still doing in Makefile.am?

Anyway, it's not used, so dependency dropped and closing

+  04 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> cdemud-1.3.0.ebuild:
+  Remove unnecessary sys-fs/sysfsutils depend wrt #347215 by Rafał Mużyło.

$ grep -r sysfs *
debian/control: libsysfs-dev, libglib2.0-dev, libao-dev (>= 0.8.0), libmirage3-dev (>= 1.3.0),
README: - libsysfs
src/Makefile.in:    $(sysfs_LIBS)
src/cdemud-device.c:           sysfs dir :/ */
src/cdemud-device.c:        gchar *sysfs_dev_path = g_strdup_printf("/sys/bus/scsi/devices/%i:%i:%i:%i", id[0], id[1], id[2], id[3]);
src/cdemud-device.c:        GDir *dir_dev = g_dir_open(sysfs_dev_path, 0, NULL);
src/cdemud-device.c:            CDEMUD_DEBUG(self, DAEMON_DEBUG_WARNING, "%s: sysfs device for device #%i (%s) could not be opened; device mapping info for this device will not be available\n", __debug__, _priv->number, sysfs_dev_path);
src/cdemud-device.c:            /* Iterate through sysfs dir */
src/cdemud-device.c:                        gchar *dirpath = g_build_filename(sysfs_dev_path, entry_name, NULL);
src/cdemud-device.c:                        gchar *symlink = g_build_filename(sysfs_dev_path, entry_name, NULL);
src/cdemud-device.c:        g_free(sysfs_dev_path);
src/Makefile.am:    $(sysfs_LIBS)
Comment 3 Rafał Mużyło 2011-08-04 16:03:37 UTC
Well, the original patch removing the dep (http://cdemu.svn.sourceforge.net/viewvc/cdemu?view=revision&revision=641) only touched the code and configure.ac - I've simply missed it back then (the upstream patch was based on the one I've sent).
Actually, src/Makefile.am is still unfixed in upstream svn in that regard, but without configure.ac bit it doesn't really matter.