Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 347183 - dev-python/pygtk-2.22.0 version bump request (Was: dev-python/sexy-python-0.1.9-r1 fails to build with x11-libs/gtk+-2.22* and dev-python/pygtk-2.17*)
Summary: dev-python/pygtk-2.22.0 version bump request (Was: dev-python/sexy-python-0.1...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 348352 349853 (view as bug list)
Depends on:
Blocks: gnome2.32
  Show dependency tree
 
Reported: 2010-11-29 15:04 UTC by Hanno Böck
Modified: 2011-01-19 14:36 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-python:sexy-python-0.1.9-r1:20101205-190035.log (dev-python:sexy-python-0.1.9-r1:20101205-190035.log,13.81 KB, text/plain)
2010-12-05 19:02 UTC, Hanno Böck
Details
pygtk-2.22.0.ebuild.diff (pygtk-2.22.0.ebuild.diff,1.34 KB, patch)
2011-01-17 18:50 UTC, Pacho Ramos
Details | Diff
pygtk-2.22.0.ebuild.diff (pygtk-2.22.0.ebuild.diff,1.69 KB, patch)
2011-01-18 09:38 UTC, Pacho Ramos
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck gentoo-dev 2010-11-29 15:04:04 UTC
After upgrading to python 2.7.1, I got a build failure with sexy-python:
In file included from /usr/include/gtk-2.0/gdk/gdkcairo.h:28:0,
                 from /usr/include/gtk-2.0/gdk/gdk.h:33,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from /usr/include/pygtk-2.0/pygtk/pygtk.h:8,
                 from sexy.override:8:
/usr/include/gtk-2.0/gdk/gdkpixbuf.h:37:35: fatal error: gdk-pixbuf/gdk-pixbuf.h: No such file or directory
compilation terminated.

After some googling, I found that this is a bug in pygtk:
http://www.spinics.net/lists/fedora-devel/msg139596.html

It's missing gtk+ from it's pkg-config (.pc) file. This has been fixed long ago upstream, but our pygtk-package is about a year old (2.17.0). Please bump pygtk to 2.22.0.
Comment 1 Joel Berendzen 2010-12-01 15:20:07 UTC
I can confirm this bug and that the fix up upgrading pygtk to 2.22.0 works.
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-05 18:31:15 UTC
I can't reproduce any build failure with Python 2.7 and dev-python/pygtk-2.17.0. Please attach full build log.
Comment 3 Hanno Böck gentoo-dev 2010-12-05 19:02:35 UTC
Created attachment 256419 [details]
dev-python:sexy-python-0.1.9-r1:20101205-190035.log
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-05 19:36:20 UTC
/usr/include/gtk-2.0/gdk-pixbuf/gdk-pixbuf.h belongs to x11-libs/gtk+. Which version of x11-libs/gtk+ do you use?
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2010-12-05 19:40:29 UTC
(In reply to comment #4)
> /usr/include/gtk-2.0/gdk-pixbuf/gdk-pixbuf.h belongs to x11-libs/gtk+. Which
> version of x11-libs/gtk+ do you use?

I am getting this error, and I have gtk+-2.22.1
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-05 19:43:24 UTC
Does this problem occur with x11-libs/gtk+-2.20* and dev-python/pygtk-2.17.0*?
Comment 7 Hanno Böck gentoo-dev 2010-12-06 00:34:54 UTC
Just checked, it only happens with the combination pygtk-2.17.0, gtk+-2.22.1 and python 2.7. It does not happen with pygtk-2.17.0, gtk+-2.20.1-r1 and python 2.7.

So yes, it seems it's only a problem of the masked gtk+ version, though for the upcoming gnome-2.32 unmask we should have pygtk updated in the tree.
Comment 8 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-06 01:27:09 UTC
Maybe dev-python/pygtk-2.17* should depend on <x11-libs/gtk+-2.22.
Comment 9 Pacho Ramos gentoo-dev 2010-12-06 12:02:17 UTC
Trying to bump pygtk to 2.22 I got its tests failing with the following:

$ make check
Making check in .
make[1]: Entering directory `/home/pacho/pygtk-2.22.0'
make[1]: Nothing to be done for `check-am'.
make[1]: Leaving directory `/home/pacho/pygtk-2.22.0'
Making check in gtk
make[1]: Entering directory `/home/pacho/pygtk-2.22.0/gtk'
make[1]: Nothing to be done for `check'.
make[1]: Leaving directory `/home/pacho/pygtk-2.22.0/gtk'
Making check in examples
make[1]: Entering directory `/home/pacho/pygtk-2.22.0/examples'
make[1]: Nothing to be done for `check'.
make[1]: Leaving directory `/home/pacho/pygtk-2.22.0/examples'
Making check in tests
make[1]: Entering directory `/home/pacho/pygtk-2.22.0/tests'
make  check-local
make[2]: Entering directory `/home/pacho/pygtk-2.22.0/tests'
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
Traceback (most recent call last):
  File "./runtests.py", line 41, in <module>
    suite.addTest(loader.loadTestsFromName(name))
  File "/usr/lib64/python2.6/unittest.py", line 576, in loadTestsFromName
    module = __import__('.'.join(parts_copy))
  File "/home/pacho/pygtk-2.22.0/tests/test_enum.py", line 9, in <module>
    class PObject(gobject.GObject):
  File "/home/pacho/pygtk-2.22.0/tests/test_enum.py", line 10, in PObject
    enum = gobject.property(type=gtk.WindowType, default=gtk.WINDOW_TOPLEVEL)
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gobject/propertyhelper.py", line 112, in __init__
    self.type = self._type_from_python(type)
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gobject/propertyhelper.py", line 202, in _type_from_python
    raise TypeError("Unsupported type: %r" % (type,))
TypeError: Unsupported type: <class 'gtk._gtk.WindowType'>
make[2]: *** [check-local] Error 1
make[2]: Leaving directory `/home/pacho/pygtk-2.22.0/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/home/pacho/pygtk-2.22.0/tests'
make: *** [check-recursive] Error 1
Comment 10 Lukas Zavodny 2010-12-07 21:00:50 UTC
temporary workaround is ln -s /usr/include/gdk-pixbuf-1.0/gdk-pixbuf /usr/include/gdk-pixbuf
Comment 11 Lukas Zavodny 2010-12-07 21:04:17 UTC
(In reply to comment #10)
> temporary workaround is ln -s /usr/include/gdk-pixbuf-1.0/gdk-pixbuf
> /usr/include/gdk-pixbuf
> 

ups, old paste :) right is ln -s /usr/include/gdk-pixbuf-2.0/gdk-pixbuf /usr/include/gdk-pixbuf

Comment 12 Dustin Polke 2010-12-14 09:12:12 UTC
*** Bug 348352 has been marked as a duplicate of this bug. ***
Comment 13 Richard 2010-12-16 12:31:07 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > temporary workaround is ln -s /usr/include/gdk-pixbuf-1.0/gdk-pixbuf
> > /usr/include/gdk-pixbuf
> > 
> 
> ups, old paste :) right is ln -s /usr/include/gdk-pixbuf-2.0/gdk-pixbuf
> /usr/include/gdk-pixbuf
> 

Is it possible to update the x11-libs/gdk-pixbuf ebuild in portage so that it makes that symbolic link?
Comment 14 Gilles Dartiguelongue gentoo-dev 2010-12-16 22:23:44 UTC
please note that pygtk bump is delayed to problems found via its testsuite.
Comment 15 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-27 14:48:44 UTC
*** Bug 349853 has been marked as a duplicate of this bug. ***
Comment 16 Pacho Ramos gentoo-dev 2011-01-17 18:50:50 UTC
Created attachment 260066 [details, diff]
pygtk-2.22.0.ebuild.diff

I vote for simply restricting tests since pygtk based apps look to still work ok for me and a lot of distributions are shipping this for months (also upstream is quite unresponsive, maybe they are too loaded :-/)
Comment 17 Pacho Ramos gentoo-dev 2011-01-18 09:38:35 UTC
Created attachment 260113 [details, diff]
pygtk-2.22.0.ebuild.diff

I have tried to simply skip failing test but, later, tests aborts due permission problems that I have been unable to fix setting some variables :-@

 * Testing of dev-python/pygtk-2.22.0 with CPython 2.6...
make -j2 check-local 
................................................................................
Gtk-WARNING **: Attempting to store changes into `/root/.recently-used.xbel', but failed: Falló al crear el archivo «/root/.recently-used.xbel.IZXQPV»: Permiso denegado
aborting...
Comment 18 Pacho Ramos gentoo-dev 2011-01-18 09:40:38 UTC
But it's not a regression
http://bugs.gentoo.org/show_bug.cgi?id=245103

Not sure what to do :-|
Comment 19 Pacho Ramos gentoo-dev 2011-01-19 14:36:09 UTC
+*pygtk-2.22.0 (19 Jan 2011)
+
+  19 Jan 2011; Pacho Ramos <pacho@gentoo.org> -pygtk-2.16.0-r1.ebuild,
+  -files/pygtk-2.16.0-gdkcolor-fix.patch, +pygtk-2.22.0.ebuild:
+  Version bump with lots of bugfixes and gtk+-2.22 compatible, skip broken test
+  (upstream bug #636589) and test wanting to write outside sandbox (bug
+  #245103). Remove old.