Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 346503 - net-dialup/ppp: pppd softlockup at bootup with IPv6 enabled
Summary: net-dialup/ppp: pppd softlockup at bootup with IPv6 enabled
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2010-11-23 08:21 UTC by Matthew Stapleton
Modified: 2011-01-25 08:23 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Stapleton 2010-11-23 08:21:01 UTC
My ISP is currently trialing IPv6 over PPPoE so I have been trying it out, but currently I get a kernel softlockup similar to the following at system bootup with the "ipv6 ," option enabled (typed out from a screenshot):

[<ffffffff810020ab>] ? system_call_fastpath+0x16/0x1b
Kernel - panic - not syncing: softlockup: hung tasks
Pid: 7932, comm: pppd Not tainted 2.6.36-gentoor1 #1
Call Trace:
<IRQ> [<ffffffff814ba518>] ? panic+0xac/0x1b0
[<ffffffff81004e10>] ? dump_trace+0x270/0x27f
[<ffffffff81002a0e>] ? apic_timer_interrupt+0xe/0x20
[<ffffffff81076683>] ? watchdog_timer_fn+0x17c/0x1b3
[<ffffffff81076507>] ? watchdog_timer_fn+0x0/0x1b3
[<ffffffff81053c70>] ? __run_hrtimer+0x50/0xa9
[<ffffffff81053ec8>] ? hrtimer_interrupt+0xaa/0x192
[<ffffffff81019371>] ? smp_apic_timer_interrupt+0x81/0x94
[<ffffffff81002a13>] ? apic_timer_interrupt+0x13/0x20
<EOI> [<ffffffff8142c096>] ? dev_deactivate_queue+0x0/0x63
[<ffffffff814bc4ba>] ? _raw_spin_lock_bh+0x28/0x2e
[<ffffffff814bc49b>] ? _raw_spin_lock_bh+0x9/0x2e
[<ffffffff8142c0be>] ? dev_deactivate_queue+0x20/0x63
[<ffffffff8142c12d>] ? dev_deactivate_queue+0x34/0xdb
[<ffffffff8141a00e>] ? __dev_close+0x54/0x70
[<ffffffff8141803f>] ? __dev_change_flags+0xaf/0x129
[<ffffffff81419ed1>] ? dev_change_flags+0x12/0x42
[<ffffffff8146070b>] ? devinet_ioctl+0x273/0x528
[<ffffffff81409324>] ? sock_do_ioctl+0x1b/0x36
[<ffffffff8140954f>] ? sock_ioctl+0x210/0x21a
[<ffffffff810c1e0a>] ? do_vfs_ioctl+0x40b/0x44c
[<ffffffff81023632>] ? do_page_fault+0x210/0x259
[<ffffffff810c1e9c>] ? sys_ioctl+0x51/0x70
[<ffffffff810020ab>] ? [<ffffffff814ba518>] ? system_call_fastpath+0x16/0x1b

I have tried both parallel and non-parallel mode and it freezes in both cases.  Also, it won't lockup if I unplug the modem while booting and then after restarting net.ppp0 on the command line once the system has booted I plug the modem in again.  After doing the following I rarely get the hangup now although pppd shouldn't be able to cause any kernel freezes:

in /etc/ppp/:
  Changed ipv6-down and ipv6-up from symlinks to dedicated scripts that point to new directories: ipv6-up.d and ipv6-down.d with only a 90-local file to bring up the IPv6 routing.  The current and scripts might not be relevent for IPv6.
  Removed ip-down.d/ and ip-up.d/

Reproducible: Always

Steps to Reproduce:
1. Connect to an ISP that offers both IPv4 and IPv6 over PPPoE
2. Enable the "ipv6 ," option in /etc/conf.d/net
3. Reboot
Actual Results:  
The kernel gets a softlockup a few seconds after net.ppp0 connects to the internet

Expected Results:  
The system should have booted completely

emerge --info
Portage (hardened/linux/amd64/10.0, gcc-4.3.4, glibc-2.11.2-r0, 2.6.36-gentoo-r1 x86_64)
System uname: Linux-2.6.36-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4000+-with-gentoo-2.0.1
Timestamp of tree: Thu, 18 Nov 2010 13:15:03 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.4.4-r13, 2.5.2-r7, 2.6.4-r1
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.4
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.4.6-r2, 4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81
virtual/os-headers:  2.6.30-r1
CFLAGS="-O2 -march=athlon64 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -fomit-frame-pointer"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext acl acpi alsa amd64 apache2 berkdb bzip2 caps cjk cli cracklib crypt cups cxx dlloader dri fam gdbm gpm hardened iconv ipv6 jpeg justify kerberos logrotate mmx mmxext mng modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pic png pppd python qt readline session sse sse2 ssl sysfs tcpd threads tiff unicode urandom vhosts xattr xinerama xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" MISDN_CARDS="netjetpci" PHP_TARGETS="php5-2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Agostino Sarubbo gentoo-dev 2010-11-23 19:18:32 UTC
can you specify your version of ppp?
thanks :)
Comment 2 Matthew Stapleton 2010-11-24 02:16:44 UTC
I was running net-dialup/ppp-2.4.4-r13, but a few days ago I updated to 2.4.4-r25 to see if it would fix the problem, but it hasn't made much difference.  I also have IPv6 forwarding enabled at the moment.
Comment 3 Alin Năstac (RETIRED) gentoo-dev 2010-11-27 09:43:20 UTC
That's probably a kernel bug, reassigning to proper team.
Comment 4 George Kadianakis (RETIRED) gentoo-dev 2010-11-27 21:52:08 UTC
I'm afraid I can't relate the backtrace with ipv6.

Would you be oh-so-kind and report this upstream (that would be and then send us the bug report URL back?

Thank you!
Comment 5 Matthew Stapleton 2010-11-30 02:59:51 UTC
I have reported the bug upstream now:
Comment 6 George Kadianakis (RETIRED) gentoo-dev 2010-11-30 03:04:15 UTC
(In reply to comment #5)
> I have reported the bug upstream now:

Thank you!
Let's see what upstream has to say about this now :)
Comment 7 Mike Pagano gentoo-dev 2010-12-12 13:50:47 UTC
We'll track the upstream bug and backport any fixes which become available.
Comment 8 Kostas Kavourakis 2011-01-24 17:22:09 UTC
Got hit with the same bug unfortunately.
Comment 9 Kostas Kavourakis 2011-01-25 08:23:37 UTC
Problem seems solved at kernel version 2.6.37.