Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 345963 - cannot run xfdesktop
Summary: cannot run xfdesktop
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 09:30 UTC by Miroslav Šulc
Modified: 2010-12-06 18:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Šulc gentoo-dev 2010-11-18 09:30:07 UTC
when trying to run xfdesktop, i get this error:

$ LC_ALL="C" xfdesktop
xfdesktop[27541]: starting up
Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

** (xfdesktop:27541): CRITICAL **: dbus_g_bus_get: assertion `error == NULL || *error == NULL' failed

** (xfdesktop:27541): WARNING **: xfdesktop: unable to connect to settings daemon: (null).  Defaults will be used

** (xfdesktop:27541): CRITICAL **: xfce_desktop_new: assertion `channel && property_prefix' failed

(xfdesktop:27541): Gtk-CRITICAL **: gtk_widget_add_events: assertion `GTK_IS_WIDGET (widget)' failed

(xfdesktop:27541): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(xfdesktop:27541): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(xfdesktop:27541): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(xfdesktop:27541): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(xfdesktop:27541): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(xfdesktop:27541): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(xfdesktop:27541): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(xfdesktop:27541): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(xfdesktop:27541): Gtk-CRITICAL **: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
Neoprávněný přístup do paměti (SIGSEGV)

package versions:
xfce-base/xfdesktop-4.7.2
xfce-base/xfce4-session-4.7.1-r2

$ emerge --info
Portage 2.1.9.24 (default/linux/amd64/10.0/desktop, gcc-4.4.5, glibc-2.12.1-r3, 2.6.36-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7_CPU_Q_720_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 18 Nov 2010 08:15:02 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.6.6-r1, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.4
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.7.9-r2, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4
sys-devel/make:      3.82
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10 AdobeFlash-10.1 skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/maven-bin-3.0/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirror.web4u.cz/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="cs_CZ.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="cs"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/fordfrog/src/gentoo/overlay"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 audacious bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups cvs cxx dbus device-mapper dhcpcd dia dri dts dvb dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif git glade gmplayer gphoto2 gpm gtk hddtemp icecast iconv id3tag jack jpeg lame laptop lash lcms libnotify libv4l libv4l2 lm_sensors mad mercurial midi mikmod mmx mng modules mp3 mp4 mpd mpeg mudflap multilib ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline sdl session shout slang sndfile spell sse sse2 ssl ssse3 startup-notification stream subversion svg sysfs theora tiff truetype udev unicode usb v4l v4l2 vhosts vorbis wavpack wifi x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs" NETBEANS_MODULES="*" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-11-18 14:01:47 UTC
I hit this when I upgraded and has a stale xfconfd running. Did you reboot or anything?
Comment 2 Miroslav Šulc gentoo-dev 2010-12-02 22:02:27 UTC
sorry, i did not notice your answer. i have the problem still till now, my laptop rebooted many times.
Comment 3 Miroslav Šulc gentoo-dev 2010-12-05 09:38:20 UTC
xfdesktop-4.7.3 fixes the problem. it still complains that it cannot connect to session manager as "SESSION_MANAGER environment variable not defined" but it runs and displays the desktop.
Comment 4 Samuli Suominen gentoo-dev 2010-12-06 16:41:41 UTC
(In reply to comment #3)
> xfdesktop-4.7.3 fixes the problem.

good. closing then.

> it still complains that it cannot connect to
> session manager as "SESSION_MANAGER environment variable not defined" but it
> runs and displays the desktop.

How do you start Xfce ?    Does that happen also if you run Xfce from a new user (like from a empty user directory, empty Xfce configs) ?  It should definately be set.   Please open a new bug for this if it's a problem and it persists.

$ echo $SESSION_MANAGER
local/unique:@/tmp/.ICE-unix/20461,unix/unique:/tmp/.ICE-unix/20461

Comment 5 Miroslav Šulc gentoo-dev 2010-12-06 18:14:42 UTC
i use slim as login screen so i guess it is slim or xdm or what is it that starts xfce. but it has no negative effect on my xfce it seems, unless it is the cause of not being able to shutdown system from xfce anymore, which worked before last big update of xfce which was week or two back iirc. but i did not have time to dig deeper into this issue yet.
Comment 6 Samuli Suominen gentoo-dev 2010-12-06 18:18:27 UTC
(In reply to comment #5)
> i use slim as login screen so i guess it is slim or xdm or what is it that
> starts xfce. but it has no negative effect on my xfce it seems, unless it is
> the cause of not being able to shutdown system from xfce anymore, which worked
> before last big update of xfce which was week or two back iirc. but i did not
> have time to dig deeper into this issue yet.
> 

Oh, I see.   Yes, SLIM was broken until 1.3.2-r3 (bug 346037). Still needs to be stabilized.

And you still need to edit /etc/pam.d/system-login by hand and remove 'nox11' parameter from 'pam_ck_connector.so' line for either SLIM or XDM to work (bug 342345).

Otherwise ConsoleKit session is never initialized properly, and xfce4-session would propably fail one way or another... 
Comment 7 Miroslav Šulc gentoo-dev 2010-12-06 18:41:04 UTC
samuli, thanks for the hints. i have latest slim as i am on ~amd64 and i changed /etc/pam.d/system-login according to your advice but it seems to have no effect on my system. thinks work still the same, echo $SESSION_MANAGER shows nothing in terminal but xfce seems to work normally, except the shutdown stuff, but i can live with that for now :-)
Comment 8 Samuli Suominen gentoo-dev 2010-12-06 18:48:05 UTC
(In reply to comment #7)
> samuli, thanks for the hints. i have latest slim as i am on ~amd64 and i
> changed /etc/pam.d/system-login according to your advice but it seems to have
> no effect on my system. thinks work still the same, echo $SESSION_MANAGER shows
> nothing in terminal but xfce seems to work normally, except the shutdown stuff,
> but i can live with that for now :-)
> 

Here's some more (propably more suitable for forums or IRC though. Feel free to find me at Freenode if you can't figure it out):

Also make sure to launch Xfce with 'exec ck-launch-session startxfce4' from SLIM (or any other).   To include the ck-launch-session there.

And obviously make sure /etc/init.d/consolekit is running.
Then you should see 'active = TRUE' with 'ck-list-sessions' inside X.

Also xfce4-session prefers sys-power/upower for those operations, but can also use sudo or hal... so any of those 3 needs to be manually installed. They're runtime-only deps.