Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 345755 - Package 'libpng12', required by 'cairo', not found
Summary: Package 'libpng12', required by 'cairo', not found
Status: RESOLVED DUPLICATE of bug 1991
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-16 12:04 UTC by Alex Buell
Modified: 2010-11-17 15:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info =app-crypt/pinentry-0.8.0 (output1.log,4.29 KB, text/plain)
2010-11-16 12:08 UTC, Alex Buell
Details
merge -pqv =app-crypt/pinentry-0.8.0 (output2.log,89 bytes, text/plain)
2010-11-16 12:08 UTC, Alex Buell
Details
/var/tmp/portage/app-crypt/pinentry-0.8.0/temp/build.log (build.log,89.39 KB, text/plain)
2010-11-16 12:09 UTC, Alex Buell
Details
/var/tmp/portage/app-crypt/pinentry-0.8.0/temp/environment (environment,98.98 KB, text/plain)
2010-11-16 12:09 UTC, Alex Buell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Buell 2010-11-16 12:04:47 UTC
Updating a six month old install of Gentoo on a iMac (PPC G3) resulted in pinentry-0.8.0 failing to build. 

Logs included. 

I'm guessing that this one may need some DEPENDS on things it needs installed first.
Comment 1 Alex Buell 2010-11-16 12:08:43 UTC
Created attachment 254489 [details]
emerge --info =app-crypt/pinentry-0.8.0
Comment 2 Alex Buell 2010-11-16 12:08:59 UTC
Created attachment 254491 [details]
merge -pqv =app-crypt/pinentry-0.8.0
Comment 3 Alex Buell 2010-11-16 12:09:29 UTC
Created attachment 254493 [details]
/var/tmp/portage/app-crypt/pinentry-0.8.0/temp/build.log
Comment 4 Alex Buell 2010-11-16 12:09:46 UTC
Created attachment 254495 [details]
/var/tmp/portage/app-crypt/pinentry-0.8.0/temp/environment
Comment 5 Rafał Mużyło 2010-11-16 12:52:07 UTC
Update more often.
The error message is:
Package libpng12 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libpng12.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libpng12', required by 'cairo', not found
See postint message for libpng and forum.
Comment 6 Alex Buell 2010-11-16 13:48:09 UTC
# eix libpng
[I] media-libs/libpng
     Available versions:  
        (1.2)   1.2.44
        (0)     1.4.3 ~1.4.4
     Installed versions:  1.2.44(1.2)(08:55:56 16/11/10) 1.4.3(20:53:52 15/11/10)
     Homepage:            http://www.libpng.org/
     Description:         Portable Network Graphics library

Already installed. Your response?
Comment 7 Samuli Suominen gentoo-dev 2010-11-16 14:51:46 UTC
> Package 'libpng12', required by 'cairo', not found

so... re-emerge cairo
Comment 8 Alex Buell 2010-11-16 15:16:01 UTC
The mystery remains: why didn't portage emerge cairo before pinentry if it needed it? 
Comment 9 Alex Buell 2010-11-16 20:14:21 UTC
I stumbled into another package that needs the same thing. This is symptomatic of a underlying problem; that packages should know to get cairo built if it's needed. 

This time it was: x11-themes/gtk-engines-2.20.1-r1 
Comment 10 Alex Buell 2010-11-16 20:15:42 UTC
My point is that emerge should smoothly work out the dependencies and get cairo built if it's needed by those packages. O
Comment 11 Jeroen Roovers gentoo-dev 2010-11-16 21:13:49 UTC
(In reply to comment #10)
> My point is that emerge should smoothly work out the dependencies and get cairo
> built if it's needed by those packages. O

So this should be a duplicate of bug #1991 then?
Comment 12 Alex Buell 2010-11-16 21:23:28 UTC
Most likely, yes. Although I've been advised that a revdep rebuild can sort this one out easily seeing as libpng 1.23 / 1.43 upgrade was the root cause of this problem.
Comment 13 Jeroen Roovers gentoo-dev 2010-11-17 15:33:42 UTC
Yes, revdep-rebuild usually has that effect.

*** This bug has been marked as a duplicate of bug 1991 ***