Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 345425 - net-print/cups 1.3.11-r3: cannot be installed on new gentoo system because of circular dependance with poppler
Summary: net-print/cups 1.3.11-r3: cannot be installed on new gentoo system because of...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords: InVCS
: 346117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-14 17:22 UTC by Konstantin Lysenko
Modified: 2010-12-01 13:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Lysenko 2010-11-14 17:22:02 UTC
if you try to install stable net-print/cups 1.3.11-r3 on new gentoo system then compilation fail because cups cannot find /usr/bin/pdftpps.

/usr/pin/pdftops this is file from app-text/poppler

for install app-text/poppler you should install net-print/cups 1.3.11-r3 first.

But you can't install net-print/cups 1.3.11-r3 because it need /usr/pin/pdftops from app-text/poppler etc.

Reproducible: Always

Steps to Reproduce:
1. install new gentoo linux.
2. run emerge cups


Actual Results:  
compilation fails because of unsatisfied dependence to pdftops

Expected Results:  
installed cups
Comment 1 Konstantin Lysenko 2010-11-14 17:31:49 UTC
workaround: install unstable cups-1.4.4-r2
It's very strange that stable cups cannot be installed, but unstable can. This type of logic too complex for me.

May be stable and unstable cups should be exchanged?
Comment 2 Kenneth Wilke 2010-11-17 15:58:27 UTC
My workaround was to check the packages available here:
http://packages.gentoo.org/package/net-print/cups

Installing cups r2 (instead of the default r3) with "emerge =net-print/cups-1.3.11-r2" will install cups and app-text/poppler without an issue

After that you can emerge the r3 version with just "emerge cups" and you'll be good to go, would be nice to have the circular dependency corrected though.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-11-20 00:38:45 UTC
*** Bug 346117 has been marked as a duplicate of this bug. ***
Comment 4 Alin Năstac (RETIRED) gentoo-dev 2010-11-28 10:13:56 UTC
Another workaround is to run "emerge -1 poppler" before updating cups.
Comment 5 Konstantin Lysenko 2010-11-28 10:43:02 UTC
I doubt that "run "emerge -1 poppler" before updating cups." will work, because poppler depend from cups, but in this bug you haven't cups installed yet.
Comment 6 Kris Hepler 2010-11-29 11:37:01 UTC
Cups is brought in by qt and gtk+ libraries.  Emerge cups and poppler like so:

USE="-qt4 -cairo" emerge -1 poppler && emerge -N1 poppler

And even though it doesn't solve the problem, the net-print/cups-1.3.11-r3 ebuild needs a poppler DEPEND.
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2010-12-01 13:04:34 UTC
Fixed properly in -r4