Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 344927 - x11-misc/shared-mime-info-0.80 is missing DEPEND on dev-perl/XML-Parser
Summary: x11-misc/shared-mime-info-0.80 is missing DEPEND on dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-10 13:57 UTC by Justin Lecher
Modified: 2010-11-10 14:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2010-11-10 13:57:25 UTC
>>> Emerging (7 of 11) x11-misc/shared-mime-info-0.80
 * CPV:  x11-misc/shared-mime-info-0.80
 * REPO: gentoo_prefix
 * USE:  amd64 elibc_glibc kernel_linux prefix userland_GNU
>>> Unpacking source...
>>> Unpacking shared-mime-info-0.80.tar.bz2 to /opt/scisoft64/var/tmp/portage/x11-misc/shared-mime-info-0.80/work
>>> Source unpacked in /opt/scisoft64/var/tmp/portage/x11-misc/shared-mime-info-0.80/work
>>> Preparing source in /opt/scisoft64/var/tmp/portage/x11-misc/shared-mime-info-0.80/work/shared-mime-info-0.80 ...
>>> Source prepared.
>>> Configuring source in /opt/scisoft64/var/tmp/portage/x11-misc/shared-mime-info-0.80/work/shared-mime-info-0.80 ...
./configure --prefix=/opt/scisoft64/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/opt/scisoft64/usr/share/man --infodir=/opt/scisoft64/usr/share/info --datadir=/opt/scisoft64/usr/share --sysconfdir=/opt/scisoft64/etc --localstatedir=/opt/scisoft64/var/lib --libdir=/opt/scisoft64/usr/lib --disable-dependency-tracking --disable-update-mimedb
checking for a BSD-compatible install... /opt/scisoft64/usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /opt/scisoft64/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking for an ANSI C-conforming const... yes
checking whether NLS is requested... yes
checking for intltool >= 0.35.0... 0.41.1 found
checking for intltool-update... /opt/scisoft64/usr/bin/intltool-update
checking for intltool-merge... /opt/scisoft64/usr/bin/intltool-merge
checking for intltool-extract... /opt/scisoft64/usr/bin/intltool-extract
checking for xgettext... /opt/scisoft64/usr/bin/xgettext
checking for msgmerge... /opt/scisoft64/usr/bin/msgmerge
checking for msgfmt... /opt/scisoft64/usr/bin/msgfmt
checking for gmsgfmt... /opt/scisoft64/usr/bin/gmsgfmt
checking for perl... /opt/scisoft64/usr/bin/perl
checking for perl >= 5.8.1... 5.12.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /opt/scisoft64/var/tmp/portage/x11-misc/shared-mime-info-0.80/work/shared-mime-info-0.80/config.log
 * ERROR: x11-misc/shared-mime-info-0.80 failed:
 *   econf failed
 * 
 * Call stack:
 *     ebuild.sh, line  53:  Called call-ebuildshell 'src_configure'
 *   environment, line 249:  Called src_configure
 *   environment, line 355:  Called econf '--disable-dependency-tracking' '--disable-update-mimedb'
 *     ebuild.sh, line 591:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =x11-misc/shared-mime-info-0.80',
 * the complete build log and the output of 'emerge -pqv =x11-misc/shared-mime-info-0.80'.

I discovered this on prefix, but probably the same on normal installs.
Comment 1 Justin Lecher gentoo-dev 2010-11-10 14:09:41 UTC
 # perl -V
Summary of my perl5 (revision 5 version 12 subversion 1) configuration:
   
  Platform:
    osname=linux, osvers=2.6.31.12-0.2-desktop, archname=x86_64-linux
    uname='linux bes 2.6.31.12-0.2-desktop #1 smp preempt 2010-03-16 21:25:39 +0100 x86_64 intel(r) xeon(r) cpu e5504 @ 2.00ghz genuineintel gnulinux '
    config_args='-des -Duseshrplib -Darchname=x86_64-linux -Dcc=x86_64-pc-linux-gnu-gcc -Doptimize=-O2 -march=core2 -pipe -Dprefix=/opt/scisoft64/usr -Dinstallprefix=/opt/scisoft64/usr -Dsiteprefix=/opt/scisoft64/usr -Dvendorprefix=/opt/scisoft64/usr -Dscriptdir=/opt/scisoft64/usr/bin -Dprivlib=/opt/scisoft64/usr/lib/perl5/5.12.1 -Darchlib=/opt/scisoft64/usr/lib/perl5/5.12.1/x86_64-linux -Dsitelib=/opt/scisoft64/usr/lib/perl5/site_perl/5.12.1 -Dsitearch=/opt/scisoft64/usr/lib/perl5/site_perl/5.12.1/x86_64-linux -Dvendorlib=/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1 -Dvendorarch=/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux -Dman1dir=/opt/scisoft64/usr/share/man/man1 -Dman3dir=/opt/scisoft64/usr/share/man/man3 -Dsiteman1dir=/opt/scisoft64/usr/share/man/man1 -Dsiteman3dir=/opt/scisoft64/usr/share/man/man3 -Dvendorman1dir=/opt/scisoft64/usr/share/man/man1 -Dvendorman3dir=/opt/scisoft64/usr/share/man/man3 -Dman1ext=1 -Dman3ext=3pm -Dlibperl=libperl.so.5.12.1 -Dlocincpth=/opt/scisoft64/usr/include  -Dglibpth=/opt/scisoft64/lib /opt/scisoft64/usr/lib  -Duselargefiles -Dd_semctl_semun -Dcf_by=Gentoo -Dmyhostname=localhost -Dperladmin=${PORTAGE_ROOT_USER}@localhost -Dinstallusrbinperl=n -Ud_csh -Uusenm -Dccdlflags=-rdynamic -Di_ndbm -Di_gdbm -Di_db -Dinc_version_list=5.12.0 5.12.0/x86_64-linux -Dusrinc=/usr/include -Dlibpth=/opt/scisoft64/lib /opt/scisoft64/usr/lib /lib /usr/lib /lib64 /usr/lib64 /lib32 /usr/lib32'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='x86_64-pc-linux-gnu-gcc', ccflags ='-fno-strict-aliasing -pipe -I/opt/scisoft64/usr/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -march=core2 -pipe',
    cppflags='-fno-strict-aliasing -pipe -I/opt/scisoft64/usr/include'
    ccversion='', gccversion='4.4.3', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='x86_64-pc-linux-gnu-gcc', ldflags =''
    libpth=/opt/scisoft64/lib /opt/scisoft64/usr/lib /lib /usr/lib /lib64 /usr/lib64
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.10.1.so, so=so, useshrplib=true, libperl=libperl.so.5.12.1
    gnulibc_version='2.10.1'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -march=core2 -pipe'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO
                        USE_PERL_ATOF
  Locally applied patches:
	0001-gentoo_MakeMaker-RUNPATH.diff
	0002-gentoo_config__over.diff
	0003-gentoo_cpan__definstalldirs.diff
	0004-gentoo_cpanplus__definstalldirs.diff
	0005-gentoo_create-libperl-soname.diff
	0006-gentoo_MakeMaker-delete__packlist.diff
	0007-fixes_8d66b3f9__h2hp__fix.diff
	0008-fixes_ef9df645__glob__crashes__when__File__Glob__is__empty.diff
	0009-fixes_e3d01d03__Naif__calls__segfault__T__PRTOBJ__of__the__stock__typemap.diff
  Built under linux
  Compiled at Sep 16 2010 13:06:33
  @INC:
    /opt/scisoft64/usr/lib/perl5/site_perl/5.12.1/x86_64-linux
    /opt/scisoft64/usr/lib/perl5/site_perl/5.12.1
    /opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux
    /opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1
    /opt/scisoft64/usr/lib/perl5/5.12.1/x86_64-linux
    /opt/scisoft64/usr/lib/perl5/5.12.1
    /opt/scisoft64/usr/lib/perl5/site_perl
    /opt/scisoft64/usr/lib/perl5/vendor_perl
    .
Comment 2 Justin Lecher gentoo-dev 2010-11-10 14:09:54 UTC
 # qlist XML-Parser
/opt/scisoft64/usr/share/doc/XML-Parser-2.40/README.bz2
/opt/scisoft64/usr/share/doc/XML-Parser-2.40/Changes.bz2
/opt/scisoft64/usr/lib/debug/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/auto/XML/Parser/Expat/Expat.so.debug
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/LWPExternEnt.pl
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-5.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/Japanese_Encodings.msg
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/x-sjis-jdk117.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-7.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-9.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/README
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/x-sjis-jisx0221.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/windows-1252.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-4.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/x-euc-jp-unicode.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/x-euc-jp-jisx0221.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/euc-kr.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/ibm866.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/big5.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-2.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/x-sjis-cp932.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/windows-1251.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/x-sjis-unicode.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/windows-1255.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/windows-1250.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-8.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/koi8-r.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Encodings/iso-8859-3.enc
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Expat.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Style/Objects.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Style/Stream.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Style/Debug.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Style/Subs.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser/Style/Tree.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/XML/Parser.pm
/opt/scisoft64/usr/lib/perl5/vendor_perl/5.12.1/x86_64-linux/auto/XML/Parser/Expat/Expat.so
Comment 3 Jeroen Roovers gentoo-dev 2010-11-10 14:20:39 UTC

*** This bug has been marked as a duplicate of bug 41124 ***