Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 344833 - app-admin/python-updater-0.8 rebuilds packages inheriting gnome-python-common.eclass
Summary: app-admin/python-updater-0.8 rebuilds packages inheriting gnome-python-common...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 348181 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-09 19:07 UTC by Sebastian Pipping
Modified: 2011-02-26 17:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of "python-updater -p -v -v -v" (python-updater-p-v-v-v.txt,230.52 KB, text/plain)
2010-11-15 14:05 UTC, Sebastian Pipping
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Pipping gentoo-dev 2010-11-09 19:07:30 UTC
Even after a previous successful run, python-updater updates these packages again:

[ebuild   R   ] dev-python/libgnomecanvas-python-2.28.1  USE="-examples" 0 kB
[ebuild   R   ] dev-python/gconf-python-2.28.1  USE="-examples" 0 kB
[ebuild   R   ] dev-python/gnome-vfs-python-2.28.1  USE="-doc -examples" 0 kB
[ebuild   R   ] dev-python/libbonobo-python-2.28.1  USE="-examples" 0 kB
[ebuild   R   ] dev-python/gtkmozembed-python-2.25.3  USE="-debug -doc" 0 kB
[ebuild   R   ] dev-python/libgnome-python-2.28.1  USE="-examples" 0 kB

It does so even when called with --disable-manual.  Is that expected?
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-11-15 02:41:30 UTC
Please attach output of: python-updater -p -v -v -v
Comment 2 Sebastian Pipping gentoo-dev 2010-11-15 14:05:26 UTC
Created attachment 254381 [details]
Output of "python-updater -p -v -v -v"

(In reply to comment #1)
> Please attach output of: python-updater -p -v -v -v

There it is.
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-11-15 14:16:37 UTC
python-updater extracts RESTRICT_PYTHON_ABIS from ebuilds, but these ebuilds don't set RESTRICT_PYTHON_ABIS and instead inherit gnome-python-common.eclass, which sets RESTRICT_PYTHON_ABIS="3.*".

Possible solutions:
- Wait for a new EAPI containing appropriate features, which would allow to use USE flags to represent Python ABI dependencies. Then python-updater wouldn't be needed for packages supporting installation for multiple Python ABIs.
- Set RESTRICT_PYTHON_ABIS in ebuilds. It would be needed only in current EAPIs. gnome-python-common.eclass could still set RESTRICT_PYTHON_ABIS.
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-12-07 13:13:09 UTC
I think mass updating ebuilds to set eclass variables before inherit is the right thing to do.
Comment 5 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-12-08 18:59:58 UTC
*** Bug 348181 has been marked as a duplicate of this bug. ***
Comment 6 Gilles Dartiguelongue gentoo-dev 2011-02-26 13:44:51 UTC
The appropriate variables are not set in all latest ~arch ebuilds inheriting the eclass. Please reopen if I've missed anything. Thanks for reporting..
Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2011-02-26 17:10:23 UTC
(In reply to comment #6)
> The appropriate variables are not set in all latest ~arch ebuilds inheriting
> the eclass.

s/not/now/ :)