Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 343541 - media-fonts/urw-fonts-2.4.9 emerge fails: failure unpacking
Summary: media-fonts/urw-fonts-2.4.9 emerge fails: failure unpacking
Status: RESOLVED DUPLICATE of bug 1991
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 16:53 UTC by John L. Poole
Modified: 2010-11-01 06:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info-Bug343541.txt,4.26 KB, text/plain)
2010-10-31 17:02 UTC, John L. Poole
Details
build.log (build.log,1.84 KB, text/plain)
2010-10-31 17:02 UTC, John L. Poole
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John L. Poole 2010-10-31 16:53:57 UTC
ERROR: media-fonts/urw-fonts-2.4.9 failed:
 *   failure unpacking /var/tmp/portage/media-fonts/urw-fonts-2.4.9/distdir/urw-fonts-2.4-9.fc13.src.rpm


Reproducible: Always

Steps to Reproduce:
1.media-fonts/urw-fonts-2.4.9


Actual Results:  
>>> Emerging (1 of 13) media-fonts/urw-fonts-2.4.9
 * urw-fonts-2.4-9.fc13.src.rpm RMD160 SHA1 SHA256 size ;-) ...                         [ ok ]
 * checking ebuild checksums ;-) ...                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                  [ ok ]
 * CPV:  media-fonts/urw-fonts-2.4.9
 * REPO: gentoo
 * USE:  X amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
>>> Unpacking urw-fonts-2.4-9.fc13.src.rpm to /var/tmp/portage/media-fonts/urw-fonts-2.4.9/work
rpm2cpio: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory
rpm2tar: /var/tmp/portage/media-fonts/urw-fonts-2.4.9/distdir/urw-fonts-2.4-9.fc13.src.rpm: failed to extract cpio via rpm2cpio (not actually an RPM?)
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
 * ERROR: media-fonts/urw-fonts-2.4.9 failed:
 *   failure unpacking /var/tmp/portage/media-fonts/urw-fonts-2.4.9/distdir/urw-fonts-2.4-9.fc13.src.rpm
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_unpack
 *   environment, line 2775:  Called rpm_src_unpack
 *   environment, line 2690:  Called srcrpm_unpack 'urw-fonts-2.4-9.fc13.src.rpm'
 *   environment, line 2780:  Called rpm_unpack 'urw-fonts-2.4-9.fc13.src.rpm'
 *   environment, line 2718:  Called die
 * The specific snippet of code:
 *           rpm2tar -O "${a}" | tar xf - || die "failure unpacking ${a}";
 *
 * If you need support, post the output of 'emerge --info =media-fonts/urw-fonts-2.4.9',
 * the complete build log and the output of 'emerge -pqv =media-fonts/urw-fonts-2.4.9'.
 * The complete build log is located at '/var/tmp/portage/media-fonts/urw-fonts-2.4.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-fonts/urw-fonts-2.4.9/temp/environment'.
 * S: '/var/tmp/portage/media-fonts/urw-fonts-2.4.9/work'

>>> Failed to emerge media-fonts/urw-fonts-2.4.9, Log file:

>>>  '/var/tmp/portage/media-fonts/urw-fonts-2.4.9/temp/build.log'


Expected Results:  
successful install

I performed:
hermes ~ # locate urw-fonts-2.4-9.fc13.src.rpm
/usr/portage/distfiles/urw-fonts-2.4-9.fc13.src.rpm
hermes ~ # rm /usr/portage/distfiles/urw-fonts-2.4-9.fc13.src.rpm
hermes ~ # locate urw-fonts-2.4-9.fc13.src.rpm

in order to force a new download just in case the download was corrupted.
then I performed:
 emerge media-fonts/urw-fonts
which started a download, but the unpack/unzip was unsuccessful, again.

Supporting files to follow.
Comment 1 John L. Poole 2010-10-31 17:01:57 UTC
hermes ~ # emerge -pqv =media-fonts/urw-fonts-2.4.9
[ebuild  N    ] media-fonts/urw-fonts-2.4.9  USE="X"
hermes ~ #
Comment 2 John L. Poole 2010-10-31 17:02:36 UTC
Created attachment 252681 [details]
emerge --info
Comment 3 John L. Poole 2010-10-31 17:02:48 UTC
Created attachment 252683 [details]
build.log
Comment 4 John L. Poole 2010-10-31 17:11:56 UTC
hermes ~ # eix app-arch/rpm
[I] app-arch/rpm
     Available versions:  4.4.6-r7 ~4.4.7-r4 ~4.4.7-r5 ~4.4.7-r6 ~4.8.1 [M]~5.1.6 {acl berkdb bzip2 caps doc lua magic neon nls pcre perl python selinux sqlite}
     Installed versions:  4.4.6-r7(12:43:41 09/11/10)(nls perl python -doc -sqlite)
     Homepage:            http://rpm5.org/
     Description:         RPM Package Manager

[I] app-arch/rpm2targz
     Available versions:  9.0.0.3g ~9.0.0.4g {userland_GNU}
     Installed versions:  9.0.0.3g(08:05:57 10/31/10)(userland_GNU)
     Homepage:            http://www.slackware.com/config/packages.php
     Description:         Convert a .rpm file to a .tar.gz archive

Found 2 matches.
hermes ~ #
Comment 5 John L. Poole 2010-10-31 17:18:13 UTC
Here's my work-around:
I unmasked  app-arch/rpm2targz so I would pull in version ~9.0.0.4g; I emerged app-arch/rpm2targz so now I have:
 
[I] app-arch/rpm2targz
     Available versions:  9.0.0.3g (~)9.0.0.4g {userland_GNU}
     Installed versions:  9.0.0.4g(09:19:04 10/31/10)
     Homepage:            http://www.slackware.com/config/packages.php
     Description:         Convert a .rpm file to a .tar.gz archive

I then attempted with success:

emerge media-fonts/urw-fonts
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-fonts/urw-fonts-2.4.9
 * urw-fonts-2.4-9.fc13.src.rpm RMD160 SHA1 SHA256 size ;-) ...          [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  media-fonts/urw-fonts-2.4.9
 * REPO: gentoo
 * USE:  X amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
>>> Unpacking urw-fonts-2.4-9.fc13.src.rpm to /var/tmp/portage/media-fonts/urw-fonts-2.4.9/work
>>> Unpacking ./urw-fonts-1.0.7pre44.tar.bz2 to /var/tmp/portage/media-fonts/urw-fonts-2.4.9/work
>>> Source unpacked in /var/tmp/portage/media-fonts/urw-fonts-2.4.9/work
>>> Compiling source in /var/tmp/portage/media-fonts/urw-fonts-2.4.9/work ...
>>> Source compiled.
...

Seems that perhaps app-arch-rpm2targz version 9.0.0.4g should be a prerequisite to media-fonts/urw-fonts-2.4.9.

Leaving this Bug as NEW so it might catch the attention of the maintainer for the package media-fonts/urw-fonts-2.4.9; otherwise the classification of this bug should be Works for Me.
Comment 6 Michael Weber (RETIRED) gentoo-dev 2010-11-01 02:38:17 UTC
This is just a problem with rpm2cpio and would have been solved by a revdep-rebuild run (which would have reemerged the broken rpm2cpio package).

Can you please reemerge your old version of rpm2cpio and try againg? Thanks
Comment 7 Jeroen Roovers gentoo-dev 2010-11-01 06:21:16 UTC
We can resolve this more elegantly.
Comment 8 Jeroen Roovers gentoo-dev 2010-11-01 06:21:28 UTC

*** This bug has been marked as a duplicate of bug 1991 ***