Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 343319 - net-filter/MailScanner: error after updating perl to 5.12
Summary: net-filter/MailScanner: error after updating perl to 5.12
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 343321 (view as bug list)
Depends on:
Reported: 2010-10-30 06:41 UTC by George Papadopoulos
Modified: 2010-11-01 04:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description George Papadopoulos 2010-10-30 06:41:09 UTC
After updating perl and running perl-cleaner --all, I get this error when trying to start MailScanner :

 /etc/init.d/MailScanner start
 * Starting MailScanner ...
Can't load '/usr/lib/perl5/5.12.2/i686-linux/auto/Compress/Raw/Zlib/' for module Compress::Raw::Zlib: /usr/lib/perl5/5.12.2/i686-linux/auto/Compress/Raw/Zlib/ undefined symbol: deflateTune at /usr/lib/perl5/5.12.2/i686-linux/ line 200.
 at /usr/lib/perl5/vendor_perl/5.12.2/Archive/ line 12
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.12.2/Archive/ line 12.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.12.2/Archive/ line 12.
Compilation failed in require at /usr/lib/MailScanner/MailScanner/ line 48.
BEGIN failed--compilation aborted at /usr/lib/MailScanner/MailScanner/ line 48.
Compilation failed in require at /usr/sbin/MailScanner line 108.
BEGIN failed--compilation aborted at /usr/sbin/MailScanner line 108.      [ !! ]

My gentoo kernel version is :

Linux t-rex 2.6.35-gentoo-r4 #4 PREEMPT Sun Aug 29 19:36:27 EEST 2010 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz GenuineIntel GNU/Linux

Reproducible: Always

Steps to Reproduce:
1.Install MailScanner
2.Update to perl 5.12.2-r1
3./etc/init.d/MailScanner restart or reboot

Same thing happened with older version of MailScanner whick worked just before updating to the new perl version.
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2010-10-30 07:39:10 UTC
*** Bug 343321 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2010-10-30 07:40:50 UTC
MailScanner is not in Portage. Report it to upstream.
Comment 3 Graham Murray 2010-10-30 14:19:51 UTC
You did run 'perl-cleaner --all' after upgrading to perl-5.12.2 didn't you?
Comment 4 George Papadopoulos 2010-10-31 10:03:57 UTC
course, I did. I ran perl-cleaner -all. The problem is that indeed MailScanner is not in portage but a friend of mine runs it perfectly well on a gentoo linux server even after updating perl. And it used to work fine before the perl upgrade on gentoo box as well. 

I might try contacting the developer of MailScanner, see if I get something out of it. For the time being I cannot access my mail, even though postfix is getting them.
Comment 5 George Papadopoulos 2010-11-01 04:58:20 UTC
Downgraded to 5.8.8-r8 and all seems to be working now. There seems to some issue with perl-5.12.2 here!!