Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 343 - xscreensaver won't compile..
Summary: xscreensaver won't compile..
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-01-26 10:36 UTC by Rodney Gordon II
Modified: 2003-02-01 23:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rodney Gordon II 2002-01-26 10:36:50 UTC
I've tried to emerge many versions; here is the error it keeps giving me..

demo-Xm-widgets.c:651: `XmNbottomWidget' undeclared (first use in this function)
demo-Xm-widgets.c:653: `XmNleftOffset' undeclared (first use in this function)
demo-Xm-widgets.c:654: `XmATTACH_WIDGET' undeclared (first use in this function)
demo-Xm-widgets.c:655: `XmNrightOffset' undeclared (first use in this function)
demo-Xm-widgets.c:656: `XmNrightWidget' undeclared (first use in this function)
demo-Xm-widgets.c:662: `XmNtopWidget' undeclared (first use in this function)
demo-Xm-widgets.c:664: `XmNbottomOffset' undeclared (first use in this function)
demo-Xm-widgets.c:742: `XmNleftWidget' undeclared (first use in this function)
make[1]: *** [demo-Xm-widgets.o] Error 1
make[1]: Leaving directory
make: *** [default] Error 5

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 39, Exitcode 2
!!! (no error message)

!!! emerge aborting on 
/usr/portage/app-misc/xscreensaver/xscreensaver-4.00.ebuild .
Comment 1 CFuga 2002-01-27 23:53:44 UTC
All the Xm* functions are from Motif. The bug could be solved by emerging
openmotif or deleting motif from USE.
Comment 2 Daniel Robbins (RETIRED) gentoo-dev 2002-02-01 15:41:33 UTC
I think this problem is that "motif" *isn't* in USE, but xscreensaver defaults
to motif.  This points to a deficiency in our USE? ( ) dependencies where we
need to support more advanced features, so I'm assigning it to gbevin.
Comment 3 Martin Schlemmer (RETIRED) gentoo-dev 2002-02-27 17:21:59 UTC
works fine here without motif. have you tried 4.0.1 yet ?
Comment 4 Geert Bevin 2002-03-18 02:05:39 UTC
works with 4.01-r1
Comment 5 Hamilton Coutinho 2003-01-23 13:20:09 UTC
I think the problem is openmotif does not create the symlink /usr/include/Xm -> 
../X11R6/include/Xm. Another alternative is put the flag -I/usr/X11R6/include in xscreensaver. 
Comment 6 Jason Shoemaker (RETIRED) gentoo-dev 2003-02-01 23:29:16 UTC

Closing this old bug because there are newer xscreensaver ebuilds.