Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 342721 - sys-apps/portage-2.1.8.3: /usr/lib/portage/bin/misc-functions.sh: fails to build rpm from ebuild with missing $FILESDIR
Summary: sys-apps/portage-2.1.8.3: /usr/lib/portage/bin/misc-functions.sh: fails to bu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 335925
  Show dependency tree
 
Reported: 2010-10-26 08:11 UTC by Sergey S. Starikoff
Modified: 2010-10-31 19:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey S. Starikoff 2010-10-26 08:11:47 UTC
ebuild utility fails to finish 'rpm' command after compiling (while packing rpm-package) if the package directory contains no files subdirectory.
If the files subdirectory exists, it packs the archiv correctly.

Reproducible: Always

Steps to Reproduce:
For example:
1. ebuild /usr/portage/media-sound/mp3unicode/mp3unicode-1.2.ebuild
Actual Results:  
>>> Completed installing mp3unicode-1.2 into /var/tmp/portage/media-sound/mp3unicode-1.2/image/

strip: i686-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/mp3unicode
ecompressdir: bzip2 -9 /usr/share/man
tar: Removing leading `/' from member names
tar: /usr/portage/media-sound/mp3unicode/files: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
 * ERROR: media-sound/mp3unicode-1.2 failed:
 *   Failed to create base rpm tarball.
 * 
 * Call stack:
 *   misc-functions.sh, line 804:  Called dyn_rpm
 *   misc-functions.sh, line 777:  Called dyn_spec
 *   misc-functions.sh, line 740:  Called die
 * The specific snippet of code:
 *   	tar czf "${sources_dir}/${PF}.tar.gz" \
 *   		"${EBUILD}" "${FILESDIR}" || \
 *   		die "Failed to create base rpm tarball."
 * 
 * If you need support, post the output of 'emerge --info =media-sound/mp3unicode-1.2',
 * the complete build log and the output of 'emerge -pqv =media-sound/mp3unicode-1.2'.
 * The complete build log is located at '/var/tmp/portage/media-sound/mp3unicode-1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/mp3unicode-1.2/temp/environment'.
 * S: '/var/tmp/portage/media-sound/mp3unicode-1.2/work/mp3unicode-1.2'

Expected Results:  
Successfully built rpm package.

# emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.35-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r4-i686-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 25 Oct 2010 03:50:02 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/env.d/50glib2 /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildsyspkg collision-protect distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.corbina.net/pub/Linux/gentoo/                   ftp://mirror.aiya.ru/pub/gentoo/                 ftp://ftp.org.kemsu.ru/gentoo/                 http://ftp.chg.ru/pub/Linux/distributions/gentoo/                 ftp://ftp.chg.ru/pub/Linux/distributions/gentoo/"
LANG="en_US"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-ftn"
SYNC="   rsync://rsync.ru.gentoo.org/gentoo-portage"
USE="X a52 ac3 acl alsa avi berkdb bzip2 cdr cli cracklib crypt cups cxx dbus djvu dri dvd flac fortran gdbm gif gtk iconv jpeg jpeg2k modules mp3 mudflap ncurses nls nptl nptlonly ogg openmp pam pcre pdf perl png pppd python qt3support readline session ssl sysfs tcpd tiff vorbis x86 xcb xorg xulrunner zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="sis" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2010-10-26 14:18:50 UTC
What version of tar? 1.24? Does downgrading to 1.23-r3 help? Duplicate of bug 342735?
Comment 2 Samuli Suominen gentoo-dev 2010-10-26 14:19:07 UTC
*downgrading to 1.23-r4, sorry
Comment 3 Samuli Suominen gentoo-dev 2010-10-26 15:45:39 UTC

*** This bug has been marked as a duplicate of bug 342735 ***
Comment 4 Sergey S. Starikoff 2010-10-27 06:02:46 UTC
(In reply to comment #1)
> What version of tar? 1.24? Does downgrading to 1.23-r3 help? Duplicate of bug
> 342735?
> 
No. Current stable tar (app-arch/tar-1.23-r2, last sync this monday, today sync prompted it status).

Attemp to build rpm for tar package also failed with the following error:

/usr/lib/portage/bin/misc-functions.sh: line 778: rpmbuild: command not found
 * ERROR: app-arch/tar-1.23-r2 failed:
 *   Failed to integrate rpm spec file
 * 
 * Call stack:
 *   misc-functions.sh, line 804:  Called dyn_rpm
 *   misc-functions.sh, line 778:  Called die
 * The specific snippet of code:
 *   	rpmbuild -bb --clean --rmsource "${PF}.spec" || die "Failed to integrate rpm spec file"
 * 
 * If you need support, post the output of 'emerge --info =app-arch/tar-1.23-r2',
 * the complete build log and the output of 'emerge -pqv =app-arch/tar-1.23-r2'.
 * The complete build log is located at '/var/tmp/portage/app-arch/tar-1.23-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-arch/tar-1.23-r2/temp/environment'.
 * S: '/var/tmp/portage/app-arch/tar-1.23-r2/work/tar-1.23'
Comment 5 SpanKY gentoo-dev 2010-10-28 21:43:54 UTC
do you have rpm & rpmbuild installed ?  if not, this isnt a bug in portage.  you need to install rpm if you expect to be able to build rpms.
Comment 6 Sergey S. Starikoff 2010-10-29 09:32:40 UTC
Excuse me, I was a little bit mistaken.
Oryginally the bug was taken on my home PC. Where I've already built rpm's
And after that, before report, I've reproduced it on my workstation.
On my workstation app-arch/rpm really wasn't installed.
After I've installed it, I've the app-arch/tar rpm was packed, but media-sound/mp3unicode failed with the same error:

tar: /usr/portage/media-sound/mp3unicode/files: Cannot stat: No such file or directory
Comment 8 Zac Medico gentoo-dev 2010-10-31 18:50:20 UTC
This is fixed in 2.1.9.24 and 2.2.0_alpha3.
Comment 9 Samuli Suominen gentoo-dev 2010-10-31 19:17:21 UTC
thanks