Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34238 - what about a "minimal" mplayer build
Summary: what about a "minimal" mplayer build
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-23 22:16 UTC by Chris Janscen
Modified: 2004-02-25 16:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Janscen 2003-11-23 22:16:32 UTC
How about a minimal mplayer build (using the minimal USE flag), which only
requires the real basic stuff, like glibc and alsa/oss...

Right now I usually just do an emerge -O mplayer, or go and butcher the ebuild
so that it does not download 600 dependencies that I will never need, example:

emerge -vp mplayer

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] media-sound/cdparanoia-3.9.8  
[ebuild  N    ] media-libs/libungif-4.1.0.1b  +X +gif 
[ebuild  N    ] dev-lang/nasm-0.98.38  -doc -build 
[ebuild  N    ] media-libs/giflib-4.1.0-r3  +X +gif 
[ebuild  N    ] media-libs/libsndfile-1.0.5  
[ebuild  N    ] media-libs/faad2-2.0_rc1  -xmms 
[ebuild  N    ] media-libs/win32codecs-20031001  +quicktime 
[ebuild  N    ] sys-libs/lib-compat-1.3  
[ebuild  N    ] media-libs/divx4linux-20030428-r1  
[ebuild  N    ] media-libs/xvid-0.9.2-r1  
[ebuild   R   ] media-video/mplayer-1.0_pre2  -dga -oss -xmms +jpeg -3dfx +sse
-matrox -sdl +X -svga -ggi -oggvorbis +3dnow -aalib -gnome +xv +opengl -truetype
-dvd -gtk +gif -esd -fbcon -encode +alsa -directfb -arts -dvb +gtk2 -samba -lirc
-matroska -debug -joystick 

If someone wants to just use mplayer to play mp3s, divx movies, xvid movies,
wave files, and mpeg movies (and most other common format), they do not need
_ANY_ of the dependencies listed, just the mplayer tar.bz2 (which comes with the
libav library and others). I propose to just add the minimal flag (as used in
vim) to make this an option for people.

If anyone thinks this is a good idea I'll try to modify the ebuild and post it here.

thanks for your time!

Reproducible: Always
Steps to Reproduce:
1. USE="*" emerge -vp mplayer

2. emerge -O mplayer

3. mplayer sound.mp3 divx-video.avi xvid-video.avi mpeg-video.mpeg
Actual Results:  
Mplayer plays all these audio/video formats just fine, without the need of all
these crazy additional libraries.

Expected Results:  
Mplayer will not compile because of missing dependencies
Comment 1 Brian Harring gentoo-dev 2004-02-25 16:19:45 UTC
Mplayer's deps are completely dependant on the user's use flags.  What you're asking for is a duplicate mplayer ebuild w/ less options (or intentionally ignoring user use flags), which is not a good solution.
Meanwhile, closing this due to it's age (and lack of activity).  Feel free to reopen this if you have an idea of how else to do it.