Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 341757 - x11-misc/appmenu-gtk-module keywording (was: New package: appmenu-gtk)
Summary: x11-misc/appmenu-gtk-module keywording (was: New package: appmenu-gtk)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All All
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL: https://bugs.launchpad.net/appmenu-gt...
Whiteboard:
Keywords: CC-ARCHES, KEYWORDREQ
Depends on:
Blocks: 428792 421231 685498
  Show dependency tree
 
Reported: 2010-10-19 11:35 UTC by Malte E.
Modified: 2020-09-07 17:58 UTC (History)
7 users (show)

See Also:
Package list:
x11-misc/appmenu-gtk-module-0.7.3-r1 arm arm64 ppc64 x86 kde-plasma/plasma-meta-5.19.5 ppc64
Runtime testing required: ---
nattka: sanity-check+


Attachments
kde-misc/plasma-widget-menubar-0.1.13 (plasma-widget-menubar-0.1.13.ebuild,491 bytes, text/plain)
2010-10-19 11:36 UTC, Malte E.
no flags Details
qt-4.7.0-appmenu.patch (qt-4.7.0-appmenu.patch,132.76 KB, text/plain)
2010-10-20 18:22 UTC, Malte E.
no flags Details
x11-libs/qt-gui-4.7.0 (qt-gui-4.7.0.ebuild,5.65 KB, text/plain)
2010-10-20 18:27 UTC, Malte E.
no flags Details
043_ubuntu-menu-proxy.patch (043_ubuntu_menu_proxy.patch,39.68 KB, text/plain)
2010-10-21 09:03 UTC, Malte E.
no flags Details
fix build fails (043_ubuntu_menu_proxy.patch,44.66 KB, patch)
2010-12-26 13:12 UTC, Kirill Kinduk
no flags Details | Diff
x11-misc/appmenu-gtk-0.1.9 (appmenu-gtk-0.1.9.ebuild,474 bytes, text/plain)
2011-02-26 22:44 UTC, Malte E.
no flags Details
GTK patch for appmenu (043_ubuntu_menu_proxy.patch,48.03 KB, patch)
2011-04-08 02:14 UTC, Malte E.
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Malte E. 2010-10-19 11:35:18 UTC
I wrote an ebuild for plasma-widget-menubar used in Ubuntu 10.10. It provides a global menubar for all Qt (and GTK+, along with another package) applications and will probably be getting support for XUL and VCL soon. Unfortunately, the applet does not work for me, I can add it to the panel but applications don't use it. I'm using Qt-4.7 and KDE-4.5 and I could not find anything about the applet requiring a patch to any of these. Maybe someone can help out. This is a much better solution than bespin's Xbar, as it works better with GTK+ (icons are supported) and it is style independent.

Reproducible: Always
Comment 1 Malte E. 2010-10-19 11:36:03 UTC
Created attachment 251231 [details]
kde-misc/plasma-widget-menubar-0.1.13
Comment 2 Malte E. 2010-10-20 16:33:47 UTC
Ok, it obviously does require a patch to Qt: https://launchpad.net/appmenu-qt
so I guess we need to wait for it to go upstream or add the patch ourselves. I'll investigate the possibility of applying a patch
Comment 3 Malte E. 2010-10-20 18:22:55 UTC
Created attachment 251355 [details]
qt-4.7.0-appmenu.patch

This patch needs to be applied to qt-gui and the plasma-widget-menubar will work (properly after a relogin)
Comment 4 Malte E. 2010-10-20 18:27:07 UTC
Created attachment 251359 [details]
x11-libs/qt-gui-4.7.0

updated qt-ebuild to use the appmenu patch. I made the patch optional as it needs qt-dbus as an additional dependency. One could consider making it non-optional - most people who have qt-gui installed have qt-dbus installed anyway.
Comment 5 Malte E. 2010-10-21 09:03:51 UTC
Created attachment 251419 [details]
043_ubuntu-menu-proxy.patch

This should be the patch that needs to be applied to gtk+ in order to make the appmenu work with gtk+ apps. Unfortunately, applying it makes the build fail with
gtkalias.h:6145: error: ‘ubuntu_gtk_menu_shell_activate_mnemonic’ undeclared here (not in a function)
And I can't figure out how to fix it.
Comment 6 Malte E. 2010-10-24 19:36:05 UTC
on #ayatana I got the hint it had something to do with the following file:
http://bazaar.launchpad.net/~ubuntu-desktop/gtk/ubuntu/annotate/head:/debian/libgtk2.0-0.symbols
but the developer couldn't tell, what exactly it was and I can't find it out either. Is there maybe someone with a little more knowledge of the debian package system?
Comment 7 Malte E. 2010-10-25 13:43:52 UTC
It would be great if someone could try qt-4.6.3 because it's stable. Portage aborts the downgrade for me because it breaks the system - I guess recompiling everything linked against it would fix it but I don't want that.
Comment 8 Kirill Kinduk 2010-12-26 13:12:05 UTC
Created attachment 258097 [details, diff]
fix build fails

With this patch build not fails and completes normal. However, gtk applications still do not show their menus. Maybe I need configure it by some special way?
Comment 9 Kirill Kinduk 2010-12-26 13:13:21 UTC
qt and kde applications works flawlessly
Comment 10 Malte E. 2010-12-28 10:36:14 UTC
Do you also have appmenu-gtk installed? you will need that, too. I have it installed, but it still won't work. I can't figure out, why. Would be great if someone else could. I will also provide the appmenu-gtk ebuild, it's quick and dirty, though.
Comment 11 Kirill Kinduk 2010-12-28 12:20:33 UTC
(In reply to comment #10)
> Do you also have appmenu-gtk installed? you will need that, too. I have it
> installed, but it still won't work. I can't figure out, why. Would be great if
> someone else could. I will also provide the appmenu-gtk ebuild, it's quick and
> dirty, though.
> 

I wrote an ebuild of appmenu-gtk and install it. I checked it on devede. It worked but there was no icons. Eclipse and mysql-workbench have many troubles with this way of menu displaying (some menu item disappeared). Anf of course firefox does not working that way.
Unfortunately, I've already deleted the ebuild of appmenu-gtk, but if you need it, I can reproduce it.
Comment 12 Malte E. 2011-02-26 22:44:17 UTC
Created attachment 263987 [details]
x11-misc/appmenu-gtk-0.1.9
Comment 13 Malte E. 2011-04-08 02:14:19 UTC
Created attachment 268953 [details, diff]
GTK patch for appmenu

I just tried to update all appmenu related packages to make Firefox work. I also updated the patches to Qt and GTK+. The Qt part is up and running, but GTK+ don't show their menu in the menubar, although they are hidden in the app's window. I tried to apply a new patch but I ran into the same build failure again. Where did you get the last fixed patch, Kirill Kinduk?
Comment 14 Shuai WANG 2011-06-30 09:51:25 UTC
I wrote some ebuilds here https://github.com/Etrnls/Etrnlay

Install these packages from the above link
x11-misc/appmenu-gtk
x11-misc/appmenu-qt
x11-libs/gtk+ (patch inside)
x11-libs/qt-gui (patch inside)

Works for me, using kde-4.6 and oxygen-appmenu (also in the above link)
Comment 15 Malte E. 2011-07-03 02:33:17 UTC
谢谢你!
It's good to finally see someone making ebuilds who is better at it than me.
I'm compiling now and will test soon. There are also globalmenu bits for Firefox (and possibly Thunderbird) and Libreoffice. I wrote an ebuild for the firefox addon that installs the binary from Ubuntu which is not very neat and I failed on the Libreoffice one.
The package names are firefox-globalmenu and lo-menubar. Do you have any intentions to write ebuilds for these as well?
Comment 16 Ivan S. Titov 2011-11-20 19:15:11 UTC
There is also an overlay with these ebuilds and patched gtk and qt:
https://github.com/megabaks/stuff.git
Comment 17 Ivan S. Titov 2011-11-20 19:15:56 UTC
BTW, author is quite responsive and updates ebuilds for gtk etc quite fast.
Comment 18 Michael Palimaka (kensington) gentoo-dev 2012-06-16 14:26:59 UTC
plasma-widget-menubar and appmenu-qt are now in the tree.
Comment 19 Samuli Suominen (RETIRED) gentoo-dev 2012-06-16 14:33:22 UTC
The Qt guys applied the (very intrusive) patch to the x11-libs/qt-* in gentoo-x86?
Propably more suitable for some experimental overlay. I was keeping this bug open just for tracking purposes...
Comment 20 Michael Palimaka (kensington) gentoo-dev 2012-06-16 14:35:36 UTC
(In reply to comment #19)
> The Qt guys applied the (very intrusive) patch to the x11-libs/qt-* in
> gentoo-x86?
It went upstream.
Comment 21 Michael Palimaka (kensington) gentoo-dev 2012-06-16 15:24:25 UTC
If anyone can convince GTK upstream to merge the appmenu patch, I don't see any problem in adding appmenu-gtk to the tree.
Comment 22 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-14 21:20:00 UTC
Have these patches been reviewed by gtk+ upstream? Please add the relevant bugs.gnome.org urls.

I am quite reluctant to apply a 48K ubuntu-specific patch to a central part of gnome if it is not upstreamable.
Comment 23 Samuli Suominen (RETIRED) gentoo-dev 2013-02-14 21:25:35 UTC
(In reply to comment #22)
> Have these patches been reviewed by gtk+ upstream? Please add the relevant
> bugs.gnome.org urls.
> 
> I am quite reluctant to apply a 48K ubuntu-specific patch to a central part
> of gnome if it is not upstreamable.

And be tied to Ubuntu's release cycle for GTK+

Just don't do it if it's not going upstream, and propably isn't
Comment 24 Pacho Ramos gentoo-dev 2013-02-14 21:34:33 UTC
Maybe other option would be to have two gtk+ packages: "upstream" one and "ubuntuized" one (this maintained by people willing to review ubuntu patches and upstream gtk+). They would block each other and, then, users could switch between them if they want to use extra ubuntu features
Comment 25 Malte E. 2013-02-14 21:45:35 UTC
(In reply to comment #24)
> Maybe other option would be to have two gtk+ packages: "upstream" one and
> "ubuntuized" one (this maintained by people willing to review ubuntu patches
> and upstream gtk+). They would block each other and, then, users could
> switch between them if they want to use extra ubuntu features

I would rather have it with a masked use flag. That has much less impact on the rest portage tree (dependencies) and makes sure no one will install it by accident. And it won't require yet another package to maintain. The changes in the package itself are rather small.
Comment 26 Gilles Dartiguelongue gentoo-dev 2013-02-15 16:18:00 UTC
We, the gnome team, are not fond of (actually mostly against) USE enabled patches as it will most likely end up in us not testing this flag (because we don't use it) hence potentially shipping continuously broken version bumps for that USE.

I, personally, would not like a gtk+-ubuntu as well, would most likely trigger unexpected bugs in applications and create support where it is not due, the applications themselves.

To conclude, as I already said in other bug reports attempting to push this work to Gentoo, this is a no go from me until upstream actually integrates it or until it emerges in a maintainable form like gnome-globalmenu does.
Comment 27 Gino McCarty 2019-05-09 22:14:10 UTC
Sorry to bring this back but KDE Plasma now require appmenu-gtk as of 5.13
I think this should be revisited,
latest release is now 12.10.2 which of course won't build without patches..
Comment 28 Gino McCarty 2019-05-10 03:30:32 UTC
I found a newer fork of this code, that is the one KDE team used in their development against this module. It no longer requires ubuntu header hacks against gtk+ and is a pretty clean package
I have filed a PR for it https://github.com/gentoo/gentoo/pull/11951
Comment 29 inasprecali 2020-01-13 22:15:07 UTC
Bump. Can this be merged at all?
Comment 30 Larry the Git Cow gentoo-dev 2020-07-26 18:35:38 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ce5c0c6e75b32b546ade4fc42ef44f14be5ee0ea

commit ce5c0c6e75b32b546ade4fc42ef44f14be5ee0ea
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-07-26 17:53:06 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-07-26 18:35:09 +0000

    x11-misc/appmenu-gtk-module: New Package
    
    Initial ebuild by Gino McCarty, improvements by Marco Genasci and myself.
    
    See also: https://github.com/gentoo/gentoo/pull/11951
    
    Bug: https://bugs.gentoo.org/341757
    Thanks-to: Gino McCarty <onigino@protonmail.com>
    Thanks-to: Marco Genasci <fedeliallalinea@gmail.com>
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 x11-misc/appmenu-gtk-module/Manifest               |  1 +
 .../appmenu-gtk-module-0.7.3.ebuild                | 48 ++++++++++++++++++++++
 .../appmenu-gtk-module/files/appmenu-gtk-module    | 12 ++++++
 x11-misc/appmenu-gtk-module/metadata.xml           | 11 +++++
 4 files changed, 72 insertions(+)
Comment 31 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-07-27 14:22:02 UTC
~x86 added
Comment 32 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-07-27 14:35:25 UTC
~arm64 added
Comment 33 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-07-30 01:35:53 UTC
~arm added
Comment 34 Larry the Git Cow gentoo-dev 2020-08-02 11:16:02 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/kde.git/commit/?id=e7aaebec9c0f229f33ae23aed84235a786a18f43

commit e7aaebec9c0f229f33ae23aed84235a786a18f43
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-08-02 10:56:41 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-08-02 10:57:30 +0000

    kde-plasma/plasma-meta: Add more IUSE="gtk" integration deps
    
    Bug: https://bugs.gentoo.org/332695
    Bug: https://bugs.gentoo.org/341757
    Package-Manager: Portage-3.0.1, Repoman-2.3.23
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 kde-plasma/plasma-meta/plasma-meta-5.19.49.9999.ebuild | 2 ++
 kde-plasma/plasma-meta/plasma-meta-9999.ebuild         | 2 ++
 2 files changed, 4 insertions(+)
Comment 35 NATTkA bot gentoo-dev 2020-08-10 19:18:22 UTC
Unable to check for sanity:

> no match for package: x11-misc/appmenu-gtk-module-0.7.3
Comment 36 NATTkA bot gentoo-dev 2020-08-10 19:30:00 UTC
All sanity-check issues have been resolved
Comment 37 Larry the Git Cow gentoo-dev 2020-09-01 12:28:03 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/kde.git/commit/?id=31f9f1558b5790e9b776624b373c642a9a162eae

commit 31f9f1558b5790e9b776624b373c642a9a162eae
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-09-01 12:27:52 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-09-01 12:27:52 +0000

    kde-plasma/plasma-meta: Drop ~ppc64 keyword
    
    Bug: https://bugs.gentoo.org/341757
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 kde-plasma/plasma-meta/plasma-meta-5.19.5.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 38 Sergei Trofimovich (RETIRED) gentoo-dev 2020-09-07 17:58:58 UTC
~ppc64 keyworded

Last arch. Closing.