Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34149 - gaim 0.73 logging is broken
Summary: gaim 0.73 logging is broken
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gaim Bugs Crew
Depends on:
Reported: 2003-11-22 18:18 UTC by Jordan
Modified: 2004-03-22 07:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jordan 2003-11-22 18:18:14 UTC
Apparently gaim 0.73's new logging scheme is not working. I'm not really sure what is causing it. Gaim apparently is creating directories with "rw" instead of "rwx" and logs aren't being written. It seems like it may be somehow related to gentoo, as I've asked around and people on other distros aren't having this problem.
Comment 1 Don Seiler (RETIRED) gentoo-dev 2003-11-22 19:27:52 UTC
Yes I'm seeing this also in my .gaim.  However that logs directory was from March 28.  I deleted the logs directory and on my next chat it was automatically recreated with 700 permissions and worked fine.

I don't think there is anything we can or should do about old directories having bad permissions.  lostlogic might disagree.
Comment 2 Jordan 2003-11-23 06:09:47 UTC
By dumping my GAIM config files I have been able to get it to start logging...I"m still not quite sure what causes this..
Comment 3 Don Seiler (RETIRED) gentoo-dev 2003-11-24 09:49:28 UTC
I don't think you needed to blow away all of your config files.  Just the logs directory in .gaim.

I'm going to resolve this as CANTFIX.
Comment 4 Don Seiler (RETIRED) gentoo-dev 2003-11-26 08:46:24 UTC
This bug has actually been confirmed upstream and is fixed in gaim-0.74.  I'm working on that ebuild now.

Comment 5 Blu3 2003-12-11 14:22:02 UTC
Has this actually been fixed yet?  I have .74-r1 installed, ~/.gaim is 700, ~/.gaim/logs is also 700, and all logfiles inside ~/.gaim/logs/ are 644.

Gaim still isn't logging.
Comment 6 Don Seiler (RETIRED) gentoo-dev 2003-12-11 14:26:31 UTC
Did you re-enable logging in your gaim preferences?  The preferences were lost from 0.72 to 0.74.  That is a gaim bug, nothing we can do about it.
Comment 7 Don Seiler (RETIRED) gentoo-dev 2003-12-11 14:29:30 UTC
Just in case you're wondering how I know, this is part of the topic in #gaim on freenode currently:

Logging prefs lost between 0.72 and 0.7[34].  Fixed in CVS
Comment 8 Blu3 2004-03-22 06:30:13 UTC
Is logging still broken?
Comment 9 Don Seiler (RETIRED) gentoo-dev 2004-03-22 06:38:49 UTC
Not for me.  Are you on gaim-0.75-r10?
Comment 10 Blu3 2004-03-22 07:13:12 UTC
Found and "fixed".  Due to the changed method of logging and prefs, you have to do the following:

1) turn off logging
2) exit and restart gaim
3) turn logging back on

Simply turning logging off/on in prefs without the above won't do anything if you're using prefs from last year (about .74 time)

Hint found at