Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340717 - [science-overlay] 'emerge -pv1 sci-mathematics/octave-forge-gsl-1.0.8" complains about invalid: DEPEND: USE flag 'bindist'
Summary: [science-overlay] 'emerge -pv1 sci-mathematics/octave-forge-gsl-1.0.8" compla...
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-12 16:29 UTC by Juergen Rose
Modified: 2010-10-18 20:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2010-10-12 16:29:12 UTC
I get the following:
root@lynx:/root(2)#  emerge -pv1 octave-forge-gsl

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "octave-forge-gsl" have been masked.
!!! One of the following masked packages is required to complete your request:
- sci-mathematics/octave-forge-gsl-1.0.8 (masked by: invalid: DEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE, invalid: RDEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE)
- sci-mathematics/octave-forge-gsl-1.0.7 (masked by: invalid: DEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE, invalid: RDEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I tried to add or to remove the bindist flag, but it does not change anything.

octave-forge-gsl was installed in Jan 2010.
root@moose:/usr/local/portage/app-misc(35)# genlop -t octave-forge-gsl
 * sci-mathematics/octave-forge-gsl

     Thu Jan 21 15:36:26 2010 >>> sci-mathematics/octave-forge-gsl-1.0.8
       merge time: 35 seconds.



Reproducible: Always




root@lynx:/root(8)# emerge --info  octave-forge-gsl
Portage 2.1.9.16 (default/linux/amd64/10.0/desktop, gcc-4.5.1, glibc-2.12.1-r1, 2.6.35-gentoo-r10 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.35-gentoo-r10-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 12 Oct 2010 09:30:20 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.6, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2, 4.5.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 cadsoft"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://vlaai.snt.ipv6.utwente.nl/pub/os/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lordvan /var/lib/layman/x11 /var/lib/layman/java-overlay /var/lib/layman/sunrise /var/lib/layman/arcon /var/lib/layman/science /var/lib/layman/pro-audio /var/lib/layman/qting-edge /var/lib/layman/n4g /var/lib/layman/ibormuth /usr/local/portage /var/lib/cpan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac abiword acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant audacious audiofile automap automount bash-completion beagle berkdb blas blast bluetooth boo boost branding bzip2 cairo cardbus cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbase dbi dbm dbus designer devhelp device-mapper dga dia djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds elf emacs emboss empathy encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fpx fts3 fuse galago garmin gd gdal gdbm gedit geoip geolocation geos gif gimp ginac git glade glib gml gmp gmtsuppl gnokii gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk guile hal harness hddtemp hdf hdf5 hdri hlapi http httpd hvm iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java5 java6 jbig john jpeg jpeg2k kdrive kerberos kpathsea kqemu kvm ladspa lame lapack laptop latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lirc lua lzo mad mail maildir mailwrapper mapnik math matroska mikmod mkl mmx mmxext mng modules mono moonlight motif mozdevelop mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numarray numeric nvidia obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio pymol python python-bindings qemu qhull qt3support qt4 quicktime readline reflection reiserfs rle romio rpc rrdcgi rrdtool samba sasl science sdl secure-delete semantic-desktop server session sip slang slp smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs theora thinkpad threads thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 video virtualbox vorbis wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse                evdev                synaptics               " KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php-5.2" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 jruby" USERLAND="GNU" VIDEO_CARDS="nv nvidia nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sci-mathematics/octave-forge-gsl-1.0.8 was built with the following:
USE="(multilib)"
LDFLAGS="-Wl,-O1"
Comment 1 Juergen Rose 2010-10-12 16:33:21 UTC
Also 'emerge -v1 octave-forge-meta' fails with the same error:
root@moose:/usr/local/portage/app-misc(40)# emerge -v1 octave-forge-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "sci-mathematics/octave-forge-gsl" have been masked.
!!! One of the following masked packages is required to complete your request:
- sci-mathematics/octave-forge-gsl-1.0.8 (masked by: invalid: DEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE, invalid: RDEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE)
- sci-mathematics/octave-forge-gsl-1.0.7 (masked by: invalid: DEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE, invalid: RDEPEND: USE flag 'bindist' referenced in conditional '!bindist?' is not in IUSE)

(dependency required by "sci-mathematics/octave-forge-meta-1.0" [ebuild])
(dependency required by "octave-forge-meta" [argument])


Any idea is deeply appreciated.
Comment 2 Sébastien Fabbro (RETIRED) gentoo-dev 2010-10-15 18:38:17 UTC
Hi,

octave-forge-* packages will be discontinued soon. please look at the g-octave application.

Thanks
Comment 3 Juergen Rose 2010-10-15 19:12:15 UTC
The installation of g-octave-0.4 fails with:
...
Making output directory...
Running Sphinx v1.0.4
ACCESS DENIED  open_wr:      /usr/lib64/python2.6/site-packages/sphinx/pycode/Grammar2.6.6.final.0.pickle
loading pickled environment... not yet created
...
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-5258.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /usr/lib64/python2.6/site-packages/sphinx/pycode/Grammar2.6.6.final.0.pickle
A: /usr/lib64/python2.6/site-packages/sphinx/pycode/Grammar2.6.6.final.0.pickle
R: /usr/lib64/python2.6/site-packages/sphinx/pycode/Grammar2.6.6.final.0.pickle
C: /usr/bin/python2.6 /usr/bin/sphinx-build -b html -d _build/doctrees . _build/html 
--------------------------------------------------------------------------------

Any hint?
Comment 4 Rafael Martins gentoo-dev 2010-10-15 19:15:38 UTC
(In reply to comment #3)
> Any hint?
> 

As workaround please emerge g-octave with USE="-doc", and open another bug for this issue.

Thanks.
Comment 5 Juergen Rose 2010-10-15 19:45:37 UTC
Hi Rafael,

thanks for yor help. I wrote a new bug Bug#: 341153. And then I emerged successfully g-octave with USE="-doc". But if I try to use g-octave, I habe only problems:

root@moose:/root(18)# g-octave --sync
 * "--sync" not available, please install g-octave-9999 if you want this.
root@moose:/root(19)# g-octave -i gsl
 * I/O error - [Errno 2] No such file or directory: '/var/cache/g-octave/info.json'
 * Try run "g-octave" as root.
 * If you fell that this is a bug, please report to us.
 * Mail to: rafael@rafaelmartins.eng.br
root@moose:/root(20)# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel),11(floppy),20(dialout),26(tape),27(video),1221(nwaccess)
root@moose:/root(21)# g-octave -l
 * I/O error - [Errno 2] No such file or directory: '/var/cache/g-octave/info.json'
 * Try run "g-octave" as root.
 * If you fell that this is a bug, please report to us.
 * Mail to: rafael@rafaelmartins.eng.br
root@moose:/root(22)# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel),11(floppy),20(dialout),26(tape),27(video),1221(nwaccess)
root@moose:/root(23)# g-octave -i
 * I/O error - [Errno 2] No such file or directory: '/var/cache/g-octave/info.json'
 * Try run "g-octave" as root.
 * If you fell that this is a bug, please report to us.
 * Mail to: rafael@rafaelmartins.eng.br

Do you still have a hint for me?
Comment 6 Rafael Martins gentoo-dev 2010-10-15 19:52:16 UTC
(In reply to comment #5)
> Do you still have a hint for me?
> 

I suppose that you missed the einfo message warning you about run `emerge --config g-octave`. This command will install the package database for you.

`g-octave --sync` only works for the live ebuild. The ebuilds for releases comes with a package database, that is installed by `emerge --config g-octave`.

Thanks
Comment 7 Juergen Rose 2010-10-18 09:43:37 UTC
Thanks once more Rafael,

After 'emerge  --config g-octave' 'g-octave -i gsl' seems to work, but 'g-octave --sync' still fails:
root@condor:/root(28)# emerge --config g-octave


Configuring pkg...

 * Extracting g-octave database files to: /var/cache/g-octave

root@condor:/root(29)# g-octave --sync
 * "--sync" not available, please install g-octave-9999 if you want this.
root@condor:/root(30)# g-octave -i gsl
 * Creating overlay: /var/lib/g-octave ...                                                [ ok ]
Package: GSL
Version: 1.0.8
Date: 2009-05-03
Maintainer: Teemu Ikonen   <tpikonen@pcu.helsinki.fi>
Description: Octave bindings to the GNU Scientific Library
Categories: None
License: GPL version 2 or later
Url: http://octave.sf.net
Comment 8 Juergen Rose 2010-10-18 10:31:24 UTC
Hi Sebastian,

I have a question to comment 2. Is there something equivalent to 'emerge -vD octave-forge-meta' with g-octave?

Comment 9 Juergen Rose 2010-10-18 19:38:06 UTC
Still an other problem, I can't install octave-forge-gsl with g-octave:

root@moose:/root(16)# emerge --config g-octave


Configuring pkg...

 * Extracting g-octave database files to: /var/cache/g-octave

root@moose:/root(17)# g-octave -puv gsl
 * Creating overlay: /var/lib/g-octave ...                                                                                                                        [ ok ]
 * Creating ebuild: g-octave/gsl-1.0.8.ebuild
>>> Downloading 'https://octave.svn.sourceforge.net/svnroot/octave/trunk/octave-forge/packages/package_Makefile.in'
--2010-10-18 21:35:42--  https://octave.svn.sourceforge.net/svnroot/octave/trunk/octave-forge/packages/package_Makefile.in
Connecting to 10.101.10.254:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 4035 (3.9K) [text/plain]
Saving to: `/usr/portage_moose/distfiles/g-octave_Makefile'

100%[===============================================================================================================================>] 4,035       --.-K/s   in 0s      

2010-10-18 21:35:47 (54.0 MB/s) - `/usr/portage_moose/distfiles/g-octave_Makefile' saved [4035/4035]

>>> Downloading 'https://octave.svn.sourceforge.net/svnroot/octave/trunk/octave-forge/packages/package_configure.in'
--2010-10-18 21:35:47--  https://octave.svn.sourceforge.net/svnroot/octave/trunk/octave-forge/packages/package_configure.in
Connecting to 10.101.10.254:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 75 [text/plain]
Saving to: `/usr/portage_moose/distfiles/g-octave_configure'

100%[===============================================================================================================================>] 75          --.-K/s   in 0s      

2010-10-18 21:35:47 (4.31 MB/s) - `/usr/portage_moose/distfiles/g-octave_configure' saved [75/75]

>>> Creating Manifest for /var/lib/g-octave/g-octave/gsl
 * Ebuild class error - Package not found: /gsl-1.0.8
 * If you fell that this is a bug, please report to us.
 * Mail to: rafael@rafaelmartins.eng.br
root@moose:/root(18)# g-octave -i gsl
Package: GSL
Version: 1.0.8
Date: 2009-05-03
Maintainer: Teemu Ikonen   <tpikonen@pcu.helsinki.fi>
Description: Octave bindings to the GNU Scientific Library
Categories: None
License: GPL version 2 or later
Url: http://octave.sf.net
root@moose:/root(19)# g-octave -uv gsl
 * Ebuild class error - Package not found: /gsl-1.0.8
 * If you fell that this is a bug, please report to us.
 * Mail to: rafael@rafaelmartins.eng.br
Comment 10 Juergen Rose 2010-10-18 19:44:43 UTC
The next try works:

root@moose:/root(24)# g-octave -v gsl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] g-octave/gsl-1.0.8  0 kB [1]
...
>>> /usr/libexec/octave/packages/gsl-1.0.8/x86_64-pc-linux-gnu-api-v37/coupling_6j.oct
 * Registering g-octave/gsl-1.0.8 on the Octave package database.

>>> Recording g-octave/gsl in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
Comment 11 Sébastien Fabbro (RETIRED) gentoo-dev 2010-10-18 20:07:16 UTC
please open other a bug for each issue.
thanks.