Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340413 - Failed to emerge x11-libs/gtk+-2.20.1-r1 *** Can't find cairo-pdf.h. You must build Cairo with the pdf *** backend enabled.
Summary: Failed to emerge x11-libs/gtk+-2.20.1-r1 *** Can't find cairo-pdf.h. You mu...
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-10 19:35 UTC by Kirill
Modified: 2010-11-11 11:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill 2010-10-10 19:35:27 UTC
Trying to reemerge the system after power fail and some problems with partition.
GTK+ is not compiling with that message. Tried to recompile cairo, pixman, libpng, fontconfig - did not solved the problem. The file cairo-pdf.h is located at /usr/include/cairo and have 644 permission. 

Reproducible: Always

Steps to Reproduce:
1. emerge -v gtk+
2.
3.




emerge --info =x11-libs/gtk+-2.20.1-r1:
http://paste.pocoo.org/show/273730/

the output of 'emerge -pqv =x11-libs/gtk+-2.20.1-r1:
[ebuild   R   ] x11-libs/cairo-1.8.10  USE="X opengl svg* xcb (-aqua) -cleartype -debug -directfb -doc -glitz -lcdfilter"
[ebuild   R   ] x11-libs/gtk+-2.20.1-r1  USE="cups jpeg tiff (-aqua) -debug -doc (-introspection) -jpeg2k -test -vim-syntax -x$

The complete build log is:
http://paste.pocoo.org/show/273732/

The ebuild environment file is:
http://paste.pocoo.org/show/273733/
Comment 1 Kirill 2010-10-10 19:41:47 UTC
/var/tmp/portage/x11-libs/gtk+-2.20.1-r1/work/gtk+-2.20.1/config.log
http://paste.pocoo.org/show/273735/
Comment 2 Gilles Dartiguelongue gentoo-dev 2010-11-10 21:54:51 UTC
Please attach all of the data you provide to this bug report.