Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 34014 - emerge opera(7.22) breaks stuff
Summary: emerge opera(7.22) breaks stuff
Status: RESOLVED DUPLICATE of bug 29388
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Heinrich Wendel (RETIRED)
Depends on:
Reported: 2003-11-21 05:53 UTC by m.o.e.
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description m.o.e. 2003-11-21 05:53:51 UTC
opera 7.22 wants openmotif-2.1* or lesstif

. does not compile if /tmp is mounted NOEXEC -- BAD
. will downgrade openmotif-2.2.2-r1 when other apps need it -- BAD
. overwrites X11 files -- BAD

. nukes most of openmotif's stuff -- new programs that want openmotif will 
really get lesstif and look real ugly -- BAD

. is missing -- no plugins in opera -- BAD
. gcc will never find includes and libraries in these obscure places


Reproducible: Always
Steps to Reproduce:
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2003-11-21 06:40:12 UTC
there is no app that needs openmotif-2.2

*** This bug has been marked as a duplicate of 29388 ***
Comment 2 SpanKY gentoo-dev 2003-11-21 07:15:43 UTC
. does not compile if /tmp is mounted NOEXEC -- BAD

more than opera will break because of that
Comment 3 m.o.e. 2003-11-21 08:09:35 UTC

Problem is the nuked X11 stuff. Now all Imakefile based ebuilds don't build nomore if tmp is NOEXEC. Worse yet, when reemerging openmotif-2.2.2-r1, imake disappears.
Comment 4 m.o.e. 2003-11-21 10:28:32 UTC
Ok, now that I've studied bugzilla, especially 29388, it seems

. openmotif-2.2.2 is bad
. openmotif-2.2.2-r1 doesn't even compile if lesstif is installed -- fixed in -r2
. openmotif-2.1.30-r1 overwrites X11 stuff -- r2 fixes that and the NOEXEC prob

Why do I get 2.2.2 after a fresh install and not 2.1.30?
Why are both -r2s masked?
How do I install 2.1.30 without breaking all my motif apps?

Comment 5 Heinrich Wendel (RETIRED) gentoo-dev 2003-11-21 11:37:23 UTC
please discuss that in bug 29388, opera needs openmotif 2.1 or lesstif, i can't change that.

*** This bug has been marked as a duplicate of 29388 ***
Comment 6 m.o.e. 2003-11-21 22:19:01 UTC
Sorry for reopening this again, BUT: as much as I agree with the suggstions 
in 29388, they're no good if the bad stuff is default and the good stuff is 

. emerge openmotif installs 2.2.2-r1, obvl. the most broken of them all
. om-2.1.30-r2 is best but in ~x86 and overridden by om-2.2.2
. opera wants om-2.1* but all other apps want om-2.2.2
. emerging om-2.1.30 unemerges om-2.2.2
. emerging om-2.2.2 unemerges om-2.1.30
. emerging lesstif overwrites openmotif
. emerge world updates to om-2.2.2

See the conflicts here? The only ebuild that wants om-2.1*/lesstif is opera.

The problem the OPERA ebuild.
Comment 7 Heinrich Wendel (RETIRED) gentoo-dev 2003-11-21 22:24:08 UTC
so should we drop opera from portage? opera does not work with openmotif 2.2! i have installed openmotif-2.2 and lesstif-0.93.40 and it's working fine this way here. We will hopefully have slottet openmotif versions soon.

*** This bug has been marked as a duplicate of 29388 ***
Comment 8 m.o.e. 2003-11-21 22:55:44 UTC
No, that's not what I'm saying. All I'm saying is that an unmasked ebuild should not depend on things that break stuff.

. lesstif-0.93.40 will OVERWRITE openmotif. All subsequent builds that need Motif will use a mixture of motif/lesstif -- BAD
. openmotif-2.1.30-r1 is in x86 but overwrites X11 stuff, like imake -- BAD
. openmotif-2.1.30-r2 seems to fix that but is in ~x86
. world updates upgrade to om-2.2.2, no imake nomore, other builds break -- BAD

Either make om-2.1.30 default or don't have other ebuilds depend on it.
I don't care much about lesstif.
Comment 9 Heinrich Wendel (RETIRED) gentoo-dev 2003-11-22 02:25:22 UTC
Please don't understand me wrong, I'm willing to solve this problem. But it can't be solved in opera, it has to be solved in the motif ebuilds. And that's what we are trying to achieve in bug 29388.
Comment 10 Heinrich Wendel (RETIRED) gentoo-dev 2003-11-22 03:16:52 UTC
opera 7.23 was just release which also works with openmotif-2.2 again. it's marked stable cause of securiy issues.