Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 339606 - sys-apps/portage-2.2_rc88 'updates have been skipped' message lists irrelevant dependency conflicts
Summary: sys-apps/portage-2.2_rc88 'updates have been skipped' message lists irrelevan...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
Depends on:
Blocks: 300071
  Show dependency tree
 
Reported: 2010-10-03 16:14 UTC by Mike Auty
Modified: 2010-10-05 18:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Auty gentoo-dev 2010-10-03 16:14:31 UTC
Hiya,

So I recently had a conflict on my system (cairo-1.10.0 installed, but rcairo's ebuild was updated to require <cairo-1.10).  What portage reported during an "emerge -avuDNt @world @system" was:

!!! One or more updates have been skipped due to a dependency conflict:

x11-libs/cairo:0

  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo[X] required by (mail-client/thunderbird-3.1.4, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.4.0 required by (media-video/cheese-2.30.1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.6[X,svg] required by (x11-libs/gtk+-2.20.1-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.2.0 required by (app-text/ghostscript-gpl-8.71-r6, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.8.10[svg] required by (dev-python/pycairo-1.8.10, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.0.0 required by (gnome-extra/gnome-power-manager-2.30.1, ebuild scheduled for merge)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.2 required by (gnome-base/librsvg-2.26.3, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo[X] required by (x11-wm/compiz-0.8.6-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo required by (media-video/totem-2.30.2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.7.6[X] required by (x11-libs/pango-1.28.1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo required by (net-libs/gtk-vnc-0.4.1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1 required by (gnome-base/gnome-panel-2.30.2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.8.8[X] required by (www-client/firefox-3.6.9-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.0 required by (x11-wm/compiz-0.8.6-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.8.8[X] required by (net-libs/xulrunner-1.9.2.9-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo required by (x11-plugins/compiz-plugins-main-0.8.6-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.1.10[svg] required by (media-gfx/graphviz-2.26.3-r2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.8.4[X] required by (dev-dotnet/libgdiplus-2.6.7-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.4 required by (x11-libs/goocanvas-0.14, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo required by (media-libs/gegl-0.1.2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.8[svg] required by (dev-cpp/cairomm-1.8.2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.6.0 required by (x11-plugins/enigmail-1.1.2-r3, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.1.10 required by (media-gfx/graphviz-2.26.3-r2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.6.0 required by (net-libs/xulrunner-1.9.2.9-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.6.0 required by (mail-client/thunderbird-3.1.4, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.8.4 required by (app-text/poppler-0.14.3, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.6.0 required by (www-client/firefox-3.6.9-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.6 required by (media-libs/swfdec-0.8.4, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1.4.14 required by (dev-java/swt-3.5.2, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    >=x11-libs/cairo-1 required by (gnome-extra/gnome-games-2.30.2-r1, installed)
  (x11-libs/cairo-1.10.0-r3, ebuild scheduled for merge) conflicts with
    x11-libs/cairo required by (net-libs/webkit-gtk-1.3.4-r1, installed)

Whereas the previous version of portage available (2.2_rc67), reports the error as:

!!! One or more updates have been skipped due to a dependency conflict:

x11-libs/cairo:0

  ('ebuild', '/', 'x11-libs/cairo-1.10.0-r3', 'merge') conflicts with
    <x11-libs/cairo-1.10 required by ('ebuild', '/', 'dev-ruby/rcairo-1.8.5-r1', 'merge')

I can't actually find the block against rcairo in the top list of conflicts, and actually cairo-1.10.0 seems to satisfy all of the ones listed.  I don't know if the conflict list has just been flipped (showing non-conflicts rather than conflicts) or if there's something else going wrong, but either way it's a definite regression.  Just let me know if you need any further information...
Comment 1 Zac Medico gentoo-dev 2010-10-03 19:25:19 UTC
Apparently it's a regression from the fix for bug 337178:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=c6ed07840d2791ef5ce921322402856c72c6dcc8
Comment 3 Zac Medico gentoo-dev 2010-10-04 02:31:48 UTC
(In reply to comment #2)
> This should fix it:
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=453684d09ece494745a7f37627b3f6288ece9715
> 

There's a note here that elaborates on the issue that the 'HACK' comment from the above commit refers to:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=5d402047d0368c0122d2f21e21bb5ff5f9b17473
Comment 4 Zac Medico gentoo-dev 2010-10-05 18:01:28 UTC
This is fixed in 2.2_rc89.

2.2_rc89 a fork from the master branch, tracking the 2.1.9 branch, and it doesn't include the commit that introduced this regression. Aside from changes intended only for the stable branch, 2.2_rc89 is identical to 2.1.9.13.