Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339463 - x11-misc/electricsheep-9999
Summary: x11-misc/electricsheep-9999
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2010-10-02 12:52 UTC by Ștefan Talpalaru
Modified: 2016-11-09 10:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

x11-misc/electricsheep-9999 ebuild (electricsheep-9999.ebuild,1.10 KB, text/plain)
2010-10-02 12:52 UTC, Ștefan Talpalaru
xdg patch (electricsheep-9999-xdg-utils.patch,556 bytes, patch)
2010-10-02 12:57 UTC, Ștefan Talpalaru
Details | Diff
x11-misc/electricsheep-9999.ebuild (electricsheep-9999.ebuild,1.20 KB, text/plain)
2012-06-11 08:37 UTC, Peter Gantner (a.k.a. nephros)
files/electricsheep-9999-ffmpeg-0.10.patch (electricsheep-9999-ffmpeg-0.10.patch,1.01 KB, patch)
2012-06-11 08:38 UTC, Peter Gantner (a.k.a. nephros)
Details | Diff
electricsheep-9999.ebuild (electricsheep-9999.ebuild,1.63 KB, text/plain)
2012-12-17 17:29 UTC, Ville Aakko
Remove some deprecated / broken macros (autoconf.patch,333 bytes, patch)
2013-03-20 07:26 UTC, Maik Nijhuis
Details | Diff
electricsheep eubuild (electricsheep-9999.ebuild,1.69 KB, text/plain)
2014-08-17 22:06 UTC, MZ
electricsheep-9999.ebuild (electricsheep-9999.ebuild,1.69 KB, text/plain)
2014-08-17 22:08 UTC, MZ
electricsheep-9999.ebuild (electricsheep-9999.ebuild,1009 bytes, text/plain)
2016-06-03 02:35 UTC, Ștefan Talpalaru

Note You need to log in before you can comment on or make changes to this bug.
Description Ștefan Talpalaru 2010-10-02 12:52:02 UTC
live ebuild for electricsheep - screensaver and client for a distributed computing fractal art project
Comment 1 Ștefan Talpalaru 2010-10-02 12:52:44 UTC
Created attachment 249306 [details]
x11-misc/electricsheep-9999 ebuild
Comment 2 Ștefan Talpalaru 2010-10-02 12:54:54 UTC
differences from the version in bug #272050 :
- better ebuild structure
- removed gnome and kde support
Comment 3 Ștefan Talpalaru 2010-10-02 12:57:48 UTC
Created attachment 249310 [details, diff]
xdg patch
Comment 4 Peter Gantner (a.k.a. nephros) 2012-06-11 08:37:27 UTC
Created attachment 314957 [details]

Make electricsheep compile against newer versions of ffmpeg (0.10.x)
Comment 5 Peter Gantner (a.k.a. nephros) 2012-06-11 08:38:05 UTC
Created attachment 314959 [details, diff]
Comment 6 Peter Gantner (a.k.a. nephros) 2012-06-11 08:39:59 UTC
Above modifications work for me with media-video/ffmpeg-0.10.2/0.10.3.

Didn't test against media-video/libav.
Comment 7 Pacho Ramos gentoo-dev 2012-06-11 18:47:10 UTC
Would you be willing to proxy maintain this package? It would mean to also fix existing bug reports:


Comment 8 Ville Aakko 2012-12-17 17:29:39 UTC
Created attachment 332590 [details]
Comment 9 Ville Aakko 2012-12-17 17:32:20 UTC
(In reply to comment #8)

The ebuild above is upgraded to use the repository @ Google Code, as the SVN is outdated.

Need a bit cleaning in the dependencies.

Unfortunately, the .desktop files for KDE and probably for Gnome too (don't use any fairy tale UI on my box) are outdated. Hopefully one can use this via xscreensaver. No problems running standalone!
Comment 10 Ville Aakko 2012-12-17 17:33:07 UTC
(In reply to comment #9)
> (In reply to comment #8)
> The ebuild above is upgraded to use the repository @ Google Code, as the SVN
> is outdated.

By SVN I meant Sourceforge. My brains is messing with me today...
Comment 11 N. Andrew Walsh 2013-02-27 11:17:57 UTC
ac-wrapper: warning: invalid WANT_AUTOCONF 'latest'; ignoring.
Found GNU Autoconf version 2.69
Found GNU Automake version 1.13.1
Found GNU Libtool version 2.4.2

Automatically preparing build ... Warning: autoreconf failed
Attempting to run the preparation steps individually

Preparing build ... ERROR: aclocal -I mk/autoconf failed
 * ERROR: x11-misc/electricsheep-9999 failed (prepare phase):
 *   subversion: can't execute ESVN_BOOTSTRAP.

This is from the latest 9999.ebuild. Am I missing a file or something?

Comment 12 Maik Nijhuis 2013-03-20 07:26:29 UTC
Created attachment 342694 [details, diff]
Remove some deprecated / broken macros

I also got "subversion: can't execute ESVN_BOOTSTRAP". After commenting out some deprecated/unused fields in, I'm getting somewhat further.

In ContentDecoder.cpp, I also had to (always) enable USE_NEW_FFMPEG_API.

Now, electricsheep won't compile because of issues with wxwidgets. Somehow it seems that time.h isn't <include>d.

Since I have other stuff to do, I'm giving up for now.
Comment 13 N. Andrew Walsh 2014-04-16 22:59:48 UTC
electricsheep has been updated to beta33 for Linux for some time now. It uses an svn checkout. Has anybody tried to build from that source? Would adding that ebuild perhaps get around this problem?

Comment 14 Ville Aakko 2014-05-11 13:18:01 UTC

I've been trying to compile electricsheep every now and then (and then always gave up as I lost interest / lack of time...);

From SVN, now I've gotten furthest point ever - it compiles, but fails at linking phase - something to do with glee. I believe this could be over my abilities to fix, but maybe soemone else will want to take a shot (I will look at the source, maybe I will figure it out).

(btw. I installed glee-5.4.0 and flam3 live ebuild, other requirements were already installed).
Comment 15 MZ 2014-08-17 22:06:21 UTC
Created attachment 383050 [details]
electricsheep eubuild
Comment 16 MZ 2014-08-17 22:07:41 UTC
sorry for my mistake, 
new ebuild.

glee used from here:

please now question, worked for me.
Comment 17 MZ 2014-08-17 22:08:34 UTC
Created attachment 383052 [details]
Comment 18 N. Andrew Walsh 2014-10-22 18:32:09 UTC
you still have the old mplayer as a dependency, which got forked back in 2013. I manually edited the ebuild to use mplayer2 (the new hotness). I'll let you know how it goes.
Comment 19 N. Andrew Walsh 2014-10-22 19:38:51 UTC
Update: so, if you change the dependency to "media-video/mplayer2" in your ebuild, it apparently compiles and runs just fine. Even shows up in xscreensaver and everything. Holy crap.
Thanks for your work on this; I've been waiting a long time to have my sheep back.
PS it'd be nice to have a GLee ebuild in the tree.
Comment 20 N. Andrew Walsh 2015-01-13 10:49:20 UTC
hrm. Now I get the following error when electricsheep tries to run:

$ electricsheep
SetInstallation: /usr/share/electricsheep/Scripts
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXUnsupportedPrivateRequest
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  16 (X_GLXVendorPrivate)
  Serial number of failed request:  90
  Current serial number in output stream:  91

I'm running nvidia-drivers-346-22 on ~amd64 gentoo-sources-3.18.2 (which nvidia does not officially support, but which runs for everything but this, so ¯\_(ツ)_/¯ ). Any suggestions? Is electricsheep basing off some obsolete version of something, say, mesa?

Comment 21 N. Andrew Walsh 2016-06-02 21:23:48 UTC
Welp, now I've checked back, and electricsheep moved to github in May of 2015. There doesn't appear to be any new ebuild, so I can't build it anymore (even if it did work, which it hasn't for a good three or four years). Is electricsheep dead on gentoo?
Comment 22 Ștefan Talpalaru 2016-06-03 02:32:57 UTC
Working live ebuild available in the 'stefantalpalaru' overlay:

It depends on media-gfx/flam3-9999 and media-libs/glee from the same overlay.
Comment 23 Ștefan Talpalaru 2016-06-03 02:35:33 UTC
Created attachment 436238 [details]
Comment 24 N. Andrew Walsh 2016-07-27 13:00:40 UTC
(In reply to Stefan Talpalaru from comment #22)
> Working live ebuild available in the 'stefantalpalaru' overlay:
> electricsheep
> It depends on media-gfx/flam3-9999 and media-libs/glee from the same overlay.


it's been something like 6 years since this has worked on my machine, and this ebuild works! Oh man, you just made me soooo happy (and also nearly gave my S.O. a heart attack when I abruptly screamed at my computer screen). 

Thanks so much for this. My life suddenly has meaning again.
Comment 25 Pacho Ramos gentoo-dev 2016-11-09 10:34:58 UTC