Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339436 - kwrite 4.4.5 : Cursor position incorrect when inserting with "static word wrap" enabled
Summary: kwrite 4.4.5 : Cursor position incorrect when inserting with "static word wra...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-02 07:56 UTC by Eric F. GARIOUD
Modified: 2010-10-25 21:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric F. GARIOUD 2010-10-02 07:56:45 UTC
When Settings/Configure Editor/Editing/General 
- Enable static word wrap : is set
- Show static word wrap marker : is set
- Wrap words at : shows 90 characters.

AND

When there is a line already split on 2 lines on more because of the preceeding setting

AND

One inserts characters immediately before the first character of the last word of the first line

THEN

If the insert leads to the word being wrapped on the second line, the insertion point will jump at the end of this word.

Graphically :

Given the following single line split in two by the word wrapping feature :

A12345 B12345 C12345 D12345 E12345 F12345
G12345 H12345 

Let's say that, to the right of the last word of the first line (F12345) there is space for 2 characters before F12345 wraps to the second line.
Lets insert characters "abc" just before the F :

Result after inserting "ab" :

A12345 B12345 C12345 D12345 E12345 abF12345
G12345 H12345

Result after inserting c :

A12345 B12345 C12345 D12345 E12345
abF12345c G12345 H12345

The c is inserted at the end of the word rather than where it should be, following ab.

Reproducible: Always




- This bug does not occurs if the line is not already split.
Comment 1 Andreas K. Hüttel gentoo-dev 2010-10-25 21:13:03 UTC
Known problem for all of kde-4.4 and all applications using katepart. 

This was fixed in kde-4.5, but there is no backport. Not much we can do here...