Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339369 - kcalc-4.4.5 won't compile under kde-4.5.1
Summary: kcalc-4.4.5 won't compile under kde-4.5.1
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-01 16:44 UTC by Ivan Trombley
Modified: 2010-10-25 21:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Fixes kDebug use. (kcalc-4.4.5-const_menu.patch,867 bytes, patch)
2010-10-01 16:46 UTC, Ivan Trombley
Details | Diff
Fixes kDebug use. (kcalc-4.4.5-kcalc_core.patch,1.14 KB, patch)
2010-10-01 16:46 UTC, Ivan Trombley
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Trombley 2010-10-01 16:44:22 UTC
The version of kcalc that ships with kde-4.5.1 is inferior to the one that ships with kde-4.4.5 (the button layout has been crippled). However, the version of kcalc that ships with kde-4.4.5 will not compile under kde-4.5.1.

I will attach a couple of patches that correct the issue.

Reproducible: Always

Steps to Reproduce:
1. Emerge =kde-base/kcalc-4.4.5.
Comment 1 Ivan Trombley 2010-10-01 16:46:00 UTC
Created attachment 249189 [details, diff]
Fixes kDebug use.
Comment 2 Ivan Trombley 2010-10-01 16:46:31 UTC
Created attachment 249191 [details, diff]
Fixes kDebug use.
Comment 3 Maciej Mrozowski gentoo-dev 2010-10-04 00:21:36 UTC
I think kcalc 4.5 should be fixed instead of kcalc-4.4 patched to build against kdelibs-4.5.
Comment 4 Andreas K. Hüttel gentoo-dev 2010-10-25 21:08:25 UTC
Resolving as of comment 3.