Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339216 - net-libs/libproxy-0.4.6: failing to link due to mozjs missing
Summary: net-libs/libproxy-0.4.6: failing to link due to mozjs missing
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://code.google.com/p/libproxy/iss...
Whiteboard:
Keywords:
: 339286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-30 06:55 UTC by DaggyStyle
Modified: 2011-03-30 21:10 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,10.17 KB, text/plain)
2010-09-30 06:56 UTC, DaggyStyle
Details
libproxy-xul-order.patch (libproxy-xul-order.patch,607 bytes, patch)
2010-09-30 08:44 UTC, Pacho Ramos
Details | Diff
build.log with CMAKE_VERBOSE=1 (build.log,62.32 KB, text/plain)
2010-09-30 16:02 UTC, DaggyStyle
Details
Corrrect fix to the reported issue (0001-Disable-transient-linking.patch,1.33 KB, patch)
2010-10-12 17:49 UTC, Nicolas Dufresne
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description DaggyStyle 2010-09-30 06:55:47 UTC
see log, emerge --info:
Portage 2.1.9.12 (default/linux/amd64/10.0/desktop, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r9 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r9-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 30 Sep 2010 06:00:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula Broadcom PUEL googleearth LOKI-EULA AdobeFlash-10.1 RTCW-ETEULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe -msse4.1"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.isoc.org.il/gentoo/ http://gentoo.llarian.net/ ftp://gentoo.llarian.net/pub/gentoo http://pandemonium.tiscali.de/pub/gentoo/ ftp://pandemonium.tiscali.de/pub/gentoo/ http://linuv.uv.es/mirror/gentoo/ http://gentoo.blueyonder.co.uk ftp://mirrors.blueyonder.co.uk/mirrors/gentoo "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en he es"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=180"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aio alsa amd64 amr audiofile berkdb bidi bluetooth branding bzip2 cairo cdparanoia cdr cjk cli consolekit cracklib crypt css cups curl cxx dbus dga dri dts dv dvb dvd dvdr dvdread edb emboss encode exif faad fam ffmpeg ffmpeg-mt firefox flac fortran ftp gallium gdbm gif gphoto2 gpm gtk hal iconv icq id3tag ieee1394 imagemagick irda ivtv java javascript joystick jpeg jpeg2k kde lame lcms ldap lirc lua lzma mad matroska mikmod mmx mng modules mono mp3 mp4 mpeg mtp mudflap multilib nas ncurses nls nptl nptlonly nsplugin ogg openexr opengl openmp oss pam pango pcre pdf perl php png policykit ppds pppd python qt3support qt4 quicktime readline reflection samba sdl session smp sndfile spell srt sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd theora threads tiff truetype unicode usb v4l v4l2 vaapi vcd vorbis vpx wavpack wifi wma x264 xcb xine xml xorg xosd xrandr xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="multi asym rate dmix dshare dsnoop softvol plug extplug ioplug hooks empty route file" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard evdev joystick synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en he es" LIRC_DEVICES="serial sir dev atiusb" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa v4l radeon r600 vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

Reproducible: Always
Comment 1 DaggyStyle 2010-09-30 06:56:22 UTC
Created attachment 249049 [details]
build.log
Comment 2 Gilles Dartiguelongue gentoo-dev 2010-09-30 07:20:26 UTC
looks like a duplicate...
Comment 3 Per-Erik Westerberg 2010-09-30 08:08:27 UTC
Add a line to /etc/portage/package.use, "net-libs/libproxy -xulrunner" and it should link without problems.
Comment 4 Pacho Ramos gentoo-dev 2010-09-30 08:44:17 UTC
Created attachment 249054 [details, diff]
libproxy-xul-order.patch

This patch should fix your issue, but, before applying it, I would prefer to clarify why some people still need this while, for example, it works fine on my systems.

libproxy-0.4.2.ebuild states:
# Stop using xulrunner 1.8 when both are installed

But 1.9 is the only one in the tree since some time, I have also read bug #320437 without knowing where is exactly the problem on systems with only xulrunner-1.9
Comment 5 Mario Bachmann 2010-09-30 09:03:38 UTC
it does not work here with the patch in Comment  #4 :

[ebuild     U ] net-libs/libproxy-0.4.6 [0.4.2] USE="perl python xulrunner -gnome -kde -mono% -networkmanager -test% -vala -webkit (-debug%)" 0 kB [0=>1]

 * Applying libproxy-0.4.2-glibc212.patch ...  [ ok ]
 * Applying libproxy-xul-order.patch ...  [ ok ]

[100%] Building C object bindings/perl/src/CMakeFiles/PLlibproxy.dir/Libproxy.c.o
Linking C shared library ../../../perl/blib/arch/auto/Net/Libproxy.so
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lmozjs
collect2: ld returned 1 exit status

# emerge --info
Portage 2.1.9.12 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35.6n2 x86_64)
=================================================================
System uname: Linux-2.6.35.6n2-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-gentoo-2.0.1
Timestamp of tree: Thu, 30 Sep 2010 07:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -m3dnow -mmmx -msse -msse2 -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe -m3dnow -mmmx -msse -msse2 -msse3"
DISTDIR="/mnt/data/gentoo/distfiles"
FEATURES="assume-digests binpkg-logs distcc distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
GENTOO_MIRRORS="rsync://server/distfiles rsync://amd2000/distfiles ftp://mirror.qubenet.net/mirror/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://gentoo.imj.fr/pub/gentoo/ ftp://mirror.netcologne.de/gentoo/ ftp://mirror.cambrium.nl/pub/os/linux/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://de-mirror.org/distro/gentoo/ ftp://gentoo.tiscali.nl/pub/mirror/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://de-mirror.org/distro/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://mirror.muntinternet.net/pub/gentoo/ http://gentoo.tiscali.nl/ http://mirror.qubenet.net/mirror/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.netcologne.de/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j7"
PKGDIR="/mnt/data/gentoo/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage_overlay"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac acl acpi alsa amd64 berkdb bzip2 cairo cdparanoia cli cracklib crypt cups custom-cflags custom-cpuopts custom-cxxflags custom-optimization cxx dbus dri dvb dvd dvdr encode exif fam flac fortran gdbm glitz gnutls gpm hal iconv ilbc imagemagick imlib ipv6 jpeg kpathsea lame lcms libsamplerate lm_sensors lzo mad mmx mmxext modules mp3 mudflap multilib ncurses nls nptl nptlonly ogg openal opengl openmp pam pcre pdf perl png pppd python qt3support qt4 readline reflection sdl semantic-desktop session smp speex spell sse sse2 sse3 ssl svg sysfs tcpd theora threads tiff truetype unicode usb vorbis wmf x264 xcb xcomposite xine xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="alias auth_basic authn_file authz_groupfile authz_host authz_user autoindex deflate dir filter ident log_config logio mime status" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="dibusb-usb1" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv vesa nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Samuli Suominen gentoo-dev 2010-09-30 09:35:00 UTC
In the build.log, it's finding the correct one: mozilla-js

-- checking for one of the modules 'xulrunner-js;firefox-js;mozilla-js;seamonkey-js'
--   found mozilla-js, version 1.9.2.9

And local testing (this is all expected output):

$ gcc -lmozjs
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.1/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lmozjs
collect2: ld returned 1 exit status

$ gcc -lmozjs `pkg-config --libs mozilla-js`
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.1/../../../../lib64/crt1.o: In function `_start':
(.text+0x20): undefined reference to `main'
collect2: ld returned 1 exit status

So seems it's not about the ordering, like the previous issue was. It's more like an issue the required -L flags never get passed from libproxy's build system to the linker.

I suggest attaching `CMAKE_VERBOSE=1 emerge -v libproxy` build.log instead...
Comment 7 DaggyStyle 2010-09-30 16:02:22 UTC
Created attachment 249097 [details]
build.log with CMAKE_VERBOSE=1
Comment 8 Robert Cabrera 2010-09-30 17:48:19 UTC
I've got this exact same issue too on my ~x86 laptop
Comment 9 Samuli Suominen gentoo-dev 2010-09-30 18:08:10 UTC
+  30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> libproxy-0.4.6.ebuild,
+  +files/libproxy-0.4.6-mozjs-link_directory.patch:
+  Fix missing link directories for mozjs wrt #339216 by "DaggyStyle".
Comment 10 Samuli Suominen gentoo-dev 2010-09-30 21:30:04 UTC
*** Bug 339286 has been marked as a duplicate of this bug. ***
Comment 11 Nicolas Dufresne 2010-10-12 17:49:41 UTC
Created attachment 250377 [details, diff]
Corrrect fix to the reported issue

Please stop using the old patch and use the correct one instead. This issue as been fixed upstream and will be delivered in next version (0.4.7).
Comment 12 Lars Wendler (Polynomial-C) gentoo-dev 2010-10-12 18:19:45 UTC
Reopening because of comment #11
Comment 13 Samuli Suominen gentoo-dev 2010-10-28 09:20:23 UTC
+  28 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
+  files/libproxy-0.4.6-mozjs-link_directory.patch:
+  Update to upstream patch wrt #339216 by Nicolas Dufresne.
Comment 14 Frank Hsieh 2011-03-30 18:36:15 UTC
(In reply to comment #3)
> Add a line to /etc/portage/package.use, "net-libs/libproxy -xulrunner" and it
> should link without problems.

It works.
Comment 15 Samuli Suominen gentoo-dev 2011-03-30 21:09:25 UTC
(In reply to comment #14)
> (In reply to comment #3)
> > Add a line to /etc/portage/package.use, "net-libs/libproxy -xulrunner" and it
> > should link without problems.
> 
> It works.

Err... We use xulrunner:2.0 in ~arch now, and xulrunner:1.8 isn't in Portage anymore.   I'm not sure what you just "worked around", but it shouldn't have been this bug anymore...

Here's an idea:

# emerge --sync
# emerge -C xulrunner:1.8
Comment 16 Samuli Suominen gentoo-dev 2011-03-30 21:10:04 UTC
(In reply to comment #15)
> Err... We use xulrunner:2.0 in ~arch now, and xulrunner:1.8 isn't in Portage

Sorry, I meant xulrunner-2.0 not xulrunner:2.0 in above line.