Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339141 - www-client/chromium-6.0.472.62 does not respect gnome-keyring USE flag usage
Summary: www-client/chromium-6.0.472.62 does not respect gnome-keyring USE flag usage
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 339942 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-29 16:09 UTC by Anton Bolshakov
Modified: 2010-10-06 14:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Bolshakov 2010-09-29 16:09:37 UTC
Hi, I have a system with KDE vm only. The current stable version requires gnome-base/gnome-keyring regardless of the USE flag. Here is more details:


Calculating dependencies... done!
[ebuild  N    ] dev-libs/libtasn1-2.7  USE="-doc" 1,824 kB
[ebuild  N    ] dev-libs/eggdbus-0.6  USE="largefile -debug -doc -test" 783 kB
[ebuild  N    ] gnome-base/gnome-keyring-2.30.3  USE="pam -debug -doc -test" 1,556 kB
[ebuild  N    ] gnome-base/libgnome-keyring-2.30.1  USE="-debug -doc -test" 794 kB
[ebuild     U ] www-client/chromium-6.0.472.62 [5.0.375.127] USE="-cups% -gnome-keyring% (-plugins-symlink%*)" 121,065 kB

Please remove the flag or fix the ebuild.


emerge --info
Portage 2.2_rc67 (default/linux/x86/10.0/desktop/kde, gcc-4.4.3, glibc-2.11.2-r0, 2.6.35-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.35-gentoo-r4-i686-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 27 Sep 2010 14:30:19 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.6.3-r1, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA PUEL skype-eula AdobeFlash-10.1 @FSF-APPROVED"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.channelx.biz/"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/enlightenment /var/lib/layman/pentoo /usr/local/portage"
SYNC="rsync://gentoo.o0o.nu/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif firefox flac fortran gdbm gif gpm gtk hal iconv ipv6 java jpeg kde lcms libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png ppds pppd pulseaudio python qt3support qt4 readline reflection sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 x86 xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0 hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" LIRC_DEVICES="sir" NGINX_MODULES_HTTP="access charset empty_gif gzip limit_req limit_zone map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel vesa radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2010-09-29 16:14:37 UTC
Sadly, it does. It is a known bug that the build system required gnome-keyring to be installed at build time even if it is not used. After installing chromium, gnome-keyring could be removed.
Comment 2 Samuli Suominen gentoo-dev 2010-10-06 14:23:48 UTC
*** Bug 339942 has been marked as a duplicate of this bug. ***