Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 338976 - dev-libs/glib-2.24.1-r1: error: 'O_CLOEXEC' undeclared (first use in this function)
Summary: dev-libs/glib-2.24.1-r1: error: 'O_CLOEXEC' undeclared (first use in this fun...
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-28 02:28 UTC by Ed Davison
Modified: 2010-12-30 13:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (glib-build-log.txt,92.63 KB, text/plain)
2010-09-28 02:33 UTC, Ed Davison
Details
emerge -pqv output (glib-emerge-pqv.txt,212 bytes, text/plain)
2010-09-28 02:35 UTC, Ed Davison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Davison 2010-09-28 02:28:10 UTC
emerge of  dev-libs/glib-2.24.1-r1 fails with a compilation error complaining about O_CLOEXEC being undeclared.

Reproducible: Always

Steps to Reproduce:
1. emerge glib
2. failure
3.

Actual Results:  
failure to compile

Expected Results:  
successful emerge

Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.1.2, glibc-2.10.1-r1, 2.6.25-gentoo-r9 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.25-gentoo-r9-i686-Intel-R-_Pentium-R-_4_CPU_2.40GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 22 Sep 2010 08:00:18 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 1.3.7, 2.1.11
dev-lang/python:     2.4.4-r9, 2.5.2-r7, 2.6.4
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       3.3.6-r1, 3.4.6-r2, 4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.4.3-r4, 2.2.6b
sys-devel/make:      3.81
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mtune=pentium3 -O3 -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gentoo-gis /usr/portage/local/layman/rox /usr/portage/local/layman/masterdriverz /usr/portage/local/layman/gentopia /usr/portage/local/layman/sunrise /usr/portage/local/layman/ephemeral /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bitmap-fonts bzip2 cli cracklib crypt cups cxx dri dvd foomatic fortran gdbm gimpprint gnome gpm gtk iconv ipv6 jpeg kerberos krb4 ldap modules mudflap mysql ncurses nls nptl nptlonly openmp pam pcre pda perl png ppds pppd python readline reflection sasl session ssl sysfs tcpd tif tiff truetype-fonts type1-fonts unicode usb x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vga vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ed Davison 2010-09-28 02:33:47 UTC
Created attachment 248866 [details]
build log
Comment 2 Ed Davison 2010-09-28 02:35:11 UTC
Created attachment 248868 [details]
emerge -pqv output
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2010-10-01 01:28:04 UTC
fcntl.h from linux-headers define O_CLOEXEC... 

I suggest you check your system sanity, that e.g. /usr/include/asm-generic/fcntl.h is there and owned by linux-headers package. Perhaps clean /usr/local from cruft.

Moving to maintainers...
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-10-01 01:30:09 UTC
(In reply to comment #0)
> Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.1.2, glibc-2.10.1-r1,

Also upgrade to stable GCC, that's 4.4.3 thesedays. The libc looks also obsolete.
Comment 5 Gilles Dartiguelongue gentoo-dev 2010-10-02 11:58:26 UTC
Please get back to us.
Comment 6 Gilles Dartiguelongue gentoo-dev 2010-12-30 13:15:23 UTC
Due to lack of updated information in the last 2 weeks, there is no way we can further help you solve this problem. Thanks for reporting anyway.