Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 338323 - sys-apps/dbus-1.4.0: /usr/lib64/libdbus-1.la: No such file or directory
Summary: sys-apps/dbus-1.4.0: /usr/lib64/libdbus-1.la: No such file or directory
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-22 01:39 UTC by fkhp
Modified: 2010-09-22 16:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fkhp 2010-09-22 01:39:09 UTC
make[1]: Leaving directory `/var/tmp/paludis/media-sound-pulseaudio-0.9.21.2-r2/work/pulseaudio-0.9.21.2'
/bin/grep: /usr/lib64/libdbus-1.la: No such file or directory
/bin/sed: can't read /usr/lib64/libdbus-1.la: No such file or directory
libtool: link: `/usr/lib64/libdbus-1.la' is not a valid libtool archive
make[3]: *** [libpulse-browse.la] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in media-sound/pulseaudio-0.9.21.2-r2::gentoo:
!!! In default_src_compile at line 27
!!! emake failed


Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2010-09-22 06:07:12 UTC

*** This bug has been marked as a duplicate of bug 338023 ***
Comment 2 fkhp 2010-09-22 07:33:51 UTC
dbus-1.4 did not generate /usr/lib64/libdbus-1.la at all!
Comment 3 Marc-Antoine Perennou 2010-09-22 10:31:59 UTC
And that is intended. Did you follow the instructions in the other bug this one has been marked as duplicate?
Comment 4 fkhp 2010-09-22 10:58:07 UTC
(In reply to comment #3)
> And that is intended. Did you follow the instructions in the other bug this one
> has been marked as duplicate?
> 
YES! I DO!
lafilefixer --justfixit 

does not fix the proble of Missing libdbus-1.la 
Comment 5 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2010-09-22 11:59:28 UTC
Did you run revdep-rebuild?
Comment 6 fkhp 2010-09-22 12:59:49 UTC
(In reply to comment #5)
> Did you run revdep-rebuild?
> 

not, only ran lafilefixer --justfixit, the /usr/lib64/libdbus-1.la is still missing, but it is not a problem any more.  the package pulseaudio and metacity compiled and installed successfully. so missing /usr/lib64/libdbus-1.la is not the root cause.
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2010-09-22 16:44:47 UTC
libdus-1.la is expected to be missing as it's not installed anymore. The only problem was that some broken .la files (which are broken by definition) referred to it.