Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 337641 - Ebuild request: Photo Image Print System for Linux. Artisan 50,Epson Stylus Photo P50/T50/T59/T60 driver.
Summary: Ebuild request: Photo Image Print System for Linux. Artisan 50,Epson Stylus P...
Status: RESOLVED DUPLICATE of bug 106658
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://avasys.jp/eng/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-16 13:07 UTC by Yuego
Modified: 2010-09-19 11:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
first version. But it is compiled with an error (pips-common-3.8.0.ebuild,617 bytes, text/plain)
2010-09-16 13:12 UTC, Yuego
Details
That it was compiled with libpng-1.4 (pips-png-1.4.patch,453 bytes, patch)
2010-09-16 13:14 UTC, Yuego
Details | Diff
All works almost... (pips-common-3.8.0.ebuild,2.54 KB, text/plain)
2010-09-18 18:35 UTC, Yuego
Details
Init script (ekpd.initd,481 bytes, text/plain)
2010-09-18 18:36 UTC, Yuego
Details
New version (pips-common-3.8.0.ebuild,4.25 KB, text/plain)
2010-09-19 11:14 UTC, Yuego
Details
New init script (ekpd,469 bytes, text/plain)
2010-09-19 11:14 UTC, Yuego
Details
Metadata (metadata.xml,481 bytes, text/plain)
2010-09-19 11:14 UTC, Yuego
Details
Small path correction (paths.patch,1.38 KB, patch)
2010-09-19 11:15 UTC, Yuego
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuego 2010-09-16 13:07:45 UTC
Source code: http://linux.avasys.jp/drivers/pips/src/
Comment 1 Yuego 2010-09-16 13:12:09 UTC
Created attachment 247598 [details]
first version. But it is compiled with an error

x86_64-pc-linux-gnu-gcc -DLOCALE_PATH=\"/usr/share/locale\" -D_LPR_DIRECT -O2 -pipe -ftracer -fomit-frame-pointer -funroll-loops -march=native -mfpmath=sse -mmmx -msse -msse2 -msse3 -Wall -Wl,-O1 -Wl,--as-needed -o .libs/pips-filter debug.o pfatt.o pfimg.o pfpng.o pips-filter.o pngfilter.o rawfilter.o  -lstdc++ ../../libltdl/.libs/libltdlc.a -ldl /usr/lib64/libxml2.so -lz -lm ../../Core/libutils/.libs/libpips-utils.so -lpthread 
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlStrcmp'
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlDocGetRootElement'
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlNodeListGetString'
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlFreeDoc'
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlParseFile'
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlGetProp'
../../Core/libutils/.libs/libpips-utils.so: undefined reference to `xmlFree'
collect2: ld returned 1 exit status
make[3]: *** [pips-filter] ?????? 1
make[3]: Leaving directory `/var/tmp/portage/net-print/pips-common-3.8.0/work/pips-common-3.8.0/Core/pips-filter'
make[2]: *** [all-recursive] ?????? 1
make[2]: Leaving directory `/var/tmp/portage/net-print/pips-common-3.8.0/work/pips-common-3.8.0/Core'
make[1]: *** [all-recursive] ?????? 1
make[1]: Leaving directory `/var/tmp/portage/net-print/pips-common-3.8.0/work/pips-common-3.8.0'
make: *** [all] ?????? 2
emake failed
Comment 2 Yuego 2010-09-16 13:14:21 UTC
Created attachment 247600 [details, diff]
That it was compiled with libpng-1.4
Comment 3 Yuego 2010-09-16 13:18:57 UTC
However, if to unpack and compile manually, errors aren't present.

Compare (ebuild):

x86_64-pc-linux-gnu-gcc -DLOCALE_PATH=\"/usr/share/locale\" -D_LPR_DIRECT -O2 -pipe -ftracer -fomit-frame-pointer -funroll-loops -march=native -mfpmath=sse -mmmx -msse -msse2 -msse3 -Wall -Wl,-O1 -Wl,--as-needed -o .libs/pips-filter debug.o pfatt.o pfimg.o pfpng.o pips-filter.o pngfilter.o rawfilter.o -lstdc++ ../../libltdl/.libs/libltdlc.a -ldl /usr/lib64/libxml2.so -lz -lm ../../Core/libutils/.libs/libpips-utils.so -lpthread

Causes an error. 
Manual compilation:

x86_64-pc-linux-gnu-gcc -DLOCALE_PATH=\"/usr/share/locale\" -D_LPR_DIRECT -g -O2 -Wall -o .libs/pips-filter debug.o pfatt.o pfimg.o pfpng.o pips-filter.o pngfilter.o rawfilter.o -lstdc++ ../../libltdl/.libs/libltdlc.a -ldl /usr/lib64/libxml2.so -lz -lm ../../Core/libutils/.libs/libpips-utils.so -lpthread

Without errors
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2010-09-16 16:58:00 UTC
Have you seen bug #106658?
Comment 5 Yuego 2010-09-16 17:35:07 UTC
No, didn't see. Probably, it is necessary to try turboprint.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2010-09-16 18:15:08 UTC
Closing then as a dup. If you'd like to try to push it anyway, please consult printing first and reopen.

*** This bug has been marked as a duplicate of bug 106658 ***
Comment 7 Yuego 2010-09-18 18:35:21 UTC
Created attachment 247891 [details]
All works almost...

That it was not lost
Comment 8 Yuego 2010-09-18 18:36:11 UTC
Created attachment 247892 [details]
Init script

Place it in FILESDIR
Comment 9 Yuego 2010-09-19 11:14:08 UTC
Created attachment 247986 [details]
New version
Comment 10 Yuego 2010-09-19 11:14:35 UTC
Created attachment 247988 [details]
New init script
Comment 11 Yuego 2010-09-19 11:14:48 UTC
Created attachment 247989 [details]
Metadata
Comment 12 Yuego 2010-09-19 11:15:58 UTC
Created attachment 247991 [details, diff]
Small path correction