Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 337178 - sys-apps/portage-2.1.9.9: make backtracking mask the higher version in slot conflicts
Summary: sys-apps/portage-2.1.9.9: make backtracking mask the higher version in slot c...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 300071 335925
  Show dependency tree
 
Reported: 2010-09-13 22:56 UTC by niogic
Modified: 2010-10-09 11:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description niogic 2010-09-13 22:56:43 UTC
Bug #330735 told that freenet wasn't compatible with ant-core-1.8
Why was the restriction removed?

Anyways I face this problem right now, if I don't mask ant-core and ant-nodeps >=1.8

# emerge -avt freenet

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] net-p2p/freenet-0.7.5_p1275  USE="-freemail" 
[ebuild  N    ]  net-libs/NativeThread-0_pre20080330  3 kB
[ebuild  N    ]   net-p2p/freenet-0.7.5_p1275  USE="-freemail" 3,501 kB
[ebuild  N    ]    dev-java/java-service-wrapper-3.3.3  USE="-doc -source -test" 294 kB
[ebuild  N    ]     dev-java/ant-nodeps-1.8.1  5,740 kB
[ebuild  N    ]      dev-java/ant-core-1.8.1  USE="-doc -source" 0 kB
[ebuild  N    ]    dev-java/fec-1.0.4-r1  USE="-doc -source" 597 kB
[ebuild  N    ]     dev-java/concurrent-util-1.3.4-r1  USE="-doc -source" 134 kB
[ebuild  N    ]     dev-java/log4j-1.2.15-r2  USE="-doc -javamail -jms -jmx -source" 2,051 kB
[ebuild  N    ]    net-libs/nativebiginteger-0.6.4-r2  11 kB
[ebuild  N    ]    dev-java/db4o-jdk5-7.4  USE="-doc -source" 64 kB
[ebuild  N    ]    dev-java/lzmajio-0.94  USE="-doc -source" 20 kB
[ebuild  N    ]    dev-db/db-je-3.3.75  USE="-doc -source" 5,059 kB
[ebuild  N    ]    dev-java/mersennetwister-0_pre23765  USE="-doc -source" 5 kB
[ebuild  N    ]    dev-java/lzma-4.63  USE="-doc -source" 282 kB
[ebuild  N    ]    dev-java/db4o-jdk12-7.4  USE="-doc -source" 90 kB
[ebuild  N    ]     dev-java/db4o-jdk11-7.4  USE="-doc -source" 313 kB
[ebuild  N    ]      dev-java/ant-core-1.7.1-r5  USE="-doc -source" 6,835 kB
[ebuild  N    ]       dev-java/javatoolkit-0.3.0-r4  17 kB
[ebuild  N    ]        dev-python/pyxml-0.8.4-r2  USE="-doc -examples" 718 kB

Total: 19 packages (19 new), Size of downloads: 25,724 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-java/ant-core:0

  (dev-java/ant-core-1.8.1, ebuild scheduled for merge) pulled in by
    ~dev-java/ant-core-1.8.1 required by (dev-java/ant-nodeps-1.8.1, ebuild scheduled for merge)

  (dev-java/ant-core-1.7.1-r5, ebuild scheduled for merge) pulled in by
    =dev-java/ant-core-1.7 required by (net-p2p/freenet-0.7.5_p1275, ebuild scheduled for merge)
Comment 1 Jonáš Vidra 2010-09-14 07:18:30 UTC
(In reply to comment #0)
> Anyways I face this problem right now, if I don't mask ant-core and ant-nodeps
> >=1.8

This bug is also valid for net-p2p/freenet-0.7.5_p1277
Comment 2 Thomas Sachau gentoo-dev 2010-09-19 12:59:31 UTC
(In reply to comment #0)
> Bug #330735 told that freenet wasn't compatible with ant-core-1.8
> Why was the restriction removed?

It was not removed, as you can see in your own output: 

>   (dev-java/ant-core-1.7.1-r5, ebuild scheduled for merge) pulled in by
>     =dev-java/ant-core-1.7 required by (net-p2p/freenet-0.7.5_p1275, ebuild
> scheduled for merge)
> 

freenet still requires ant-core-1.7, but portage itself has problems with the dependency resolving, it pulls in the latest version for unspecified dependencies, which then collides with the requrested version for freenet.
Comment 3 Thomas Sachau gentoo-dev 2010-09-19 21:25:10 UTC
Suggested temporal workaround is either to mask the higher version (ant-core-1.8) or to try some newer portage version.

*** This bug has been marked as a duplicate of bug 1343 ***
Comment 4 Zac Medico gentoo-dev 2010-09-20 06:38:06 UTC
There's a fix in git to make portage handle this better:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=4bc78ab0b563697b98527eebcdfe474863383cf0
Comment 5 Zac Medico gentoo-dev 2010-09-22 03:44:30 UTC
This is fixed in 2.1.9.10 and 2.2_rc86.
Comment 6 Zac Medico gentoo-dev 2010-09-26 13:49:17 UTC
(In reply to comment #4)
> There's a fix in git to make portage handle this better:
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=4bc78ab0b563697b98527eebcdfe474863383cf0

A regression related to the above commit is fixed here:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=b8c77a67e0cf6348201dbdca8c58372ebb75b6f0
Comment 7 Zac Medico gentoo-dev 2010-09-27 05:44:01 UTC
The backtracking behavior change from this bug has been reverted here:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=4511c049634c26a3235f3c2d0e519ab01f950371

There's an alternative fix for review here:

http://github.com/few/fews-portage-branch/tree/backtracking
Comment 9 Zac Medico gentoo-dev 2010-09-28 01:17:44 UTC
This is fixed in 2.1.9.12 and 2.2_rc88.