Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336889 - emerge --deep --depclean should check for no-longer-needed dependencies when a package is specified
Summary: emerge --deep --depclean should check for no-longer-needed dependencies when ...
Status: RESOLVED DUPLICATE of bug 591960
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-12 05:53 UTC by Ben Anderson
Modified: 2016-10-21 05:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Anderson 2010-09-12 05:53:44 UTC
There should be a way to remove a package and all its now-unnecessary dependencies with a single command. First idea that comes to mind:

emerge --depclean --deep <package> removes not only the specified package, but any dependencies that are not dependencies of another package. (And those dependencies' dependencies, and so on)

It probably should come with the warning about link-level dependencies.
Comment 1 Agostino Sarubbo gentoo-dev 2010-09-12 09:37:09 UTC
(In reply to comment #0)
> There should be a way to remove a package and all its now-unnecessary
> dependencies with a single command. First idea that comes to mind:
> 
> emerge --depclean --deep <package> removes not only the specified package, but
> any dependencies that are not dependencies of another package. (And those
> dependencies' dependencies, and so on)
> 
> It probably should come with the warning about link-level dependencies.
> 

emerge -Cav <packege>;emerge -cav           ??
Comment 2 Ben Anderson 2010-09-15 01:43:12 UTC
Not the same thing, really. There's a lot of things that can make --depclean (world) decide to not work; Many times I just want to quickly get rid of some things I just installed and the dependencies they pulled onto my system, without fixing the inevitable inconsistencies that make a full-on depclean stop.
Comment 3 Zac Medico gentoo-dev 2016-10-21 05:44:58 UTC

*** This bug has been marked as a duplicate of bug 591960 ***