Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336808 - x11-libs/cairo-1.10.0-r3: gvim hangs during startup
Summary: x11-libs/cairo-1.10.0-r3: gvim hangs during startup
Status: RESOLVED DUPLICATE of bug 336837
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2010-09-11 12:15 UTC by Hans Nieser
Modified: 2010-09-11 16:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Hans Nieser 2010-09-11 12:15:48 UTC
After upgrading to cairo-1.10.0-r3, gvim refuses to start up. Instead, it just hangs: if I try to launch it from an xterm nothing is printed and no window appears, and I can't get back to my bash prompt (CTRL+C does nothing) unless I 'killall -KILL gvim'. Same hang occurs when gvim is launched from a launcher on my GNOME panel.

Strangely enough when I run 'strace gvim' it starts up normally. Downgrading cairo back to 1.8.10 makes the problem go away entirely.

Reproducible: Always

Steps to Reproduce:
1. Upgrade to cairo-1.10.0-r3, have gvim-7.3 installed
2. Open xterm
3. run 'gvim'

Actual Results:  
Nothing happens, bash prompt doesn't reappear :/

Expected Results:  
The gvim window should've appeared

$ emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r5 x86_64)
System uname: Linux-2.6.35-gentoo-r5-x86_64-AMD_Athlon-tm-_Dual_Core_Processor_5050e-with-gentoo-2.0.1
Timestamp of tree: Fri, 10 Sep 2010 16:00:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=athlon64 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/portage /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -pipe"
FEATURES="assume-digests distlocks fixlafiles fixpackages news parallel-fetch protect-owned sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/crossdev-overlay /var/lib/layman/sunrise /usr/local/aphax-overlay"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 audacious automount avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cjk cli consolekit cracklib crypt cups cxx dbus dirac divx djvu dri dts dv dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran fuse gdbm gif gnome gnome-keyring gpm gstreamer gtk gtk2 hal iconv ieee1394 ipv6 jpeg jpeg2k lcms ldap libnotify mad matroska mikmod mmx mmxext mng modules mono moonlight mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nntp nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline reflection samba sdl session spell sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff truetype unicode usb vcd vdpau vim-syntax vorbis wmf wmp wxwindows x264 xcb xinerama xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa radeon radeonhd nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Andreas Proteus 2010-09-11 15:17:14 UTC
I think it nothing to do with cairo but with the new  nvidia-drivers-260.19.04
see #336837 
Comment 2 Hans Nieser 2010-09-11 16:23:15 UTC
(In reply to comment #1)
> I think it nothing to do with cairo but with the new  nvidia-drivers-260.19.04
> see #336837 

That wouldn't explain why downgrading cairo fixes the issue for me though, but I guess there is some really weird interaction going on here.
Comment 3 Hans Nieser 2010-09-11 16:43:43 UTC
Just tried downgrading nvidia-drivers and that also makes gvim start normally again, so I guess somehow latest nvidia-drivers and cairo aren't playing nice?

Anyway, no point in having two bugs open for this, so I'll be easy and mark mine as the dup. 

*** This bug has been marked as a duplicate of bug 336837 ***