Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336677 - media-gfx/digikam-1.4.0 does not find qsqlite
Summary: media-gfx/digikam-1.4.0 does not find qsqlite
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
: 336680 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-10 03:06 UTC by barton
Modified: 2010-09-18 20:21 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description barton 2010-09-10 03:06:37 UTC
Unable to open digikam-1.4.0, run time error.

Reproducible: Always

Steps to Reproduce:
1.open digikam
2.
3.

Actual Results:  
Run-time Qt4 SQLite or MySQL database plugin is not available - please install it.
Database plugins installed on your computer are listed below:qsqlite

Expected Results:  
Digikam opens

Portage 2.2_rc67 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.1, glibc-2.12.1-r1, 2.6.35-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6750_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 09 Sep 2010 17:30:22 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.5.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ rsync://gentoo.chem.wisc.edu/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ http://mirrors.cs.wmich.edu/gentoo http://www.cyberuse.com/gentoo/ http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.hoobly.com/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://gentoo.netnitco.net http://gentoo.osuosl.org/ rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://gentoo.llarian.net/pub/gentoo http://gentoo.llarian.net/ ftp://gentoo.mirrors.tds.net/gentoo rsync://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.tds.net/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.lug.udel.edu/pub/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ ftp://mirror.its.uidaho.edu/gentoo/ http://mirror.its.uidaho.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ rsync://gentoo.cs.uni.edu/gentoo-distfiles http://gentoo.cs.uni.edu/ http://mirror.usu.edu/mirrors/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org"
INSTALL_MASK="/etc/portage/package.mask/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/qting-edge /var/lib/layman/kde /opt/portage/gfxboot_overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi additions aio alsa amd64 archive aspell ass audacious audio automount autotrace bazaar bigtiff bluetooth bzip2 cairo cdda cddax cddb cdio cdparanoia cdr cdrdao chm cli clucene cmake consolekit corefonts cpio css cue cups curl cvs cxx dbus desktopglobe device-mapper djvu dvd dvdarchive dvdchapjump dvdnav dvdr ebook eigen emerald emovix enca enchant encode eselect exceptions exif expat extras faac faad facedetect fame fastcgi fbcon fbcondecor fbdev fbsplash ffmpeg firefox3 flac fontconfig foomaticdb fortran fts3 fuse gallium gensplash gif git glsl gmp gphoto2 gpm graphite graphviz gs gsf gzip hal hpcups hpijs iconv id3 id3tag ieee1394 imagemagick imlib infowidget jbig joystick jpeg jpeg2k kdcraw kde kipi lame laptop lcdfilter lcms lensfun libass libcaca libextractor libffi libmms libnotify lm_sensors lua lua-cairo lua-imlib lucene lzma lzo mad matroska mdi mercurial mjpeg mmx mmxext mng motif mp3 mp4 mpeg mplayer mudflap multilib multimedia multipath musepack nautilus ncurses network networkmanager newmousefocus nforce2 nls nokia normalize nptl nptlonly nsplugin ogg openexr opengl openmp optimisememory optimized-qmake osdmenu pam pango parport pccts pcf pdf plasma plugins-symlink pm-utils png pnm policykit postproc ppds ps psf pstoedit python python3 qalculate qscintilla qt-dbus qt-faststart qt-webkit qt3support qt4 quicktime qwt raptor rar raw raw-font-data rdesktop rdp rdpusb readline redeyes ruby ruby-bindings samba samba4 sasl scanner schroedinger scrobbler sdl sdl-image sdl-sound sdlaudio search sensord shutdown sip skins slit slp smbclient smbkrb5passwd smbsharemodes sndfile snmp spell splash sql sqlite sqlite3 srt sse sse2 sse3 ssl ssse3 static-ppds subtitles subversion svg swat symlink szip taglib tcl tcmalloc tga tgif theora threads threadsafe thumbnail thumbnails tiff toolame toolbar transcode truetype twolame type3 udev udev-acl unicode unsupported upnp usb uswsusp utils vaapi vcd vcdinfo vcdx vdpau video virtuoso vorbis wav wavpack webdav-neon webphoto wifi windeco wma wma-fixed wmf x264 x86emu xanim xattr xcb xcf xcomposite xft xine xinerama xinetd xls xml xmlpatterns xmlreader xmlrpc xmlwriter xmp xorg xorgmodule xosd xpdf-headers xpm xrandr xrender xterm-color xulrunner xv xvid xvmc yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shmasym  dmix empty iec958 ioplug mmap_emul plug softvol asym shm alisp" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" RUBY_TARGETS="ruby18" SANE_BACKENDS="hpaio gphoto2 dll hp canon" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2010-09-10 05:37:06 UTC
*** Bug 336680 has been marked as a duplicate of this bug. ***
Comment 2 Andreas K. Hüttel gentoo-dev 2010-09-15 20:59:44 UTC
Could you please paste the output of 

equery uses qt-sql

Thanks!
Comment 3 barton 2010-09-15 21:52:55 UTC
[ Legend : U - flag is set in make.conf       ]
[        : I - package is installed with flag ]
[ Colors : set, unset                         ]
 * Found these USE flags for x11-libs/qt-sql-4.6.3-r2:
 U I
 - - aqua       : Include support for the Aqua / Carbon GUI
 - - debug      : Enable extra debug codepaths, like asserts and extra output.
                  If you want to get meaningful backtraces see
                  http://www.gentoo.org/proj/en/qa/backtraces.xml
 + + exceptions : Add support for exceptions - like catching them inside the
                  event loop (recommended by Nokia)
 - - firebird   : Adds support for the Firebird relational database
 - - freetds    : Adds support for the TDS protocol to connect to MSSQL/Sybase
                  databases
 + + iconv      : Enable support for the iconv character set conversion library
 - - mysql      : Adds mySQL Database support
 - - odbc       : Adds ODBC Support (Open DataBase Connectivity)
 - - pch        : Enable precompiled header support for faster compilation at
                  the expense of disk space and memory (>=sys-devel/gcc-3.4
                  only)
 - - postgres   : Adds support for the postgresql database
 + + qt3support : Enable the Qt3Support libraries for Qt4
 + + sqlite     : Adds support for sqlite - embedded sql database
Comment 4 Andreas K. Hüttel gentoo-dev 2010-09-16 20:54:28 UTC
I bumped the version to the tree anyway, but this needs some more investigation (-> weekend). The only obvious difference that I see is that I have mysql useflag set globally. 
Comment 5 barton 2010-09-17 02:12:16 UTC
Thank-you for your help.  I added mysql as a global use flag, that did the trick. I am now able to open digikam without any problems.
Comment 6 Andreas K. Hüttel gentoo-dev 2010-09-17 05:24:34 UTC
Great... we have a workaround. It's not really fixed yet, though. :)
Comment 7 Nikolaj Šujskij 2010-09-17 08:16:02 UTC
Does Digikam 1.4.0 strictly depend on MySQL now? I didn't see anything about that in official changelog, but this bug suggests that there're issues with it. For me it even can't be emerged: configure fails (I haven't decided wherether to open bug or not yet).
Comment 8 Andreas K. Hüttel gentoo-dev 2010-09-17 08:24:09 UTC
(In reply to comment #7)
> Does Digikam 1.4.0 strictly depend on MySQL now? I didn't see anything about
> that in official changelog, but this bug suggests that there're issues with it.

I dont know yet. 

> For me it even can't be emerged: configure fails (I haven't decided wherether
> to open bug or not yet).
 
Please do open a separate bug.
Comment 9 Andreas K. Hüttel gentoo-dev 2010-09-18 20:21:08 UTC
The crazy thing is, it needs both backends present, i.e. x11-libs/qt-sql[mysql,sqlite]. Fixed. Arrgh.

http://blog.akhuettel.de/2010/09/database-mania.html