Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336371 - Stabilize =sys-devel/llvm-2.8-r1
Summary: Stabilize =sys-devel/llvm-2.8-r1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 337467
Blocks: 335399 344827
  Show dependency tree
 
Reported: 2010-09-07 17:49 UTC by Pacho Ramos
Modified: 2011-02-14 11:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2010-09-07 17:49:12 UTC
Would be nice to be sure it's ready to go stable and tobe included in emul set (bug #335399)

Thanks

Reproducible: Always
Comment 1 Bernard Cafarelli gentoo-dev 2010-09-09 08:14:07 UTC
I still have to fix support for "other" arches (keywording bug open), but for x86/amd64/ppc, it works fine so far and no open bugs. Plus it will make djc happy ;)

So arches please test and mark stable =sys-devel/llvm-2.7. It has a nice test suite by itself but can also be tested with live mesa, clang compiler or lightspark flash plugin

Comment 2 David Abbott gentoo-dev 2010-09-10 21:41:18 UTC
All good x86.
Comment 3 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-09-11 18:55:30 UTC
This is a first-time stabilization. Please fix the following QA issue:

 * QA Notice: The following shared libraries lack a SONAME
 * /usr/lib/libEnhancedDisassembly.so
 * /usr/lib/libLLVMHello.so
 * /usr/lib/libLTO.so
 * /usr/lib/libprofile_rt.so
Comment 4 Joe Jezak (RETIRED) gentoo-dev 2010-09-13 14:05:48 UTC
Do these QA issues hold up stabling?
Comment 5 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-09-13 23:41:07 UTC
(In reply to comment #4)
> Do these QA issues hold up stabling?

I think they should. It's a first-time stabilization. If we don't fix it now, people will start jumping on the "it's not a regression" train and never fix it.
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2010-09-14 09:21:48 UTC
This is NOT always true

http://blog.flameeyes.eu/2010/04/06/important-names-pointless-names
Comment 7 Bernard Cafarelli gentoo-dev 2010-09-18 16:27:49 UTC
I fixed lib install path in 2.7-r1, but as this changes a few things, let's wait and see how this version behaves before stabling. Sorry for the noise, arches
Comment 8 Bernard Cafarelli gentoo-dev 2010-11-09 15:37:02 UTC
Ok let's try this again, with 2.8  this time. Shared libraries are in /usr/$(get_libdir)/llvm now, one month without bugs since 2.8-r1

So arches please test and mark stable =sys-devel/llvm-2.8-r1. Thanks!
Comment 9 Agostino Sarubbo gentoo-dev 2010-11-09 16:16:28 UTC
it seems to have no problem on amd64
Comment 10 Thomas Kahle (RETIRED) gentoo-dev 2010-11-09 21:19:56 UTC
=dev-libs/udis86-1.7 is needed too!

x86 stable for both.
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2010-11-11 17:31:25 UTC
amd64 done. Thanks Agostino
Comment 12 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2011-02-14 11:19:40 UTC
ppc done, last arch closing