Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336146 - xfce-base/xfce4-session-4.7.0 configure appears broken
Summary: xfce-base/xfce4-session-4.7.0 configure appears broken
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: XFCE Team
URL: http://bugzilla.xfce.org/show_bug.cgi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-06 01:52 UTC by Matthew Turnbull
Modified: 2011-05-01 12:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
configure.in patch (xfce4-session-4.7.0-configure.patch,2.27 KB, text/plain)
2010-09-06 01:52 UTC, Matthew Turnbull
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Turnbull 2010-09-06 01:52:14 UTC
I have found that when building xfce4-session-4.7.0 with consolekit enabled and policykit disabled, the configure script results in consolekit disabled and policykit enabled.

After poking around in the configure.in, I found 2 problems:

1) There's a typo in the policykit test ("x$ac_cv_enable_polkit" = !"xyes" should be "x$ac_cv_enable_polkit" != "xyes").

2) The AC_ARG_ENABLE macros and following tests use a custom variable name, which is undefined when the configure flag is present.

Reproducible: Always

Steps to Reproduce:
Comment 1 Matthew Turnbull 2010-09-06 01:52:51 UTC
Created attachment 246208 [details]
configure.in patch
Comment 2 Samuli Suominen gentoo-dev 2010-09-06 12:15:10 UTC
Patch looks good to me, can you please open a bug at http://bugs.xfce.org/ too and link the bug in the URL field here?
Comment 3 Matthew Turnbull 2010-09-06 14:25:07 UTC
Upstream bug has been filed.
Comment 4 Samuli Suominen gentoo-dev 2010-09-06 17:26:42 UTC
Actually, none of these are required at build-time at all... But simply detected from the dbus service at runtime. There's really no reason to disable any of them far as I can see.

But of course this bug should get fixed, so thanks for opening the upstream ticket!

+  06 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+  xfce4-session-4.7.0.ebuild:
+  Change gnome-keyring depend to libgnome-keyring. Remove USE flags for
+  consolekit, policykit and udev because they are not required at build-time
+  wrt #336146 by Matthew Turnbull.
Comment 5 Samuli Suominen gentoo-dev 2010-09-30 16:09:26 UTC
http://git.xfce.org/xfce/xfce4-session/commit/?id=d21e21188c3ed7ab59d7924b9f63f2ab52cc182d

:)

I'll look at xfce4-session-4.7.1 again if it's worth to bring back any of these USE flags. Thanks a lot again.
Comment 6 Samuli Suominen gentoo-dev 2011-01-05 23:57:04 UTC
restored the USE flags now for 4.7.3 since upstream took your patch, thanks again.
Comment 7 Samuli Suominen gentoo-dev 2011-05-01 12:36:17 UTC
Fixed in tree by 4.8.x releases