Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 33611 - k3b does not emerge: sandbox access violation
Summary: k3b does not emerge: sandbox access violation
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All All
: High major (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2003-11-16 08:48 UTC by Dan Noe
Modified: 2004-02-11 19:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Dan Noe 2003-11-16 08:48:39 UTC
app-cdr/k3b does not emerge correctly.  It compiles, then end the compilation with system speaker beeps and this message:

ialog.o k3binteractiondialog.o k3bjobprogresssystemtray.o k3bsystemproblemdialog.o k3bdevicecombobox.o k3binterface.o k3bprojectinterface.o k3binterface_skel.o k3bprojectinterface_skel.o ./data/ ./mixed/ ./vcd/ ./movix/ ./cdinfo/ ./audio/ ./option/ ./rip/ ./rip/songdb/ ./tools/ ./tools/kostore/ ./cdcopy/ ./videoEncoding/ ./plugin/ -lvorbisfile -lvorbis -logg -lartskde -lkio -lkparts ./core/  
make[3]: Leaving directory `/var/tmp/portage/k3b-0.9/work/k3b-0.9/src'
make[2]: Leaving directory `/var/tmp/portage/k3b-0.9/work/k3b-0.9/src'
make[2]: Entering directory `/var/tmp/portage/k3b-0.9/work/k3b-0.9'
make[2]: Leaving directory `/var/tmp/portage/k3b-0.9/work/k3b-0.9'
make[1]: Leaving directory `/var/tmp/portage/k3b-0.9/work/k3b-0.9'
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-k3b-0.9-22974.log"

mkdir:     /root/.kde
mkdir:     /root/.kde
mkdir:     /root/.kde
mkdir:     /root/.kde
mkdir:     /root/.kde
mkdir:     /root/.kde
Comment 1 friggos 2003-12-18 11:47:31 UTC
it has to do with sandbox support
disable it using the command:::::
ACCEPT_KEYWORDS="~x86" FEATURES="-sandbox" emerge k3b

Comment 2 Heinrich Wendel (RETIRED) gentoo-dev 2004-01-27 06:01:58 UTC
please try out 0.10
Comment 3 Heinrich Wendel (RETIRED) gentoo-dev 2004-02-09 12:24:28 UTC
can you still reproduce that with 0.10/0.11?
Comment 4 Dan Noe 2004-02-11 19:52:04 UTC
I don't know -- the problem was corrected after actually logging in as root and running emerge instead of using sudo.

I'm not sure if the new version fixed it, but I've updated it in sudo and it worked fine.

Several other KDE packages had this problem: they seem to be fixed at this point as well.